Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-6534

Same Billing Address generates an error

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Release Branch 12.04, Release Branch 13.07, Release Branch 14.12, Trunk
    • Fix Version/s: 14.12.01, 12.04.06, 13.07.03, 16.11.01
    • Component/s: ecommerce
    • Labels:
      None

      Description

      When opting for a 'Single Use EFT Account in the checkout process of e-commerce and opting for 'Billing address is the same as delivery address' following error is generated:

      
      FreeMarker template error: Java method "org.ofbiz.widget.renderer.ScreenRenderer.render(String)" threw an exception when invoked on org.ofbiz.widget.renderer.ScreenRenderer object "org.ofbiz.widget.renderer.ScreenRenderer@475a9aec"; see cause exception in the Java stack trace. ---- FTL stack trace ("~" means nesting-related): - Failed at: ${screens.render(anonymoustrailScreen)} [in template "component://ecommerce/webapp/ecommerce/order/billsettings.ftl" at line 40, column 17] ---- Java stack trace (for programmers): ---- freemarker.core._TemplateModelException: [... Exception message was already printed; see it above ...] at freemarker.ext.beans._MethodUtil.newInvocationTemplateModelException(_MethodUtil.java:311) at freemarker.ext.beans._MethodUtil.newInvocationTemplateModelException(_MethodUtil.java:284) at freemarker.ext.beans.OverloadedMethodsModel.exec(OverloadedMethodsModel.java:68) at freemarker.core.MethodCall._eval(MethodCall.java:62) at freemarker.core.Expression.eval(Expression.java:78) at freemarker.core.Expression.evalAndCoerceToString(Expression.java:82) at freemarker.core.DollarVariable.accept(DollarVariable.java:40) at freemarker.core.Environment.visit(Environment.java:312) at freemarker.core.MixedContent.accept(MixedContent.java:62) at freemarker.core.Environment.visitByHiddingParent(Environment.java:333) at freemarker.core.ConditionalBlock.accept(ConditionalBlock.java:48) at freemarker.core.Environment.visit(Environment.java:312) at freemarker.core.MixedContent.accept(MixedContent.java:62) at freemarker.core.Environment.visit(Environment.java:312) at freemarker.core.Environment.process(Environment.java:290) at org.ofbiz.base.util.template.FreeMarkerWorker.renderTemplate(FreeMarkerWorker.java:257) at org.ofbiz.widget.model.HtmlWidget.renderHtmlTemplate(HtmlWidget.java:167) at org.ofbiz.widget.model.HtmlWidget$HtmlTemplate.renderWidgetString(HtmlWidget.java:216) at org.ofbiz.widget.model.HtmlWidget.renderWidgetString(HtmlWidget.java:140) at org.ofbiz.widget.model.ModelScreenWidget$PlatformSpecific.renderWidgetString(ModelScreenWidget.java:1319) at org.ofbiz.widget.model.ModelScreenWidget.renderSubWidgetsString(ModelScreenWidget.java:98) at org.ofbiz.widget.model.ModelScreenWidget$DecoratorSection.renderWidgetString(ModelScreenWidget.java:906) at org.ofbiz.widget.model.ModelScreenWidget$SectionsRenderer.render(ModelScreenWidget.java:127) at org.ofbiz.widget.model.ModelScreenWidget$DecoratorSectionInclude.renderWidgetString(ModelScreenWidget.java:943) at org.ofbiz.widget.model.ModelScreenWidget.renderSubWidgetsString(ModelScreenWidget.java:98) at org.ofbiz.widget.model.ModelScreenWidget$Container.renderWidgetString(ModelScreenWidget.java:459) at org.ofbiz.widget.model.ModelScreenWidget.renderSubWidgetsString(ModelScreenWidget.java:98) at org.ofbiz.widget.model.ModelScreenWidget$Container.renderWidgetString(ModelScreenWidget.java:459) at org.ofbiz.widget.model.ModelScreenWidget.renderSubWidgetsString(ModelScreenWidget.java:98) at org.ofbiz.widget.model.ModelScreenWidget$Section.renderWidgetString(ModelScreenWidget.java:280) at org.ofbiz.widget.model.ModelScreenWidget.renderSubWidgetsString(ModelScreenWidget.java:98) at org.ofbiz.widget.model.ModelScreenWidget$Section.renderWidgetString(ModelScreenWidget.java:280) at org.ofbiz.widget.model.ModelScreen.renderScreenString(ModelScreen.java:164) at org.ofbiz.widget.model.ScreenFactory.renderReferencedScreen(ScreenFactory.java:211) at org.ofbiz.widget.model.ModelScreenWidget$DecoratorScreen.renderWidgetString(ModelScreenWidget.java:860) at org.ofbiz.widget.model.ModelScreenWidget.renderSubWidgetsString(ModelScreenWidget.java:98) at org.ofbiz.widget.model.ModelScreenWidget$Section.renderWidgetString(ModelScreenWidget.java:280) at org.ofbiz.widget.model.ModelScreen.renderScreenString(ModelScreen.java:164) at org.ofbiz.widget.renderer.ScreenRenderer.render(ScreenRenderer.java:136) at org.ofbiz.widget.renderer.ScreenRenderer.render(ScreenRenderer.java:98) at org.ofbiz.widget.renderer.macro.MacroScreenViewHandler.render(MacroScreenViewHandler.java:157) at org.ofbiz.webapp.control.RequestHandler.renderView(RequestHandler.java:988) at org.ofbiz.webapp.control.RequestHandler.doRequest(RequestHandler.java:675) at org.ofbiz.webapp.control.ControlServlet.doGet(ControlServlet.java:213) at javax.servlet.http.HttpServlet.service(HttpServlet.java:620) at javax.servlet.http.HttpServlet.service(HttpServlet.java:727) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:303) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208) at org.ofbiz.webapp.control.ContextFilter.doFilter(ContextFilter.java:325) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208) at org.ofbiz.content.content.ContentUrlFilter.doFilter(ContentUrlFilter.java:104) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208) at org.ofbiz.product.category.CatalogUrlFilter.doFilter(CatalogUrlFilter.java:338) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208) at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:220) at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:122) at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:504) at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:170) at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:103) at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:116) at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:950) at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:421) at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1074) at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:611) at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:316) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61) at java.lang.Thread.run(Thread.java:745) Caused by: org.ofbiz.widget.renderer.ScreenRenderException: Error rendering screen [component://ecommerce/widget/OrderScreens.xml#anonymoustrail]: java.lang.IllegalArgumentException: Error running script at location [component://ecommerce/webapp/ecommerce/WEB-INF/actions/order/AnonymousTrail.groovy]: groovy.lang.MissingPropertyException: No such property: parameter for class: AnonymousTrail (Error running script at location [component://ecommerce/webapp/ecommerce/WEB-INF/actions/order/AnonymousTrail.groovy]: groovy.lang.MissingPropertyException: No such property: parameter for class: AnonymousTrail) at org.ofbiz.widget.model.ModelScreen.renderScreenString(ModelScreen.java:179) at org.ofbiz.widget.renderer.ScreenRenderer.render(ScreenRenderer.java:136) at org.ofbiz.widget.renderer.ScreenRenderer.render(ScreenRenderer.java:98) at sun.reflect.GeneratedMethodAccessor362.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:606) at freemarker.ext.beans.BeansWrapper.invokeMethod(BeansWrapper.java:1458) at freemarker.ext.beans.ReflectionCallableMemberDescriptor.invokeMethod(ReflectionCallableMemberDescriptor.java:52) at freemarker.ext.beans.MemberAndArguments.invokeMethod(MemberAndArguments.java:48) at freemarker.ext.beans.OverloadedMethodsModel.exec(OverloadedMethodsModel.java:62) ... 69 more Caused by: java.lang.IllegalArgumentException: Error running script at location [component://ecommerce/webapp/ecommerce/WEB-INF/actions/order/AnonymousTrail.groovy]: groovy.lang.MissingPropertyException: No such property: parameter for class: AnonymousTrail at org.ofbiz.base.util.ScriptUtil.executeScript(ScriptUtil.java:348) at org.ofbiz.base.util.ScriptUtil.executeScript(ScriptUtil.java:324) at org.ofbiz.widget.model.AbstractModelAction$Script.runAction(AbstractModelAction.java:632) at org.ofbiz.widget.model.AbstractModelAction.runSubActions(AbstractModelAction.java:141) at org.ofbiz.widget.model.ModelScreenWidget$Section.renderWidgetString(ModelScreenWidget.java:273) at org.ofbiz.widget.model.ModelScreen.renderScreenString(ModelScreen.java:164) ... 78 more Caused by: groovy.lang.MissingPropertyException: No such property: parameter for class: AnonymousTrail at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.unwrap(ScriptBytecodeAdapter.java:50) at org.codehaus.groovy.runtime.callsite.PogoGetPropertySite.getProperty(PogoGetPropertySite.java:49) at org.codehaus.groovy.runtime.callsite.AbstractCallSite.callGroovyObjectGetProperty(AbstractCallSite.java:231) at AnonymousTrail.run(AnonymousTrail.groovy:37) at org.ofbiz.base.util.GroovyUtil.runScriptAtLocation(GroovyUtil.java:173) at org.ofbiz.base.util.ScriptUtil.executeScript(ScriptUtil.java:342) ... 83 more
      Payment Information
      
      
      1. OFBIZ-6534.patch
        4 kB
        Mridul Pathak

        Activity

        mridul.pathak Mridul Pathak added a comment -

        Found another error while fixing this bug on continue button,

        [java] 2015-11-21 19:43:23,192 |http-bio-8443-exec-5 |RequestHandler |I| [RequestHandler.doRequest]: Response is a chained request. sessionId=B20C140B44731912798F4138C952A773.jvm1
        [java] 2015-11-21 19:43:23,192 |http-bio-8443-exec-5 |RequestHandler |I| [RequestHandler]: Chain in place: requestUri=processPaymentSettings overrideViewUri=null sessionId=B20C140B44731912798F4138C952A773.jvm1
        [java] 2015-11-21 19:43:23,192 |http-bio-8443-exec-5 |GroovyEventHandler |W| Error running event :
        [java] org.ofbiz.base.util.GeneralException: Error loading Groovy script at []: (Script not found at location [])
        [java] at org.ofbiz.base.util.GroovyUtil.getScriptClassFromLocation(GroovyUtil.java:150) ~[ofbiz-base.jar:?]
        [java] at org.ofbiz.webapp.event.GroovyEventHandler.invoke(GroovyEventHandler.java:93) [ofbiz-webapp.jar:?]
        [java] at org.ofbiz.webapp.control.RequestHandler.runEvent(RequestHandler.java:759) [ofbiz-webapp.jar:?]
        [java] at org.ofbiz.webapp.control.RequestHandler.doRequest(RequestHandler.java:476) [ofbiz-webapp.jar:?]
        [java] at org.ofbiz.webapp.control.RequestHandler.doRequest(RequestHandler.java:630) [ofbiz-webapp.jar:?]
        [java] at org.ofbiz.webapp.control.ControlServlet.doGet(ControlServlet.java:213) [ofbiz-webapp.jar:?]
        [java] at org.ofbiz.webapp.control.ControlServlet.doPost(ControlServlet.java:88) [ofbiz-webapp.jar:?]
        [java] at javax.servlet.http.HttpServlet.service(HttpServlet.java:646) [servlet-api-3.0.jar:?]
        [java] at javax.servlet.http.HttpServlet.service(HttpServlet.java:727) [servlet-api-3.0.jar:?]

        mridul.pathak Mridul Pathak added a comment -

        Patch to fix both the issues.

        mridul.pathak Mridul Pathak added a comment -

        Fixed in,

        • Trunk r1715531
        • 14.12 r1715533
        • 13.07 r1715534
        • 12.04 r1715535

        Also applied relevant fix from trunk r1704227 to the branches.

        mridul.pathak Mridul Pathak added a comment -

        Thanks Pierre for reporting the issue.


          People

          • Assignee:
            mridul.pathak Mridul Pathak
            Reporter:
            pfm.smits Pierre Smits
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development