Details

    • Type: Task
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: Release Branch 14.12, Trunk, 13.07.01
    • Fix Version/s: 14.12.01, 13.07.03, 16.11.01
    • Component/s: framework
    • Labels:
      None

      Activity

      jacques.le.roux Jacques Le Roux added a comment -

      Done in

      trunk r1679702
      R14.12 r1679703
      R13.07 r1679704

      deepak.dixit Deepak Dixit added a comment -

      Hi Jacques,

      After upgrade to 2.3 ofbiz throwing following exception:

      Caused by: java.lang.ClassCastException: org.apache.logging.slf4j.SLF4JLoggerContext cannot be cast to org.apache.logging.log4j.core.LoggerContext

      rongnk Rong Nguyen added a comment -

      I have the same issue when executing 'load-demo':

      load-demo:
      [java] Start.java using configuration file org/ofbiz/base/start/load-data.properties
      [java] Set OFBIZ_HOME to - /run/media/rongnguyen/work/OFBiz/source/ofbiz
      [java] Admin socket not configured; set to port 0
      [java] SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
      [java] SLF4J: Defaulting to no-operation (NOP) logger implementation
      [java] SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
      [java] SLF4J: Failed to load class "org.slf4j.impl.StaticMDCBinder".
      [java] SLF4J: Defaulting to no-operation MDCAdapter implementation.
      [java] SLF4J: See http://www.slf4j.org/codes.html#no_static_mdc_binder for further details.
      [java] Exception in thread "main" java.lang.ExceptionInInitializerError
      [java] at org.ofbiz.entity.util.EntitySaxReader.endElement(EntitySaxReader.java:379)
      [java] at javolution.xml.sax.XMLReaderImpl.parseAll(XMLReaderImpl.java:337)
      [java] at javolution.xml.sax.XMLReaderImpl.parse(XMLReaderImpl.java:100)
      [java] at org.ofbiz.entity.util.EntitySaxReader.parse(EntitySaxReader.java:296)
      [java] at org.ofbiz.entity.util.EntitySaxReader.parse(EntitySaxReader.java:248)
      [java] at org.ofbiz.entity.util.EntityDataLoader.loadData(EntityDataLoader.java:257)
      [java] at org.ofbiz.entityext.data.EntityDataLoadContainer.loadContainer(EntityDataLoadContainer.java:488)
      [java] at org.ofbiz.entityext.data.EntityDataLoadContainer.start(EntityDataLoadContainer.java:243)
      [java] at org.ofbiz.base.container.ContainerLoader.start(ContainerLoader.java:237)
      [java] at org.ofbiz.base.start.Start.startStartLoaders(Start.java:408)
      [java] at org.ofbiz.base.start.Start.start(Start.java:434)
      [java] at org.ofbiz.base.start.Start.main(Start.java:135)
      [java] Caused by: java.lang.ClassCastException: org.apache.logging.slf4j.SLF4JLoggerContext cannot be cast to org.apache.logging.log4j.core.LoggerContext
      [java] at org.apache.log4j.Logger.getLogger(Logger.java:37)
      [java] at freemarker.log._Log4jLoggerFactory.getLogger(_Log4jLoggerFactory.java:29)
      [java] at freemarker.log.Logger.getLogger(Logger.java:357)
      [java] at freemarker.template.Configuration.<clinit>(Configuration.java:125)
      [java] ... 12 more
      [java] Exception in thread "Thread-0" java.lang.NoSuchMethodError: java.util.concurrent.ConcurrentHashMap.keySet()Ljava/util/concurrent/ConcurrentHashMap$KeySetView;
      [java] at org.ofbiz.service.ServiceContainer.getAllDispatcherNames(ServiceContainer.java:111)
      [java] at org.ofbiz.service.ServiceContainer.stop(ServiceContainer.java:69)
      [java] at org.ofbiz.base.container.ContainerLoader.unload(ContainerLoader.java:264)
      [java] at org.ofbiz.base.start.Start.shutdownServer(Start.java:384)
      [java] at org.ofbiz.base.start.Start$1.run(Start.java:231)
      [java] Java Result: 1

      jacques.le.roux Jacques Le Roux added a comment -

      Thanks guys,

      Indeed same here, I did not find any warning in the 2.3 changelog so I thought it was straightforward, and simply replaced file.

      I revert and will see that later...

      jacques.le.roux Jacques Le Roux added a comment -

      Moreover I forgot to update the .classpath file :/

      deepak.dixit Deepak Dixit added a comment -

      I think its due to log4j-to-slf4j-2.3.jar, I removed this jar file and its working fine.

      jacques.le.roux Jacques Le Roux added a comment -

      Rerverted respectively at
      revision: 1679723
      revision: 1679726
      revision: 1679725

      jacques.le.roux Jacques Le Roux added a comment -

      Thanks Deepak,

      I think so, but we need to check more, because IIRW log4j-to-slf4j-2.2.jar was used by one of our externals...

      jacopoc Jacopo Cappellato added a comment -

      The upgrade is done with the following revisions:
      trunk 1680733
      14.12 1680736
      13.07 1680738

      jacques.le.roux Jacques Le Roux added a comment -

      Thanks Jacopo, should we not investigate about removing geronimo-connector? Though we will still need log4j-slf4j-impl for geronimo-transaction anyway. I think the Geronimo project is stale since IBM stopped its effort :/ OK we have bigger fishes to fry for now...

      jacopoc Jacopo Cappellato added a comment -

      Upgrading Geronimo, removing (if possible) geronimo-connector, switching to another TX manager (e.g. Atomikos) is probably food for another day

      jacques.le.roux Jacques Le Roux added a comment - - edited

      Ha just spotted you backported to R13, so another vote ahead...

      Ha no cool it's .03 not .02


        People

        • Assignee:
          jacopoc Jacopo Cappellato
          Reporter:
          jacques.le.roux Jacques Le Roux
        • Votes:
          0 Vote for this issue
          Watchers:
          4 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development