Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-6090

Unable to return order items in return process.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: Trunk, 14.12.01, 13.07.01
    • Fix Version/s: 14.12.01, 12.04.06, 13.07.02, 16.11.01
    • Component/s: order
    • Labels:
      None

      Description

      Steps to generate :-

      1. Select return menu from order manager.
      2. Select new return with from and to party in it.
      3. A return will be created and then switch to return items menu.
      4. Select order having items to return and check items to return.

      Here items can't be selected and return because of error at checkbox and return selected item button. Error can be found in browser developer tool.

      Error on return selected item button
      <a class="buttontext" href="javascript:document.FreeMarker template error: The following has evaluated to null or missing: ==> selectAllFormName [in template "component://order/webapp/ordermgr/return/returnItemInc.ftl" at line 250, column 40] ---- Tip: If the failing expression is known to be legally refer to something that's null or missing, either specify a default value like myOptionalVar!myDefault, or use <#if myOptionalVar??>when-present<#else>when-missing</#if>. (These only cover the last step of the expression; to cover the ...ocessor.java:1070) at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:611) at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:316) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61) at java.lang.Thread.run(Thread.java:745) .submit()">Return Selected Item(s)</a>

      1. OFBIZ-6090.patch
        0.7 kB
        Amardeep Singh Jhajj

        Activity

        mridul.pathak Mridul Pathak added a comment -

        Closing it as a duplicate of OFBIZ-6013.

        mridul.pathak Mridul Pathak added a comment -

        The fix is now committed in,
        Trunk r1661324
        14.12 r1661325
        13.07 r1661326
        12.04 r1661426

        mridul.pathak Mridul Pathak added a comment -

        Thanks Amardeep Singh Jhajj for reporting the issues and providing the patch. The line you have added was probably removed mistakenly in r1646204.

        This issue though is duplicate of OFBIZ-6013 reported by Christian Carlow.

        amardeepsj Amardeep Singh Jhajj added a comment -

        Here is the patch attached of fix for Release 13.07, 14.12 and trunk.


          People

          • Assignee:
            mridul.pathak Mridul Pathak
            Reporter:
            amardeepsj Amardeep Singh Jhajj
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development