Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-6071

Issue in decrypting entity fields where encrypt="true" is used in tenant

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: Trunk, 16.11.01
    • Fix Version/s: 14.12.01, 16.11.01
    • Component/s: framework
    • Labels:
      None

      Description

      Error while adding a credit card from order manager when logged in with tenant account.

      The error is as following:

      ERROR rendering error page [/error/error.jsp], but here is the error text: org.ofbiz.widget.renderer.ScreenRenderException: Error rendering screen component://party/widget/partymgr/PaymentMethodScreens.xml#editcreditcard: org.ofbiz.widget.renderer.ScreenRenderException: Error rendering screen component://party/widget/partymgr/PaymentMethodScreens.xml#PaymentMethodDecorator: org.ofbiz.entity.transaction.GenericTransactionException: The current transaction is marked for rollback, not beginning a new transaction and aborting current operation; the rollbackOnly was caused by: Failure in findByCondition operation for entity [CreditCard]: org.ofbiz.entity.GenericEntityException: Error creating GenericValue (org.ofbiz.base.util.GeneralException: javax.crypto.BadPaddingException: Given final block not properly padded (Given final block not properly padded) (javax.crypto.BadPaddingException: Given final block not properly padded (Given final block not properly padded))). Rolling back transaction.org.ofbiz.entity.GenericEntityException: Error creating GenericValue (org.ofbiz.base.util.GeneralException: javax.crypto.BadPaddingException: Given final block not properly padded (Given final block not properly padded) (javax.crypto.BadPaddingException: Given final block not properly padded (Given final block not properly padded)))

      It seems there is some issue with encryption-decryption mechanism for the fields of an entity for which encrypt="true" is set. From the exception it seemed that incorrect key is being used for decryption i.e. the key is not appropriate with respect to the one which was used for encryption.

      After tracing the process flow we suspect that in SqlJdbcUtil.java while calling 'decryptFieldValue' the delegator which is being used is baseDelegator instead of tenant's delegator, but at the time of encryption using 'encryptFieldValue' the delegator was tenant's delegator. May be this is the reason why it is generating "javax.crypto.BadPaddingException".

      Steps to regenerate:
      1. Create a tenant and login to tenant's admin account.
      2. Navigate to ORDER > Order Entry > Sales Order
      3. Use Demo Customer as Customer and continue.
      4. Add some item to order and proceed for Quick Finalize Order.
      5. Try to add new credit card.
      6. On saving credit card information it will generate the above error.

      1. OFBIZ-6071.patch
        1.0 kB
        Rohit Koushal

        Activity

        diveshdut Divesh Dutta added a comment -

        Hi Jacques Le Roux

        This issue was not in 13.07 branch. I doubt that this issue was introduced after some refactoring done by you in revision number 1608347, but I am not sure.

        Please see if you can help in this issue

        jacques.le.roux Jacques Le Roux added a comment -

        Hi Divesh,

        I will have a look ASAP...

        jacques.le.roux Jacques Le Roux added a comment - - edited

        OK, I spent too long time trying to login already.

        To test if it could be related to r1608347, I got back to r1655795 which is the last revision before I merged the SEO branch in trunk (r1655803)

        I put multitenant=Y in general.properties
        then used
        ant load-demo-multitenant
        ant load-tenant-admin-user-login -DtenantId=DEMO1

        But then I could not login with DEMO1-admin/ofbiz/DEMO1 (following OFBIZ-3971)
        The DEMO1-admin user was not recognised
        BTW, I found weird this message after ant load-tenant-admin-user-login -DtenantId=DEMO1

        load-tenant-admin-user-login:
             [echo] ------------------------------------
             [echo] Installing the admin for the tenant
             [echo] Delegator = ${delegatorId}
             [echo] Tenant admin = '${userLoginId}'
             [echo] Password for tenant admin is 'ofbiz' must change on first login
             [echo] ------------------------------------
            [input] Continue Y or N (N, n, Y, y)
        

        compared to what was at https://issues.apache.org/jira/browse/OFBIZ-3971?focusedCommentId=12988521

        I gave up at this stage. Could you made the same test than me (using r1655795) to see if you reproduce with this revision (before the SEO merge).

        I'd like also that you give me the steps you used before

        1. Create a tenant and login to tenant's admin account.

        Thanks!

        jacques.le.roux Jacques Le Roux added a comment -

        BTW, what makes you think that r1608347 could be related?

        diveshdut Divesh Dutta added a comment -

        For creating tenant I am using ant target "./ant create-tenant". Below is the snippet from console while running this target:

        Note: I am using default Derby database configuration and setting multitenant=Y in general.properties

        mysystem@system:~/dev/ofbiz/ofbiz_trunk$ ./ant create-tenant
        Buildfile: /home/rahulbho/dev/ofbiz/ofbiz_trunk/build.xml
        
        
        get-tenant-data:
            [input] Enter Id for the tenant: 
        TEST123
            [input] Enter name for tenant: 
        TEST123
            [input] Enter domain name for tenant (Optional): 
        
            [input] Enter data to install.         Choices are e.g. seed,seed-initial,ext,demo.         Multipe datasets must be separated with a comma: 
         seed,seed-initial,ext,demo
            [input] Select your default database platform, D = Derby,M = MySQL, O = Oracle, P = PostgreSQL (D, M, O, P)
        M
             [echo] Please make sure that the driver of the platform is installed and that the databases have been created (in function of the entityengine.xml datasource-names)
            [input] Enter IP address of the database server (you may add a port number)
        127.0.0.1
            [input] Enter userID of database user: 
        root
            [input] Enter password of database user: 
        123456
        
        tenant-data-entry:
             [echo] ------------------------------------
             [echo] tenantId = TEST123
             [echo] tenantName = TEST123
             [echo] domainName = 
             [echo] db-Platform = M
             [echo] db-IP = 127.0.0.1
             [echo] db-User = root
             [echo] db-Password = 123456
             [echo] ------------------------------------
             [echo] database for tenant data will be 'ofbiz_TEST123'
             [echo] database for tenant olap data will be 'ofbizolap_TEST123
             [echo] Please make sure that the driver of the platform is installed and that the databases have been created (Check names just above)
             [echo] ------------------------------------
            [input] Continue Y or N (N, n, Y, y)
        Y
        .
        .
        further processes will run here
        .
        .
        load-tenant-admin-user-login:
             [echo] ------------------------------------
             [echo] Installing the admin for the tenant
             [echo] Delegator = default#TEST123
             [echo] Tenant admin = 'TEST123-admin'
             [echo] Password for tenant admin is 'ofbiz' must change on first login
             [echo] ------------------------------------
            [input] Continue Y or N (N, n, Y, y)
        y
        .
        .
        .
        
        

        After this I started the server and logged in with UserName: TEST123-admin ,Password: ofbiz,TenantId: TEST123

        Tested this further on revision 1655795. The issue exists on revision 1655795 too. So, sorry for the confusion here.

        Initially I thought r1608347 could be related to this because the code snippet in SqlJdbcUtil.java of method getValue which calls decryptFieldValue was not available before r1608347. And delegator used to call decryptFieldValue is default delegator. And I think delegator should be of tenant because at the time of encryption tenant's delegator was used.

        Please let me know if you want any other details. Thanks in advance

        jacques.le.roux Jacques Le Roux added a comment -

        Thanks Divesh, I'm sure this will quite help!

        rohit.koushal Rohit Koushal added a comment -

        Jacques Le Roux, Divesh Dutta : I have uploaded patch for this issue. During the research found that system is trying to decrypt credit card number using the default delegator and causing error.

        Please validate and let me know if you find any other issue in the fix.

        diveshdut Divesh Dutta added a comment -

        HI Rohit Koushal

        I have tested your patch and it works fine for me.

        I can see that getValue method of SqlJdbcUtil.java is called from currentGenericValue method of EntityListIterator class. In currentGenericValue delegator is set after getValue method is called. And you have set tenant's delegator before getValue method is called. And now getValue method get tenant's delegator for decrypting the fields. So your changes looks good to me.

        Jacques Le Roux if you are fine with the changes you may commit the patch.

        jacopoc Jacopo Cappellato added a comment -

        Divesh Dutta, Rohit Koushal thanks for your contribution, it looks good.
        While testing this (before applying your patch) during the create-tenant task I got the following error:

        2015-02-18 07:48:31,501 |main |EntitySaxReader |I| Beginning import from URL: file:/Users/jacopoc/projects/ofbiz/release14.12/framework/entity/data/TenantDemoData.xml
        2015-02-18 07:48:31,501 |main |EntitySaxReader |I| Transaction Timeout set to 2 hours (7200 seconds)
        2015-02-18 07:48:31,501 |main |GenericDelegator |I| Can't access entity of entityGroup = org.ofbiz.tenant using tenant delegator default#TEST123, use base delegator instead
        2015-02-18 07:48:31,502 |main |GenericDelegator |E| Failure in storeAll operation: org.ofbiz.entity.GenericEntityException: There is no datasource (Helper) configured for the entity-group [org.ofbiz.tenant]; was trying to find datasource (helper) for entity [Tenant]. Rolling back transaction.
        org.ofbiz.entity.GenericEntityException: There is no datasource (Helper) configured for the entity-group [org.ofbiz.tenant]; was trying to find datasource (helper) for entity [Tenant]
        at org.ofbiz.entity.GenericDelegator.getEntityHelper(GenericDelegator.java:544) ~[ofbiz-entity.jar:?]
        at org.ofbiz.entity.GenericDelegator.storeAll(GenericDelegator.java:1429) [ofbiz-entity.jar:?]
        at org.ofbiz.entity.util.EntitySaxReader.writeValues(EntitySaxReader.java:329) [ofbiz-entity.jar:?]
        at org.ofbiz.entity.util.EntitySaxReader.parse(EntitySaxReader.java:299) [ofbiz-entity.jar:?]
        at org.ofbiz.entity.util.EntitySaxReader.parse(EntitySaxReader.java:248) [ofbiz-entity.jar:?]
        at org.ofbiz.entity.util.EntityDataLoader.loadData(EntityDataLoader.java:257) [ofbiz-entity.jar:?]
        at org.ofbiz.entityext.data.EntityDataLoadContainer.loadContainer(EntityDataLoadContainer.java:490) [ofbiz-entityext.jar:?]
        at org.ofbiz.entityext.data.EntityDataLoadContainer.start(EntityDataLoadContainer.java:245) [ofbiz-entityext.jar:?]
        at org.ofbiz.base.container.ContainerLoader.start(ContainerLoader.java:237) [ofbiz-base.jar:?]
        at org.ofbiz.base.start.Start.startStartLoaders(Start.java:343) [ofbiz.jar:?]
        at org.ofbiz.base.start.Start.start(Start.java:369) [ofbiz.jar:?]
        at org.ofbiz.base.start.Start.main(Start.java:136) [ofbiz.jar:?]
        2015-02-18 07:48:31,504 |main |TransactionUtil |W| Calling transaction setRollbackOnly; this stack trace shows where this is happening:
        java.lang.Exception: Failure in storeAll operation: org.ofbiz.entity.GenericEntityException: There is no datasource (Helper) configured for the entity-group [org.ofbiz.tenant]; was trying to find datasource (helper) for entity [Tenant]. Rolling back transaction.
        at org.ofbiz.entity.transaction.TransactionUtil.setRollbackOnly(TransactionUtil.java:360) [ofbiz-entity.jar:?]
        at org.ofbiz.entity.transaction.TransactionUtil.rollback(TransactionUtil.java:301) [ofbiz-entity.jar:?]
        at org.ofbiz.entity.GenericDelegator.storeAll(GenericDelegator.java:1481) [ofbiz-entity.jar:?]
        at org.ofbiz.entity.util.EntitySaxReader.writeValues(EntitySaxReader.java:329) [ofbiz-entity.jar:?]
        at org.ofbiz.entity.util.EntitySaxReader.parse(EntitySaxReader.java:299) [ofbiz-entity.jar:?]
        at org.ofbiz.entity.util.EntitySaxReader.parse(EntitySaxReader.java:248) [ofbiz-entity.jar:?]
        at org.ofbiz.entity.util.EntityDataLoader.loadData(EntityDataLoader.java:257) [ofbiz-entity.jar:?]
        at org.ofbiz.entityext.data.EntityDataLoadContainer.loadContainer(EntityDataLoadContainer.java:490) [ofbiz-entityext.jar:?]
        at org.ofbiz.entityext.data.EntityDataLoadContainer.start(EntityDataLoadContainer.java:245) [ofbiz-entityext.jar:?]
        at org.ofbiz.base.container.ContainerLoader.start(ContainerLoader.java:237) [ofbiz-base.jar:?]
        at org.ofbiz.base.start.Start.startStartLoaders(Start.java:343) [ofbiz.jar:?]
        at org.ofbiz.base.start.Start.start(Start.java:369) [ofbiz.jar:?]
        at org.ofbiz.base.start.Start.main(Start.java:136) [ofbiz.jar:?]
        2015-02-18 07:48:31,506 |main |EntitySaxReader |E| An error occurred saving the data, rolling back transaction (true)

        It happens in trunk and 14.12: are you getting the same? Jacques Le Roux, is this the issue you are having?

        jacques.le.roux Jacques Le Roux added a comment -

        Hi Jacopo, since I did not use the create-tenant target I did not get this one exactly. BTW I think we should cleanup the tenant related ant targets. Either I don't know how to use them, then some documentation is missing, or some are deprecated an we should either update them or remove them. I'm not sure but it seems to me there are too much of them, it's confusing.

        jacopoc Jacopo Cappellato added a comment -

        Ok, thanks for feedback Jacques: if you don't mind I will assign this ticket to me as I am able to recreate the issue.

        jacques.le.roux Jacques Le Roux added a comment -

        Sure, done, thanks Jacopo!

        pfm.smits Pierre Smits added a comment -

        It is always good to evaluate ./ant targets with respect to their usefulness. Like it is good to the same for other aspects in the code base OFBiz.

        I suggest to create specific JIRAs so that this issue doesn't get sidetracked and awareness is kept near its optimum.

        jacopoc Jacopo Cappellato added a comment -

        Thanks Divesh and Rohit for your report and fix; I have committed your work in rev. 1660579 (trunk) and rev. 1660580 (14.12)

        jacques.le.roux Jacques Le Roux added a comment -

        Hi Jacopo, does it stop at R14, below are not concerned?

        BTW I will create a Jira to clean the tenant targets

        jacques.le.roux Jacques Le Roux added a comment -

        Hi Divesh,

        You said this issue was not in R13.07, is this still true, did you test?

        diveshdut Divesh Dutta added a comment -

        Yes Jacques, we tested R13.07 and this issue is not there.

        jacques.le.roux Jacques Le Roux added a comment -

        Thanks Divesh!


          People

          • Assignee:
            jacopoc Jacopo Cappellato
            Reporter:
            diveshdut Divesh Dutta
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development