Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 14.12.01, 16.11.01
    • Component/s: product
    • Labels:
      None

      Description

      Steps to reproduce this bug:

      1) Create a sales order from Order manager application
      2) Click on "New Shipment For Ship Group" button on Shipment Information section.
      3) Shipment will be created in system and you will be landed on Edit Shipment page.
      4) This page is broken and Event date field is not showing up. Also update button is not showing up.

        Issue Links

          Activity

          diveshdut Divesh Dutta added a comment -

          After researching on this issue, found that issue is in EditShipment form in ShipmentForms.xml . This form tries to display eventDate field because its a IN parameter of service updateShipment and auto-fields-service tag is used to display field of updateShipment service. Now eventDate field is not field of Shipment entity. And system tries to get eventDate field from Shipment (GenericValue) entity. And due to recent changes in commit number: 1646666 (OFBIZ-5004) this issue occurred.

          Jacopo Cappellato we need your help here. One fix which we have in mind is to change code in EditShipment.groovy file. We can put shipment generic value in a map . And then form will try to get value from a Map instead of generic value. And since java Map returns null if key is not available in a Map. Doing this change, code will not blow up. But I am not sure if this is right solution. Please help us to find better solution.

          Here is example of what I am suggesting:

          
          shipmentMap = [:];
          shipmentMap.putAll(shipment);
          context.shipment = shipmentMap;
          
          
          diveshdut Divesh Dutta added a comment -

          I guess fix done in OFBIZ-5944 should also fix this issue. Thanks Jacopo for the proper fix in OFBIZ-5944

          jacopoc Jacopo Cappellato added a comment -

          Thanks Divesh,
          this is indeed a similar issue, fixed in OFBIZ-5944 with rev. 1649742 (trunk) and 1649747 (14.12 release branch).


            People

            • Assignee:
              jacopoc Jacopo Cappellato
              Reporter:
              diveshdut Divesh Dutta
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development