OFBiz
  1. OFBiz
  2. OFBIZ-5140

Exceptions when rendering pdfs due to bad filename prefix in ApacheFopWorker

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: Trunk
    • Fix Version/s: Trunk
    • Component/s: framework
    • Labels:
      None

      Description

      Caused by commit r1446940: The default value for the fop.font.base.url uses a file:/// prefix. After calling fontBaseFile.toURI, the whole path is duplicated. The following one-line patch fixes this:

      -                    String fopFontBaseProperty = UtilProperties.getPropertyValue("fop.properties", "fop.font.base.url", "file:///" + ofbizHome + "/framework/webapp/config/");
      +                    String fopFontBaseProperty = UtilProperties.getPropertyValue("fop.properties", "fop.font.base.url", ofbizHome + "/framework/webapp/config/");
      

        Activity

        Christoph Neuroth created issue -
        Christoph Neuroth made changes -
        Field Original Value New Value
        Description Caused by commit r1446940: The default value for the fop.font.base.url uses a file:/// prefix. After calling fontBaseFile.toURI, the whole path is duplicated. The following one-line patch fixes this:

        {{{
        - String fopFontBaseProperty = UtilProperties.getPropertyValue("fop.properties", "fop.font.base.url", "file:///" + ofbizHome + "/framework/webapp/config/");
        + String fopFontBaseProperty = UtilProperties.getPropertyValue("fop.properties", "fop.font.base.url", ofbizHome + "/framework/webapp/config/");
        }}}
        Caused by commit r1446940: The default value for the fop.font.base.url uses a file:/// prefix. After calling fontBaseFile.toURI, the whole path is duplicated. The following one-line patch fixes this:

        {code}
        - String fopFontBaseProperty = UtilProperties.getPropertyValue("fop.properties", "fop.font.base.url", "file:///" + ofbizHome + "/framework/webapp/config/");
        + String fopFontBaseProperty = UtilProperties.getPropertyValue("fop.properties", "fop.font.base.url", ofbizHome + "/framework/webapp/config/");
        {code}
        Adrian Crum made changes -
        Assignee Adrian Crum [ adrianc@hlmksw.com ]
        Adrian Crum added a comment -

        Fixed, rev 1449429. Thanks Christoph!

        Adrian Crum made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Fix Version/s SVN trunk [ 12311928 ]
        Resolution Fixed [ 1 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        2d 14h 43m 1 Adrian Crum 24/Feb/13 00:28

          People

          • Assignee:
            Adrian Crum
            Reporter:
            Christoph Neuroth
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development