Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-4849

YUI Compressor conflict with BIRT

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Trunk
    • Fix Version/s: 12.04.06
    • Component/s: framework
    • Environment:

      Ubuntu 10.04

      Description

      I got a problem when I entered an example report which has been created using BIRT https://demo-trunk.ofbiz.apache.org:8443/example/control/Report

      I got an error message: Invalid javascript expression: dataSetRow["exampleId"]

      This is a Mozilla JavaScript problem.

      Actually BIRT has a proper library for that, framework/birt/lib/js.jar, but it is conflicted by YUI Compressor library, framework/base/lib/yuicompressor-2.4.6.jar . If I take the YUI Compressor library out then the example report works fine.

      I see that in the YUI Compressor library contains org.mozilla.javascript package which duplicate with BIRT but I think it is different version.

      Regards,
      Chatree Srichart

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                jacques.le.roux Jacques Le Roux
                Reporter:
                chatree Chatree Srichart
              • Votes:
                1 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 8h
                  8h
                  Remaining:
                  Remaining Estimate - 8h
                  8h
                  Logged:
                  Time Spent - Not Specified
                  Not Specified