OFBiz
  1. OFBiz
  2. OFBIZ-4808

Missing helpscreens for Project Mgr application

    Details

      Description

      Fixing the missing help screens in project mgr app of R11.04 branch

        Activity

        Jacques Le Roux added a comment -

        Thanks Pierre,

        Completed: At revision: 1340350

        Jacques Le Roux added a comment -

        Ha OK, sorry I my view we should not commit those in release, but I think nobody expressed a refusal, so I think we can do it. I will do later...

        Pierre Smits added a comment -

        Jacques,

        This patch is for the r11.04 release branch.

        Regards,

        Pierre

        Jacques Le Roux added a comment -

        Pierre,

        Do you mean this should be closed as duplicate or still the patch reworked?

        Pierre Smits added a comment -

        Jacques,

        You already committed the help screens for ProjectMgr to trunk as per issue https://issues.apache.org/jira/browse/OFBIZ-4806.

        Regards,

        Pierre

        Pierre Smits added a comment -

        Jacques,

        I will look into this.

        Regards,

        Pierre

        Jacques Le Roux added a comment -

        Hi Pierre,

        Please provide a patch for trunk, this one failed

        D:\workspace\ofbizClean>patch -N -p0 0<OFBIZ-4808-r11_04-ProjectMgr-helpscreens.patch
        patching file specialpurpose/projectmgr/data/helpdata/HELP_PROJECTMGR_ProjectOrders.xml
        patching file specialpurpose/projectmgr/data/helpdata/HELP_PROJECTMGR_ProjectContent.xml
        patching file specialpurpose/projectmgr/data/helpdata/HELP_PROJECTMGR_ProjectMailingList.xml
        patching file specialpurpose/projectmgr/data/helpdata/HELP_PROJECTMGR_Skills.xml
        patching file specialpurpose/projectmgr/data/helpdata/HELP_PROJECTMGR_MyTasks.xml
        patching file specialpurpose/projectmgr/data/ProjectMgrHelpData.xml
        Hunk #1 FAILED at 18.
        1 out of 1 hunk FAILED – saving rejects to file specialpurpose/projectmgr/data/ProjectMgrHelpData.xml.rej
        patching file specialpurpose/projectmgr/data/helpdata/HELP_PROJECTMGR_main.xml
        patching file specialpurpose/projectmgr/data/helpdata/HELP_PROJECTMGR_ProjectPhases.xml
        patching file specialpurpose/projectmgr/data/helpdata/HELP_PROJECTMGR_ProjectResources.xml
        patching file specialpurpose/projectmgr/data/helpdata/HELP_PROJECTMGR_Projects.xml
        patching file specialpurpose/projectmgr/data/helpdata/HELP_PROJECTMGR_TimeSheets.xml
        patching file specialpurpose/projectmgr/documents/ProjectMgr.xml
        Hunk #1 FAILED at 22.
        1 out of 1 hunk FAILED – saving rejects to file specialpurpose/projectmgr/documents/ProjectMgr.xml.rej
        patching file specialpurpose/projectmgr/data/helpdata/HELP_PROJECTMGR_Tasks.xml
        patching file specialpurpose/projectmgr/data/helpdata/HELP_PROJECTMGR_ProjectEditProject.xml
        patching file specialpurpose/projectmgr/data/helpdata/HELP_PROJECTMGR_Project.xml
        patching file specialpurpose/projectmgr/data/helpdata/HELP_PROJECTMGR_MyTimesheet.xml
        patching file specialpurpose/projectmgr/data/helpdata/HELP_PROJECTMGR_ProjectSubProjects.xml
        patching file specialpurpose/projectmgr/data/helpdata/HELP_PROJECTMGR.xml
        patching file specialpurpose/projectmgr/data/helpdata/HELP_PROJECTMGR_ProjectTasks.xml
        patching file specialpurpose/projectmgr/data/helpdata/HELP_PROJECTMGR_Requests.xml
        patching file specialpurpose/projectmgr/data/helpdata/HELP_PROJECTMGR_Resources.xml
        patching file specialpurpose/projectmgr/data/helpdata/HELP_PROJECTMGR_ProjectNotes.xml
        patching file specialpurpose/projectmgr/data/helpdata/HELP_PROJECTMGR_ProjectBilling.xml

        Jacques Le Roux added a comment -

        Trivial improvement

        Jacques Le Roux added a comment -

        Pierre,

        Once again, we don't commit improvements in releases branches. This is not a bug, nothing crashes or behaves incorrectly, this is an improvement.

        This said we could make an exception for help files, like we did in others cases (I don't cleary remember when, maybe adding label).
        Because there are very few chances that they introduce regression. Then this should be discussed in dev ML

        Pierre Smits added a comment -

        This patch fixes the missing help screens for branch 11.04


          People

          • Assignee:
            Jacques Le Roux
            Reporter:
            Pierre Smits
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 1h
              1h
              Remaining:
              Remaining Estimate - 1h
              1h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development