Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Invalid
    • Affects Version/s: SVN trunk
    • Fix Version/s: None
    • Component/s: framework
    • Labels:
      None
    • Environment:

      WXP SP3, Sun SDK 1.6;0_30, PostgreSQL 9.2

      Description

      Hi

      I suggest to improve the integration of ofbiz under Eclipse by adding 4 lauching configurations:
      tools/ofbiz.start
      tools/ofbiz.stop
      tools/ofbiz.status
      tools/ofbiz.test

      The ofbiz.start has the specific JVM property DEBUG set to the value of "eclipse" -DDEBUG=eclipse so that all ofbiz jars located under each build/lib won't be loaded/added to the classpath. This will allow to continue producing all ofbiz jars with the build.xml while allowing hot replacement of classes when running under the Eclipse's debug launcher.

      Also, I added to this issue a patched version of the jackrabbit-core-2.3.3.jar that should replace the one in the framework/jcr/lib to avoid the jdbc driver exception: See https://issues.apache.org/jira/browse/JCR-3288

      Hope this help

      1. jackrabbit-core-2.3.3.jar
        2.14 MB
        Francis ANDRE
      2. ofbiz-eclipse.patch
        8 kB
        Francis ANDRE

        Issue Links

          Activity

          Francis ANDRE added a comment -

          The patches for the launchers and additional patches for runnign ofbiz under the Eclipse debugger

          Francis ANDRE added a comment -

          The jcr core patched jar

          Erwan de FERRIERES added a comment -

          Please Francis keep the issues where they belong, it will be easier to manage them.
          Also, who patched the jar ? Is it the jackrabbit team or you ? Maybe it would be better updating jackrabbit to 2.4.1 if the bugs are corrected instead of patching a jar.

          Regards,

          Francis ANDRE added a comment -

          Erwan

          The jar is linked with this ofbiz issue since the jcr issue https://issues.apache.org/jira/browse/JCR-3288 appears only when running ofbiz under Eclipse without the ofbiz-*.jar.

          I patched the jackrabbit-core-2.3.3.jar and the problem is the same in all upper versions of jackrabbit.

          Rgds

          Francis ANDRE added a comment -

          Hi

          I just realized that I missed in the patch to add a entry in the classpath. The framework/base/config directory should be added to run ofbiz under Eclipse. This is the entry to add in .classpath:

          <classpathentry kind="src" path="framework/base/config"/>

          Jacques Le Roux added a comment -

          Please Francis, open another issue, linked to this one, for the jackrabbit patched jar

          THanks

          Francis ANDRE added a comment -

          The jackrabbit-core-2.3.3.jar needed for this improvment to work.


            People

            • Assignee:
              Unassigned
              Reporter:
              Francis ANDRE
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development