OFBiz
  1. OFBiz
  2. OFBIZ-4801

Add Support for Dependent Country State Drop Downs to SFA New Postal Address

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: SVN trunk
    • Fix Version/s: SVN trunk
    • Component/s: marketing
    • Labels:
      None
    • Environment:

      demo-trunk

      Description

      In SFA "Create New Account" does not implement dependent drop downs for Country/State.
      This is not consistent whith the behavior in the Account update form which uses Country/State dependent drop downs.

      To Reproduce:
      In SFA select Accounts
      Select "Create New Account"

      Expect: "State" values to be limited to values valid for the selected country.
      Actual: "State" values include all values in stateProvinceGeoId regardless of the selected Country.

      After Improvement:
      State values will be filtered based on the value selected in "Country Geo Id"

        Activity

        Jacques Le Roux added a comment -

        Thanks Tom,

        Fixed at revision 1329332.

        Tom Burns added a comment -

        Duplicate line for stateProvinceGeoId in AccountForms.xml

        Jacques Le Roux added a comment -

        Thanks Tom,

        Your patch is in trunk at revision: 1325136.

        We could have removed the "required" tooltip for Country and state fields since it's now automatically mandatory, but I decided to keep them


          People

          • Assignee:
            Jacques Le Roux
            Reporter:
            Tom Burns
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development