OFBiz
  1. OFBiz
  2. OFBIZ-478

Gift Certificates sold offline (in store, over the phone, etc)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 14.12.01
    • Component/s: accounting
    • Labels:
      None

      Description

      Apologies in advance if this is user error and not a bug.

      If I create a Sales Order for a gift certificate (basically using the Demo Seed Data) I think the finaccount is being created but I'm confused about the use-model.

      If I look in the FinAccount table, I can see several GIFTCERT_ACCOUNTs. None of them have a finAccountName, but they all have a finAccountCode which looks like the output of a toString or something similar. With the Demo Data config, ought I be seeing a 12 alphanum account id somewhere in that table?

      In the case where I am selling the GC to a customer (say on the phone), should I be able to get the account id from somewhere in the UI to inform the customer, and/or to print out on some official looking store card for later redemption. Or.......

      Is the current implementation only intended for pure electronic use? A slight bummer if this is the base.

      Also, where can I see the balance on a fin_account? I can see transactions in the GL, but I'm having a heck of a time finding where (if at all) I can view/update fin_accounts.

      Again, apologies if this is inappropriate use of Jira, but from my naive perspective this looks like a bug, but I recognise it could be either deliberate design, or a stupid user

      Cheers, Iain

        Activity

        Iain Fogg created issue -
        Jacques Le Roux added a comment -

        Iain,

        Perhaps this could be also addressed to users ML. I guess you will have more luck to have a quick answer...

        Iain Fogg added a comment -

        Good point Jacques. I took you advice.

        Cheers, Iain


        No virus found in this outgoing message.
        Checked by AVG Free Edition.
        Version: 7.1.409 / Virus Database: 268.14.7/538 - Release Date: 18/11/2006

        Si Chen added a comment -

        Is your issue resolved? Can we close this JIRA issue?

        Iain Fogg added a comment -

        Si,

        I don't believe the problem is resolved. I just refreshed my installation from svn last night but haven't tested this functionality again yet. Having said that, I haven't seen any patches that address the problem, so I assume it's not fixed.

        Jacques Le Roux added a comment -

        Iain, Si,

        I can see a result in https://localhost:8443/financials/control/BalanceSheet...

        If iI understand weel, to resolve this issue it would take an UI to allow users to know more about their GC ?

        Jacques Le Roux added a comment -

        Mmm... perhaps I'm not clear : users are here of course admin, etc.

        Iain Fogg added a comment -

        Jacques,

        I've come to the same conclusion as you, but I wanted to find out if I
        was just missing something in either the existing UI, or in some config
        I was supposed to set somewhere that I forgot.

        Cheers, Iain


        No virus found in this outgoing message.
        Checked by AVG Free Edition.
        Version: 7.1.409 / Virus Database: 268.15.6/566 - Release Date: 3/12/2006

        Gavin made changes -
        Field Original Value New Value
        Workflow jira [ 12389890 ] OFbiz Workflow [ 12504653 ]
        Prateek added a comment -

        Hi Jacques,

        I don't see this is correct link https://localhost:8443/financials/control/BalanceSheet. I'm using OFBiz 13.07.01. Could you please let me know / help / guide how we can do a balance inquiry from OFBiz ui ?

        Jacques Le Roux added a comment -

        The link is now http://demo-trunk-ofbiz.apache.org/accounting/control/BalanceSheet?organizationPartyId=Company

        But there is a problem at the moment. I will see later why... I will then review this issue...

        Jacques Le Roux added a comment -

        This does not exist for a long time. The financials component has been replaced by the accouting one. The link is now

        accounting/control/BalanceSheet?organizationPartyId=Company

        I just fixed a missing .from("CustomTimePeriod") in EntityQuery today

        Jacques Le Roux made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Assignee Jacques Le Roux [ jacques.le.roux ]
        Fix Version/s Upcoming Branch [ 12327361 ]
        Resolution Fixed [ 1 ]
        Prateek added a comment - - edited

        Hi Jacques,

        Thanks, but how can I get details only about gift cards for the following points?

        • How to check the list of gift cards & it's corresponding balance from Apache OFBiz UI ?
        • Is there a report / screen showing which gift cards need to “ship”?
        Jacques Le Roux added a comment -

        I don't think there are means for that, but better to ask your questions on the user ML

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        2955d 14h 4m 1 Jacques Le Roux 23/Dec/14 06:45

          People

          • Assignee:
            Jacques Le Roux
            Reporter:
            Iain Fogg
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development