OFBiz
  1. OFBiz
  2. OFBIZ-4755

E-commerce search does not always functioning correctly

    Details

    • Type: Bug Bug
    • Status: Patch Available
    • Priority: Minor Minor
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None

      Description

      There seems to be a number of problems with the way e-commerce search works. I'll just a name a few examples of things I have tried that don't seem to work the way I think they should. I can delete a catalog from a store and the catalog still shows up and is completely searchable. I can delete a part from a catalog, then search the catalog and it still shows up, if you click the part from the search results you get a NullPointerException error. To take things a step further, after deleting the main catalog from the web store, I changed it to View Allow instead of Browse Root, then I even changed every category within the catalog to internal and search still finds parts from that catalog. Then I created a new catalog and category and put a product within. From here I can drill down to the part from the newly created catalog, but when I click on the part for details, it still directs me to the other catalog!

      1. ecommerceSearch2.patch
        0.7 kB
        Jeremy Olmstead
      2. ecommerceSearch1.patch
        0.7 kB
        Jeremy Olmstead

        Activity

          People

          • Assignee:
            Unassigned
            Reporter:
            Jeremy Olmstead
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:

              Development