OFBiz
  1. OFBiz
  2. OFBIZ-4740

Un-necessary Drop Down in Web Tools

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 14.12.01, 13.07.01
    • Component/s: framework
    • Labels:
      None

      Description

      Drop down in Web Tools Main select Service Reference appears to do nothing useful.

      To reproduce:
      In Web Tools Main select Service Reference
      To the right of the alpha list select a Dispatcher from the drop down.
      Expected: Expected results unknown
      Actual: Service Reference is refreshed with all services

        Activity

        Tom Burns created issue -
        Tom Burns added a comment -

        Consider removing this drop down

        Jacques Le Roux added a comment -

        We should check before if it's not a feature which dissapeared (for a reason or another, but not wanted).

        Jacopo Cappellato added a comment -

        This issue has been originally reported by Tom Burns.

        Jacopo Cappellato made changes -
        Field Original Value New Value
        Reporter Tom Burns [ brettonwoods ] Jacopo Cappellato [ jacopoc ]
        Jacopo Cappellato made changes -
        Assignee Jacopo Cappellato [ jacopoc ]
        Jacopo Cappellato made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Jacopo Cappellato added a comment -

        Fixed in rev. 1610420 and backported to the 13.07 branch.

        Jacopo Cappellato made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Fix Version/s 13.07.01 [ 12327355 ]
        Fix Version/s Upcoming Branch [ 12327361 ]
        Resolution Fixed [ 1 ]
        Jacopo Cappellato made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Adrian Crum added a comment -

        The expected results: List of services refreshed with new service dispatcher.

        The problem is, the selected service dispatcher is not being used. You can see it in the UI:

        Services list for webtools (2942 Found)

        So, selecting the "accounting" service dispatcher should change the UI to say:

        Services list for accounting(2942 Found)

        Jacques Le Roux added a comment -

        Should we not reopen? Adrian?

        Jacques Le Roux made changes -
        Fix Version/s Release Branch 11.04 [ 12316420 ]
        Fix Version/s 13.07.01 [ 12327355 ]
        Jacques Le Roux made changes -
        Fix Version/s 13.07.01 [ 12329159 ]
        Fix Version/s Release Branch 11.04 [ 12316420 ]
        Fix Version/s Upcoming Branch [ 12327361 ]
        Jacques Le Roux made changes -
        Fix Version/s Upcoming Branch [ 12327361 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open In Progress In Progress
        845d 17h 6m 1 Jacopo Cappellato 14/Jul/14 15:52
        In Progress In Progress Resolved Resolved
        51s 1 Jacopo Cappellato 14/Jul/14 15:53
        Resolved Resolved Closed Closed
        7s 1 Jacopo Cappellato 14/Jul/14 15:53

          People

          • Assignee:
            Jacopo Cappellato
            Reporter:
            Jacopo Cappellato
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development