OFBiz
  1. OFBiz
  2. OFBIZ-4682

Can not deploy to external tomcat

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Not a Problem
    • Affects Version/s: SVN trunk
    • Fix Version/s: SVN trunk
    • Component/s: ALL APPLICATIONS
    • Environment:

      linux gentoo 64 bit.
      Linux localhost 3.1.6-gentooasus #2 SMP PREEMPT Sun Jan 8 03:17:10 EST 2012 x86_64 Intel(R) Core(TM) i5-2410M CPU @ 2.30GHz GenuineIntel GNU/Linux

      Description

      When deploying to run under existing tomcat, it generates a lot of error in the catalina.out

      The message I get when targeting any component with my browser:
      ========================================================================
      HTTP Status 500 -

      type Exception report

      message

      description The server encountered an internal error () that prevented it from fulfilling this request.

      exception

      java.lang.IllegalArgumentException: [GenericDelegator.makePK] could not find entity for entityName: Visitor
      org.ofbiz.entity.GenericDelegator.makePK(GenericDelegator.java:663)
      org.ofbiz.entity.GenericDelegator.findOne(GenericDelegator.java:1549)
      org.ofbiz.entity.GenericDelegator.findOne(GenericDelegator.java:1542)
      org.ofbiz.webapp.stats.VisitHandler.getVisitor(VisitHandler.java:245)
      org.ofbiz.webapp.control.ControlServlet.doGet(ControlServlet.java:205)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:617)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
      org.ofbiz.webapp.control.ContextFilter.doFilter(ContextFilter.java:336)

      note The full stack trace of the root cause is available in the Apache Tomcat/6.0.29 logs.
      =====================================================================

      And within seconds the catalina.out becomes multiple GBs in size, containing repeated messages:

      =====================================================================
      Jan 28, 2012 12:14:58 AM org.apache.catalina.core.AprLifecycleListener init
      INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /opt/sun-jdk-1.6.0.26/jre/lib/amd64/server:/opt/sun-jdk-1.6.0.26/jre/lib/amd64:/opt/sun-jdk-1.6.0.26/jre/../lib/amd64:/usr/java/packages/lib/amd64:/usr/lib64:/lib64:/lib:/usr/lib
      Jan 28, 2012 12:14:58 AM org.apache.coyote.http11.Http11Protocol init
      INFO: Initializing Coyote HTTP/1.1 on http-8080
      Jan 28, 2012 12:14:59 AM org.apache.coyote.http11.Http11Protocol init
      INFO: Initializing Coyote HTTP/1.1 on http-8443
      Jan 28, 2012 12:14:59 AM org.apache.catalina.startup.Catalina load
      INFO: Initialization processed in 805 ms
      Jan 28, 2012 12:14:59 AM org.apache.catalina.core.StandardService start
      INFO: Starting service Catalina
      Jan 28, 2012 12:14:59 AM org.apache.catalina.core.StandardEngine start
      INFO: Starting Servlet Engine: Apache Tomcat/6.0.29
      Jan 28, 2012 12:14:59 AM org.apache.catalina.startup.ExpandWar copy
      SEVERE: Error copying /home/mansour/ofbiz/specialpurpose/oagis/webapp/oagis to /opt/tomcat6/temp/0-oagis
      java.io.FileNotFoundException: /home/mansour/ofbiz/specialpurpose/oagis/webapp/oagis (No such file or directory)
      at java.io.FileInputStream.open(Native Method)
      at java.io.FileInputStream.<init>(FileInputStream.java:120)
      at org.apache.catalina.startup.ExpandWar.copy(ExpandWar.java:308)
      at org.apache.catalina.startup.ContextConfig.antiLocking(ContextConfig.java:988)
      at org.apache.catalina.startup.ContextConfig.beforeStart(ContextConfig.java:1036)
      at org.apache.catalina.startup.ContextConfig.lifecycleEvent(ContextConfig.java:263)
      at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
      at org.apache.catalina.core.StandardContext.start(StandardContext.java:4397)
      at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
      at org.apache.catalina.core.StandardHost.start(StandardHost.java:785)
      at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
      at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:445)
      at org.apache.catalina.core.StandardService.start(StandardService.java:519)
      at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
      at org.apache.catalina.startup.Catalina.start(Catalina.java:581)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289)
      at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:414)
      Jan 28, 2012 12:14:59 AM org.apache.catalina.core.StandardContext resourcesStart
      SEVERE: Error starting static Resources
      java.lang.IllegalArgumentException: Document base /home/mansour/ofbiz/specialpurpose/oagis/webapp/oagis does not exist or is not a readable directory
      at org.apache.naming.resources.FileDirContext.setDocBase(FileDirContext.java:142)
      at org.apache.catalina.core.StandardContext.resourcesStart(StandardContext.java:4249)
      at org.apache.catalina.core.StandardContext.start(StandardContext.java:4418)
      at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
      at org.apache.catalina.core.StandardHost.start(StandardHost.java:785)
      at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
      at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:445)
      at org.apache.catalina.core.StandardService.start(StandardService.java:519)
      at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
      at org.apache.catalina.startup.Catalina.start(Catalina.java:581)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289)

      =====================================================================

      This is not true because the file /home/mansour/ofbiz/specialpurpose/oagis/webapp/oagis exists and readable by the user.

      Then I get a message in catalina.out like:
      ====================================================================

      2012-02-07 03:23:13,770 (main) [ ConfigXMLReader.java:293:ERROR]
      ---- exception report ----------------------------------------------------------
      Error processing include at [component://common/webcommon/WEB-INF/common-controller.xml]:java.net.MalformedURLException: Could not get root location for component with name [common], error was: org.ofbiz.base.component.ComponentException: No component found named : common
      Exception: java.net.MalformedURLException
      Message: Could not get root location for component with name [common], error was: org.ofbiz.base.component.ComponentException: No component found named : common
      ---- stack trace ---------------------------------------------------------------
      java.net.MalformedURLException: Could not get root location for component with name [common], error was: org.ofbiz.base.component.ComponentException: No component found named : common
      org.ofbiz.base.location.ComponentLocationResolver.getBaseLocation(ComponentLocationResolver.java:68)
      org.ofbiz.base.location.ComponentLocationResolver.resolveLocation(ComponentLocationResolver.java:39)
      org.ofbiz.base.location.FlexibleLocation.resolveLocation(FlexibleLocation.java:132)
      org.ofbiz.base.location.FlexibleLocation.resolveLocation(FlexibleLocation.java:73)
      org.ofbiz.webapp.control.ConfigXMLReader$ControllerConfig.loadIncludes(ConfigXMLReader.java:290)
      org.ofbiz.webapp.control.ConfigXMLReader$ControllerConfig.<init>(ConfigXMLReader.java:111)
      org.ofbiz.webapp.control.ConfigXMLReader.getControllerConfig(ConfigXMLReader.java:74)
      org.ofbiz.webapp.control.RequestHandler.init(RequestHandler.java:90)
      org.ofbiz.webapp.control.RequestHandler.getRequestHandler(RequestHandler.java:74)
      org.ofbiz.webapp.control.ControlServlet.getRequestHandler(ControlServlet.java:340)
      org.ofbiz.webapp.control.ControlServlet.init(ControlServlet.java:79)
      org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1173)
      org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:993)
      org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:4350)
      org.apache.catalina.core.StandardContext.start(StandardContext.java:4659)
      org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
      org.apache.catalina.core.StandardHost.start(StandardHost.java:785)
      org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
      org.apache.catalina.core.StandardEngine.start(StandardEngine.java:445)
      org.apache.catalina.core.StandardService.start(StandardService.java:519)
      org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
      org.apache.catalina.startup.Catalina.start(Catalina.java:581)
      sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      java.lang.reflect.Method.invoke(Method.java:597)
      org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289)
      org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:414)
      --------------------------------------------------------------------------------

      2012-02-07 03:23:13,771 (main) [ComponentLocationResolver.java:67 :ERROR]
      ---- exception report ----------------------------------------------------------
      Could not get root location for component with name [commonext], error was: org.ofbiz.base.component.ComponentException: No component found named : commonext
      Exception: org.ofbiz.base.component.ComponentException
      Message: No component found named : commonext
      ---- stack trace ---------------------------------------------------------------
      org.ofbiz.base.component.ComponentException: No component found named : commonext
      org.ofbiz.base.component.ComponentConfig.getComponentConfig(ComponentConfig.java:86)

      =======================================================================

      And finally many messsages:

      2012-02-07 03:28:51,198 (org.ofbiz.service.job.JobPoller@5cf346dc) [ TransactionUtil.java:351:INFO ] [TransactionUtil.rollback] transaction rolled back
      2012-02-07 03:28:51,198 (org.ofbiz.service.job.JobPoller@5cf346dc) [ TransactionUtil.java:276:WARN ] [TransactionUtil.commit] Not committing transaction, status is No Transaction (6)
      2012-02-07 03:28:51,199 (org.ofbiz.service.job.JobPoller@5cf346dc) [ GenericDelegator.java:397:ERROR]
      ---- exception report ----------------------------------------------------------
      Error getting entity definition from model
      Exception: org.ofbiz.entity.GenericModelException
      Message: Could not find definition for entity name JobSandbox
      ---- stack trace ---------------------------------------------------------------
      org.ofbiz.entity.GenericModelException: Could not find definition for entity name JobSandbox
      org.ofbiz.entity.model.ModelReader.getModelEntity(ModelReader.java:452)
      org.ofbiz.entity.GenericDelegator.getModelEntity(GenericDelegator.java:395)
      org.ofbiz.entity.GenericDelegator.clearCacheLineByCondition(GenericDelegator.java:2130)
      org.ofbiz.entity.GenericDelegator.clearCacheLineByCondition(GenericDelegator.java:2121)
      org.ofbiz.entity.GenericDelegator.storeByCondition(GenericDelegator.java:1277)
      org.ofbiz.entity.GenericDelegator.storeByCondition(GenericDelegator.java:1262)
      org.ofbiz.service.job.JobManager.poll(JobManager.java:156)
      org.ofbiz.service.job.JobPoller.run(JobPoller.java:90)
      java.lang.Thread.run(Thread.java:662)
      --------------------------------------------------------------------------------

      2012-02-07 03:28:51,199 (org.ofbiz.service.job.JobPoller@5cf346dc) [ JobManager.java:186:ERROR]
      ---- runtime exception report --------------------------------------------------
      Error in polling JobSandbox: [java.lang.NullPointerException]. Rolling back transaction.
      Exception: java.lang.NullPointerException
      Message: null
      ---- stack trace ---------------------------------------------------------------
      java.lang.NullPointerException
      org.ofbiz.entity.GenericDelegator.clearCacheLineByCondition(GenericDelegator.java:2130)
      org.ofbiz.entity.GenericDelegator.clearCacheLineByCondition(GenericDelegator.java:2121)
      org.ofbiz.entity.GenericDelegator.storeByCondition(GenericDelegator.java:1277)
      org.ofbiz.entity.GenericDelegator.storeByCondition(GenericDelegator.java:1262)
      org.ofbiz.service.job.JobManager.poll(JobManager.java:156)
      org.ofbiz.service.job.JobPoller.run(JobPoller.java:90)
      java.lang.Thread.run(Thread.java:662)
      --------------------------------------------------------------------------------

      2012-02-07 03:28:51,199 (org.ofbiz.service.job.JobPoller@5cf346dc) [ TransactionUtil.java:351:INFO ] [TransactionUtil.rollback] transaction rolled back
      2012-02-07 03:28:51,199 (org.ofbiz.service.job.JobPoller@5cf346dc) [ TransactionUtil.java:276:WARN ] [TransactionUtil.commit] Not committing transaction, status is No Transaction (6)
      2012-02-07 03:28:51,199 (org.ofbiz.service.job.JobPoller@5cf346dc) [ GenericDelegator.java:397:ERROR]

        Activity

        Jacques Le Roux added a comment -

        This is not an OFBiz bug, closing

        Jacques Le Roux added a comment -

        It's not fixed but a wont't fix


          People

          • Assignee:
            Adrian Crum
            Reporter:
            Mansour Al Akeel
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 120h
              120h
              Remaining:
              Remaining Estimate - 120h
              120h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development