OFBiz
  1. OFBiz
  2. OFBIZ-4657

ArrayIndexOutOfBoundsException in OrderServices.xml:updateOrderItemShipGroup

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Not a Problem
    • Affects Version/s: Trunk
    • Fix Version/s: None
    • Component/s: order
    • Labels:
      None

      Description

      When changing the billing or shipping address of a sales order in the ordermgr, a bsh exception is logged - with absolutely no trace where it is coming from. And the change of the adress is successful as well.

      The exception occurs here in OrderServices.xml in updateOrderItemShipGroup() in the BSH script

      <call-bsh><![CDATA[
      shipmentMethod = parameters.get("shipmentMethod");
      if (shipmentMethod != null)

      { arr = shipmentMethod.split( "@" ); parameters.put("shipmentMethodTypeId", arr[0]); parameters.put("carrierPartyId", arr[1]); parameters.put("carrierRoleTypeId", arr[2]); }

      ]]></call-bsh>

      Splitting for not existing chars and assuming the array was split successfully leads to the exception. The fix could work liks this, but as I do not have a clue at all, why it is split by the at-sign anyway I dont know if this fix does what it should. For us it does, because we do not care for sales order ship groups.

      <call-bsh><![CDATA[
      shipmentMethod = parameters.get("shipmentMethod");
      if (shipmentMethod != null) {
      arr = shipmentMethod.split( "@" );
      if (arr.length >= 3)

      { parameters.put("shipmentMethodTypeId", arr[0]); parameters.put("carrierPartyId", arr[1]); parameters.put("carrierRoleTypeId", arr[2]); }

      }
      ]]></call-bsh>

        Issue Links

          Activity

          Jacques Le Roux added a comment -

          This sounds to be related to OFBIZ-4389, I will have a look...

          Jacques Le Roux added a comment -

          In the meantime, you could try to revert r1167116, seemingly the same problem should exists for releases...

          Paul Foxworthy added a comment -

          Due to the line at https://fisheye6.atlassian.com/browse/ofbiz/trunk/applications/order/webapp/ordermgr/order/ordershippinginfo.ftl?hb=true#to255, I would expect that there should always be two @ characters. As Jacques says, that line was was changed in 4389.

          If that is not the case, there should be an exception. I think the error should not be quietly ignored.

          Alexander, is the problem that you are combining a newer OrderServices.xml, expecting two @ characters, with an older version of ordershippinginfo.ftl?

          Jacques Le Roux added a comment -

          Alexander,

          Could you confirm you have the same issue with trunk HEAD?

          Jacques Le Roux added a comment -

          Alexander,

          I had another look at your patch. It's buid againt revision 1164029. There is no such revision in OFBiz commits. But this is around early September. So finally it should not be related to OFBIZ-4389 and r1167116...

          Still, could you confirm you can reproduce with trunk HEAD? Because, of course we apply our patches against trunk HEAD...

          Thanks

          Paul Foxworthy added a comment -

          Please close as not a problem.

          Jacques Le Roux added a comment -

          Thanks for confirmation Paul

          Paul Foxworthy added a comment - - edited

          Turns out there is a problem after all. I'm pretty sure this is the same problem as OFBIZ-4865, which has a patch. Thanks to Leon for tracking it down.


            People

            • Assignee:
              Jacques Le Roux
              Reporter:
              Alexander Reelsen
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development