OFBiz
  1. OFBiz
  2. OFBIZ-4647

Date Picker widget in for breaks Internet Explorer 7

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: Trunk
    • Fix Version/s: None
    • Component/s: framework
    • Labels:
    • Sprint:
      Bug Crush Event - 21/2/2015

      Description

      When using a date field like in the code sample below, the generated JavaScript causes IE7 to stop loading the page with the infamous "Operation aborted" error and then redirect to an error page, making the screen unusable. For background information on the issue, see MS Knowledge Base 927917. This problem probably occurs with other js code blocks as well, however we only fixed this one for now because we urgently needed it for a client. This can be circumvented by moving the code in question into a function and binding that to the jQuery document.ready even as I did in the patch.

      Example that breaks IE7 on current trunk:

      <field id-name="fromDate" name="fromDate" tooltip="00:00"><date-time type="date"/></field>
      

      Note: In the patch, I also added two missing semicolons joined some lines so that there is no newlines before that semicolon. While those did not cause errors here, I really doubt if generating JavaScript code using FreeMarker is that great an idae.

      1. OFBIZ-4647.patch
        8 kB
        Christoph Neuroth

        Activity

        Christoph Neuroth added a comment -

        sorry about that, the first change in the previous patch belongs to a different issue

        Amardeep Singh Jhajj added a comment -

        I have seen given sample code of date field in different forms which uses minilang form and open those pages that uses date field in IE7, IE8, IE9 and IE10, everything seems to be working fine. There is no such error while rendering those pages. I think we can close this issue.

        Deepak Dixit added a comment -

        Based on Amardeep comments closing the issue


          People

          • Assignee:
            Unassigned
            Reporter:
            Christoph Neuroth
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development

                Agile