OFBiz
  1. OFBiz
  2. OFBIZ-4517

Shipment created for drop ship order is missing information

    Details

    • Type: Improvement Improvement
    • Status: Reopened
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: Release Branch 11.04, Trunk
    • Fix Version/s: None
    • Component/s: order
    • Labels:
      None
    • Sprint:
      Bug Crush Event - 21/2/2015

      Description

      Shipment created for drop ship order is missing:
      1. Shipping origin address (ShipmentServices.xml#setShipmentSettingsFromPrimaryOrder line 532 Cannot find a shipping origin address for WS10123)
      2. Shipping origin phone number (ShipmentServices.xml#setShipmentSettingsFromPrimaryOrder line 568 Cannot find a shipping origin phone number for WS10123)
      3. Shipping destination address

      Also, purchase order notification is not sent.

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Patch Available Patch Available
          45s 1 Kiran Gawde 26/Oct/11 00:23
          Patch Available Patch Available In Progress In Progress
          1025d 19h 31m 1 Anil K Patel 16/Aug/14 19:55
          In Progress In Progress Resolved Resolved
          56s 1 Anil K Patel 16/Aug/14 19:56
          Resolved Resolved Closed Closed
          20s 1 Anil K Patel 16/Aug/14 19:56
          Closed Closed Reopened Reopened
          2m 54s 1 Adrian Crum 16/Aug/14 19:59
          Sharan Foga made changes -
          Rank Ranked higher
          Sharan Foga made changes -
          Rank Ranked higher
          Sharan Foga made changes -
          Rank Ranked higher
          Sharan Foga made changes -
          Sprint Bug Crush Event - 21/2/2015 [ 91 ]
          Adrian Crum made changes -
          Issue Type Bug [ 1 ] Improvement [ 4 ]
          Adrian Crum made changes -
          Resolution Won't Fix [ 2 ]
          Status Closed [ 6 ] Reopened [ 4 ]
          Assignee Anil K Patel [ anilpatel ]
          Anil K Patel made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Anil K Patel made changes -
          Status In Progress [ 3 ] Resolved [ 5 ]
          Resolution Won't Fix [ 2 ]
          Anil K Patel added a comment -

          This is not a bug. With clear requirements and enough discussion , community may decide to add new feature.

          Anil K Patel made changes -
          Status Patch Available [ 10002 ] In Progress [ 3 ]
          Anil K Patel made changes -
          Assignee Anil K Patel [ anilpatel ]
          HotWax Media OFBiz Team added a comment -
          1. In case of drop shipment (Purchase Order), shipping origin address and shipping origin phone number is not getting set as per the current implementation in OFBiz. It seems to be not much needed requirement and can be worked if needed. This could be taken as enhancement but is definitely not a bug.
          2. Currently, there is not any support for purchase order notification email in OOTB. So the issue should not be considered as a bug and the support for this feature could also be provided as an enhancement.
          Kiran Gawde made changes -
          Link This issue blocks OFBIZ-4496 [ OFBIZ-4496 ]
          Kiran Gawde made changes -
          Link This issue is related to OFBIZ-4496 [ OFBIZ-4496 ]
          Kiran Gawde made changes -
          Link This issue blocks OFBIZ-4496 [ OFBIZ-4496 ]
          Kiran Gawde made changes -
          Attachment OFBIZ-4517-ShoppingCartJava.patch [ 12500834 ]
          Kiran Gawde made changes -
          Attachment OFBIZ-4517-OrderServicesJava.patch [ 12500798 ]
          Kiran Gawde made changes -
          Attachment OFBIZ-4517-OrderServicesJava.patch [ 12510067 ]
          Attachment OFBIZ-4517-ShoppingCartJava.patch [ 12510068 ]
          Kiran Gawde added a comment -

          With ASF license

          Erwan de FERRIERES added a comment -

          Kiran,
          you should accept to grant license to ASF for inclusion when uploading your patch, otherwise your code cannot be committed.

          Thanks

          Kiran Gawde made changes -
          Attachment OFBIZ-4517-ShoppingCartJava.patch [ 12500834 ]
          Kiran Gawde added a comment -

          Code has been updated to chose correct facility

          Kiran Gawde made changes -
          Attachment OFBIZ-4517-OrderServicesJava.patch [ 12500795 ]
          Kiran Gawde made changes -
          Attachment OFBIZ-4517-OrderServicesJava.patch [ 12500798 ]
          Kiran Gawde added a comment -

          Removed white space changes

          Kiran Gawde made changes -
          Attachment OFBIZ-4517-OrderServicesJava.patch [ 12500795 ]
          Kiran Gawde made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Kiran Gawde made changes -
          Field Original Value New Value
          Affects Version/s Release Branch 11.04 [ 12316420 ]
          Affects Version/s SVN trunk [ 12311928 ]
          Kiran Gawde created issue -

            People

            • Assignee:
              Unassigned
              Reporter:
              Kiran Gawde
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:

                Development

                  Agile