OFBiz
  1. OFBiz
  2. OFBIZ-4445

On register page, billing address same as shipping doesn't copy the phone number

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Invalid
    • Affects Version/s: Trunk
    • Fix Version/s: None
    • Labels:
      None

      Description

      Steps:
      1. Click register
      2. enter the shipping address
      3. Click 'billing address same as shipping address'

      Issue: Billing phone number is not populated. Also it is not disabled.
      Question: In ofbiz, we have two separate contact for phone and postal address. But do we believe that on the UI they should be treated separately?

        Activity

        Kiran Gawde created issue -
        Kiran Gawde made changes -
        Field Original Value New Value
        Priority Major [ 3 ] Minor [ 4 ]
        Jacques Le Roux made changes -
        Affects Version/s SVN trunk [ 12311928 ]
        Component/s specialpurpose/ecommerce [ 12311148 ]
        Divesh Dutta added a comment -

        First of all I am not able to find check box of "billing same as shipping" on Register page of E-commerce . You can only add shipping address on register page. May be that check box is removed to keep things simple. So reported bug is invalid now.

        Now I can see this case on check out page, i.e when clicking on "billing address same as shipping address", billing phone number is not populated . But this was never expected from this check box. Clicking on check will only copy address and not phone number. Also service on server side add "billing" as a purpose to the shipping address which gets created when this check box is checked. Service also does not care about phone number. So, this not a bug. You should fill the phone number at the time of creating billing address.

        To answer the question asked by Kiran Gawde , OFBiz data model gives flexibility to manage every contact separately. Decision of UI is completely dependent on requirement and how your will like to define user experience. Different people may have different views on defining user experience.

        Also its not necessary all the time that if billing and shipping address is same, then phone numbers will also be the same.

        We should mark this issue invalid and close it.

        Ashish Vijaywargiya made changes -
        Assignee Ashish Vijaywargiya [ toashishvijay ]
        Ashish Vijaywargiya added a comment -

        Based on Divesh's recent comment we can close this issue. Thanks Kiran Gawde for creating the issue.

        Ashish Vijaywargiya made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Invalid [ 6 ]
        Pierre Smits added a comment -

        As this is concluded to see this as a bug, it should be considered an improvement.

        Divesh Dutta added a comment -

        Pierre your comment is confusing. It is not concluded to see this as a bug. Also why do you think its an improvement ?

        Pierre Smits added a comment -

        Divesh,

        You are right indeed. Rereading my posting I also find it confusing. To hasty, and not sharp enough, to submit the right message. My apologies.

        What I meant to say (a bit more elaborate) is this:
        This issue is marked as bug (see Type field), but is regarded as not a bug (statement in your comment - which is very thorough and well written - kudos) and as such it is marked as invalid and closed.

        For sure, requirements are user specific. And the description of this issue is cryptic. But the question raised is valid. That, combined with what you have written, suggests that we should treat this issue as a opportunity to improve the user experience in the ecommerce app.


          People

          • Assignee:
            Ashish Vijaywargiya
            Reporter:
            Kiran Gawde
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development