OFBiz
  1. OFBiz
  2. OFBIZ-4336

Can not upload pdf content for a task

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: Trunk
    • Fix Version/s: None
    • Component/s: content
    • Labels:
      None
    • Environment:

      Description

      some mime-types can not be uploaded with a task. An error messages is displayed when attempting to upload a PDF.

      Error: No uploaded content found in context calling service createContentFromUploadedFile in createWorkEffortContent.

      The same applies to JPEG, ZIP, JAR (possibly other formats I didn't test). Some formats can be uploaded with no problem like (png images, text, xml).
      This issue appears from SVN trunk but not in 10.04 Release. And it doesn't appear on ofbiz trunk-demo either.

      This is the log for the error:

      [java] org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:554)
      [java] org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298)
      [java] org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:859)
      [java] org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:588)
      [java] org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:489)
      [java] java.lang.Thread.run(Thread.java:662)
      [java] --------------------------------------------------------------------------------
      [java]
      [java] 2011-07-09 00:01:53,847 (http-0.0.0.0-8443-2) [ CallSimpleMethod.java:109:WARN ] Got error [error] calling inline simple-method named [saveLocalFileDataResource] in resource [], message is null, and the error message list is:

      {No uploaded content found in context}
      [java] 2011-07-09 00:01:53,848 (http-0.0.0.0-8443-2) [ TransactionUtil.java:383:INFO ] [TransactionUtil.setRollbackOnly] transaction rollback only not set, rollback only is already set.
      [java] 2011-07-09 00:01:53,849 (http-0.0.0.0-8443-2) [ ServiceDispatcher.java:543:ERROR] Error in Service [attachUploadToDataResource]: No uploaded content found in context
      [java] 2011-07-09 00:01:53,850 (http-0.0.0.0-8443-2) [ TransactionUtil.java:383:INFO ] [TransactionUtil.setRollbackOnly] transaction rollback only not set, rollback only is already set.
      [java] 2011-07-09 00:01:53,850 (http-0.0.0.0-8443-2) [ GroupModel.java:165:ERROR] Grouped service [attachUploadToDataResource] failed.
      [java] 2011-07-09 00:01:53,851 (http-0.0.0.0-8443-2) [ ServiceDispatcher.java:543:ERROR] Error in Service [createContentFromUploadedFile]: No uploaded content found in context
      [java] 2011-07-09 00:01:53,851 (http-0.0.0.0-8443-2) [ TransactionUtil.java:383:INFO ] [TransactionUtil.setRollbackOnly] transaction rollback only not set, rollback only is already set.
      [java] 2011-07-09 00:01:53,852 (http-0.0.0.0-8443-2) [ ServiceDispatcher.java:604:INFO ] Sync service [projectmgr/createContentFromUploadedFile] finished in [1067] milliseconds with response [{errorMessageList={No uploaded content found in context}

      , responseMessage=error}]
      [java] 2011-07-09 00:01:53,864 (http-0.0.0.0-8443-2) [ UtilProperties.java:1056:INFO ] ResourceBundle DefaultMessages (en) created in 0.01s with 11 properties
      [java] 2011-07-09 00:01:53,879 (http-0.0.0.0-8443-2) [ UtilProperties.java:1056:INFO ] ResourceBundle MiniLangErrorUiLabels (en) created in 0.014s with 4 properties
      [java] 2011-07-09 00:01:53,881 (http-0.0.0.0-8443-2) [ TransactionUtil.java:341:ERROR]
      [java] ---- exception report ----------------------------------------------------------
      [java] [TransactionUtil.rollback]
      [java] Exception: java.lang.Exception
      [java] Message: Stack Trace
      [java] ---- stack trace ---------------------------------------------------------------
      [java] java.lang.Exception: Stack Trace
      [java] org.ofbiz.entity.transaction.TransactionUtil.rollback(TransactionUtil.java:340)
      [java] org.ofbiz.entity.transaction.TransactionUtil.rollback(TransactionUtil.java:317)
      [java] org.ofbiz.minilang.SimpleMethod.exec(SimpleMethod.java:870)
      [java] org.ofbiz.minilang.SimpleMethod.runSimpleMethod(SimpleMethod.java:160)
      [java] org.ofbiz.minilang.SimpleMethod.runSimpleEvent(SimpleMethod.java:121)
      [java] org.ofbiz.webapp.event.SimpleEventHandler.invoke(SimpleEventHandler.java:70)
      [java] org.ofbiz.webapp.control.RequestHandler.runEvent(RequestHandler.java:647)
      [java] org.ofbiz.webapp.control.RequestHandler.doRequest(RequestHandler.java:393)
      [java] org.ofbiz.webapp.control.ControlServlet.doGet(ControlServlet.java:224)
      [java] org.ofbiz.webapp.control.ControlServlet.doPost(ControlServlet.java:87)
      [java] javax.servlet.http.HttpServlet.service(HttpServlet.java:637)
      [java] javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
      [java] org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
      [java] org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      [java] org.ofbiz.webapp.control.ContextFilter.doFilter(ContextFilter.java:336)
      [java] org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      [java] org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      [java] org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
      [java] org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
      [java] org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
      [java] org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
      [java] org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
      [java] org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:554)
      [java] org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298)
      [java] org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:859)
      [java] org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:588)
      [java] org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:489)
      [java] java.lang.Thread.run(Thread.java:662)
      [java] --------------------------------------------------------------------------------
      [java]
      [java] 2011-07-09 00:01:53,904 (http-0.0.0.0-8443-2) [ TransactionUtil.java:351:INFO ] [TransactionUtil.rollback] transaction rolled back
      [java] 2011-07-09 00:01:53,904 (http-0.0.0.0-8443-2) [ RequestHandler.java:648:INFO ] Ran Event simple:component://projectmgr/script/org/ofbiz/project/ProjectSimpleEvents.xml#createWorkEffortContent from [request], result is [error]
      [java] 2011-07-09 00:01:53,906 (http-0.0.0.0-8443-2) [ RequestHandler.java:440:WARN ] Could not find response in request [createTaskContent] for event return [error]
      [java] 2011-07-09 00:01:53,907 (http-0.0.0.0-8443-2) [ RequestHandler.java:707:INFO ] Sending redirect to: [/projectmgr/control/EditTaskContents], sessionId=9E4A2889D7C539492C6108E0AA5BC887.jvm1
      [java] 2011-07-09 00:01:53,914 (http-0.0.0.0-8443-2) [ ServerHitBin.java:627:INFO ] Visit delegatorName=default, ServerHitBin delegatorName=default
      [java] 2011-07-09 00:01:53,926 (http-0.0.0.0-8443-2) [ ControlServlet.java:324:INFO ] [[[createTaskContent(Domain:localhost)] Request Done- total:1.684,since last([createTaskConten...):1.684]]
      [java] 2011-07-09 00:01:54,064 (http-0.0.0.0-8443-1) [ ControlServlet.java:141:INFO ] [[[EditTaskContents(Domain:localhost)] Request Begun, encoding=[UTF-8]- total:0.0,since last(Begin):0.0]]

        Activity

        BJ Freeman added a comment -

        as you mentioned this works on the demo-trunk.
        so what is different between the demo-trunk and the svn?

        Mansour Al Akeel added a comment -

        BJ Freeman,
        This is the question that I like to get answered. I am still not sure if the difference is in the code base, or the default configuration. Please note that the default configuration in release 10.04, works fine.

        Mansour Al Akeel added a comment -

        This issue appear only when I check code out from the repo. It happened with all source code branches, 10.04, trunk, 11.04, even when I checked out commits from last year. The only thing that worked fine for me is the 10.04 from the zip file. I was not able to track down the cause.

        BJ Freeman added a comment -

        the difference is that the zip file has the db initialized with the demo data.
        the repo(SVN) needs not only to be compiled but the data loaded.
        so this can be closed?

        Mansour Al Akeel added a comment -

        BJ Freeman,
        I initialized the demo data with

        ./ant run-install

        I tried to install the seeds separately,

        ./ant run-install-extseed

        Nothing worked.
        Is there something else I am missing ?

        BJ Freeman added a comment -

        at this point this is not a bug so the jira can be closed and the conversation moved to the user mailing list.
        I suggest you take the working copy of 10.04 and copy it to a new folder then do
        ./ant clean all
        ./ant run-install
        and see if the problem shows up.

        Jacques Le Roux added a comment -

        Before closing, if yoyu want more help you need to give us more details. Most of the time URLs are enough and welcome
        Else please follow this scenario (at leat relevant parts)

        Why

        • What you were looking for
        • How did you try to achieve it
        • What did you expect as results
        • And what you really got

        How

        1. What you did (including detailed steps to reproduce)
        2. What you expected to happen
        3. What actually happened (including exact quotes of error messages, etc)
        4. If possible provide an URL
        Mansour Al Akeel added a comment -

        Jacques,
        The issue had to do with git. Getting the code from snapshot zip file works fine, but not when I used git. This thread on the mailing list discusses what I did.

        http://mail-archives.apache.org/mod_mbox/ofbiz-user/201107.mbox/browser

        Thank you.

        Jacques Le Roux added a comment -

        Mansour,

        Before we close, and to make things totaly clear, coud you please try the same with svn (which is so far the recommended way to check out code)?

        TIA

        Mansour Al Akeel added a comment -

        Jacques,
        I will try it with SVN sometime next week and will let you know.

        Thank you.

        Mansour Al Akeel added a comment -

        Jacques,
        I tested it from SVN and it worked fine.
        This issue occur when using GIT only.

        Jacques Le Roux added a comment -

        I close but not sure how we could inform users that using Git can give some issues like that

        Jacques Le Roux added a comment -

        I added a link from the repository page


          People

          • Assignee:
            Unassigned
            Reporter:
            Mansour Al Akeel
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development