Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Later
    • Affects Version/s: SVN trunk
    • Fix Version/s: None
    • Component/s: framework
    • Labels:

      Description

      the allows on the fly addition of deny parms before a lot of resources are allocated.
      The goal is to filter out the requests that are not relevant to the site.
      Like the image bots that just want you images.
      or someone that copies you content.
      the two seed data are from mod rewrite for bots(171) and Ip's that are known to attempt to hack, or do unnecessary requests.

      1. VisitFllterIP.xml
        3 kB
        BJ Freeman
      2. VisitFllter.xml
        39 kB
        BJ Freeman

        Activity

        Jacques Le Roux added a comment -

        Maybe later...

        BJ Freeman added a comment -

        what you call give up I call taking the path of least resistance.
        I see the difference in being most want stuff in ofbiz svn so they can use the svn to further their business.
        From the get go my view was I would like to contribute what I am already planning
        Now I don't mind someone doing a Code review, to maintain best practices. But when the overhead to contributed exceeds a limit of what I want to do, I cut if off so I can direct my energy to those things the have a higher priority.

        It is NOT important to me to have what I contribute in the SVN.

        BJ Freeman added a comment -

        though some messages of broken pipes comes from the handling of errors in Controlserverlet.java, there are some AJP broken pipes messages of data that does not get transfer to the Browser. I have not address it specifically here because I can not pinpoint the cause.

        Jacques Le Roux added a comment -

        BTW why do you give up? Should we really close?

        Jacques Le Roux added a comment -

        For my information, what do you mean exaclty by "AJP gets clogged up"?

        BJ Freeman added a comment -

        Yes, that assumes using AJP.
        I am migrating from that since it seems the AJP gets clogged up.
        we can close this and I will put it on my site.

        Jacques Le Roux added a comment -

        I meant you can do that in Apache HTTPD conf, which is completly unrelated to OFBiz.

        BJ Freeman added a comment -

        I did not find the way to delete the patches.
        I did not expect it to be put in trunk.
        and yes the filter of the web.xml is where it programmaticly go.
        my understanding, is in ofbiz, unlike TC it takes a restart.
        This is not acceptable for productions.

        Jacques Le Roux added a comment -

        3. if the data are put as demo it's OK with me. The idea is also to prevent the overhead it it's done in HHTPD or like

        Better to remove patches than simply remove the feather, it's not obvious to spot the change

        BJ Freeman added a comment -

        thought I had eclipse set to 4 spaces though it would not have caught ==

        #3 if the VisitFllter entity is empty it returns a false so not action taken. an indirect option. putting in code to disable would have about the same time as the way it is set up now.

        Note this is not ready yet. I thought it was working but it was not loaded.
        once loaded I found errors I am working on.
        that is why I removed the patch provided flag

        Jacques Le Roux added a comment -

        Hi BJ,

        Some remarks after a quick review:

        1. Minor: bad indentation and formatting in ControlServlet.java, for instance
          if(VisitHandler.filterVisitor(request, response)==Boolean.TRUE){
          

          should be

          if (VisitHandler.filterVisitor(request, response) == Boolean.TRUE) {
          
        2. You use tabs in your patch.
        3. I did not see a mean to deactivate this option (for instance if you already filter with HTTPD in front)
        BJ Freeman added a comment -

        typo

        BJ Freeman added a comment -

        I left some hooks and parms in to expand this further.
        as I get time i will add to it.
        It does what I want now so I doubt I will do anything more till next year.


          People

          • Assignee:
            Jacques Le Roux
            Reporter:
            BJ Freeman
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development