OFBiz
  1. OFBiz
  2. OFBIZ-4064

order manager order entry show cart.ftl problem probably caused by jquery update

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: SVN trunk
    • Fix Version/s: SVN trunk
    • Component/s: order
    • Labels:
      None

      Description

      when creating a new sales order in the order manager, the product entry screen shows the following problem:

      Error rendering included template at location [component://order/webapp/ordermgr/entry/cart/showcart.ftl]: freemarker.core.ParseException: Token manager error: freemarker.core.TokenMgrError: Lexical error at line 113, column 89. Encountered: "#" (35), after : ""

      In the log:

      2010-12-17 09:09:27,813 (http-0.0.0.0-8443-6) [ ScreenFactory.java:130:INFO ] Got 21 screens in 0.0090s from: file:/home/hans/ofbiz/ofbizTrunk/framework/common/widget/CommonScreens.xml
      2010-12-17 09:09:27,818 (http-0.0.0.0-8443-6) [ComponentLocationResolver.java:43 :WARN ] Unable to get file URL for component location; expanded location was [/home/hans/ofbiz/ofbizTrunk/framework/images/webapp/images/jquery/ui/development-bundle/ui/i18n/jquery.ui.datepicker-en-US.js], original location was [component://images/webapp/images/jquery/ui/development-bundle/ui/i18n/jquery.ui.datepicker-en-US.js]
      2010-12-17 09:09:28,148 (http-0.0.0.0-8443-6) [ ScreenFactory.java:130:INFO ] Got 19 screens in 0.0070s from: file:/home/hans/ofbiz/ofbizTrunk/applications/order/widget/ordermgr/OrderEntryCatalogScreens.xml
      2010-12-17 09:09:28,536 (http-0.0.0.0-8443-6) [ HtmlWidget.java:224:ERROR]
      ---- exception report ----------------------------------------------------------
      Error rendering included template at location [component://order/webapp/ordermgr/entry/cart/showcart.ftl]: freemarker.core.ParseException: Token manager error: freemarker.core.TokenMgrError: Lexical error at line 113, column 89. Encountered: "#" (35), after : ""
      Exception: freemarker.core.ParseException
      Message: Token manager error: freemarker.core.TokenMgrError: Lexical error at line 113, column 89. Encountered: "#" (35), after : ""
      ---- stack trace ---------------------------------------------------------------
      freemarker.core.ParseException: Token manager error: freemarker.core.TokenMgrError: Lexical error at line 113, column 89. Encountered: "#" (35), after : ""
      freemarker.template.Template.<init>(Template.java:152)
      freemarker.template.Template.<init>(Template.java:167)
      org.ofbiz.base.util.template.FreeMarkerWorker.getTemplate(FreeMarkerWorker.java:334)
      org.ofbiz.widget.screen.HtmlWidget.renderHtmlTemplate(HtmlWidget.java:203)
      org.ofbiz.widget.screen.HtmlWidget$HtmlTemplate.renderWidgetString(HtmlWidget.java:250)
      org.ofbiz.widget.screen.HtmlWidget.renderWidgetString(HtmlWidget.java:110)
      org.ofbiz.widget.screen.ModelScreenWidget$PlatformSpecific.renderWidgetString(ModelScreenWidget.java:915)
      org.ofbiz.widget.screen.ModelScreenWidget.renderSubWidgetsString(ModelScreenWidget.java:104)
      org.ofbiz.widget.screen.ModelScreenWidget$DecoratorSection.renderWidgetString(ModelScreenWidget.java:613)
      org.ofbiz.widget.screen.ModelScreenWidget$SectionsRenderer.render(ModelScreenWidget.java:129)
      org.ofbiz.widget.screen.ModelScreenWidget$DecoratorSectionInclude.renderWidgetString(ModelScreenWidget.java:646)
      org.ofbiz.widget.screen.ModelScreenWidget.renderSubWidgetsString(ModelScreenWidget.java:104)
      org.ofbiz.widget.screen.ModelScreenWidget$Section.renderWidgetString(ModelScreenWidget.java:191)
      org.ofbiz.widget.screen.ModelScreenWidget.renderSubWidgetsString(ModelScreenWidget.java:104)
      org.ofbiz.widget.screen.ModelScreenWidget$DecoratorSection.renderWidgetString(ModelScreenWidget.java:613)
      org.ofbiz.widget.screen.ModelScreenWidget$SectionsRenderer.render(ModelScreenWidget.java:129)
      org.ofbiz.widget.screen.ModelScreenWidget$DecoratorSectionInclude.renderWidgetString(ModelScreenWidget.java:646)

        Activity

        Erwan de FERRIERES committed 1211397 (1 file)
        Reviews: none

        OFBIZ-4064 - patch from Olivier Heintz - French translation correction for ListWorkEffortTimeEntries label

        Jacques Le Roux made changes -
        Status Reopened [ 4 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        Jacques Le Roux added a comment -

        Thanks Hans for report, Dukian for patch,

        Properly fixed at r1050313. Dukian your fix was not complete. It was missing the useAsDefaultDesiredDeliveryDate part. I also missed it before I really tested

        Jan le Roux committed 1050313 (1 file)
        Reviews: none

        Properly fix "Order manager order entry show cart.ftl problem probably caused by jquery update" (https://issues.apache.org/jira/browse/OFBIZ-4064) - OFBIZ-4064

        Dukian fix was not complete (I guess because it was not properly moved during jQuery merge).

        Jacques Le Roux made changes -
        Resolution Fixed [ 1 ]
        Status Closed [ 6 ] Reopened [ 4 ]
        Jacques Le Roux added a comment -

        Sorry Dukian fix was not complete (I guess because it was not porperly moved during jQuery merge). I will fix it soon

        Jacques Le Roux added a comment -

        I fixed another like (<#if inside <@htmlTemplate.renderDateTimeField) at r1050305. I checked, it was the only one remaining.

        Jacques Le Roux made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        Jacques Le Roux added a comment -

        Thanks Dukian,

        Your (slightly modfied) patch is in trunk at r1050297.

        Jan le Roux committed 1050297 (1 file)
        Reviews: none

        A slightly modified patch from Dukian "Order manager order entry show cart.ftl problem probably caused by jquery update" (https://issues.apache.org/jira/browse/OFBIZ-4064) - OFBIZ-4064

        JLR: It's the 2d issue like that we cross. I will check and fix all <@htmlTemplate.renderDateTimeField son

        Jacques Le Roux added a comment -

        Yes right, thanks Dukian,

        It's the 2d issue like that we cross. I will check and fix all <@htmlTemplate.renderDateTimeField son

        Jacques Le Roux made changes -
        Assignee Jacques Le Roux [ jacques.le.roux ]
        dukian made changes -
        Field Original Value New Value
        Attachment OFBIZ-4064_showcart_ftl.patch [ 12466446 ]
        dukian added a comment - - edited

        I just found two problems in showcart.ftl (maybe wrong):

        1. can't use other directives in User-defined directive, like line 113:

        <@htmlTemplate.renderDateTimeField name="itemDesiredDeliveryDate"<#if useAsDefaultDesiredDeliveryDate?exists> value="${defaultDesiredDeliveryDate}" <#else> value=""</#if> className="" alert="" title="Format: yyyy-MM-dd HH:mm:ss.SSS" size="25" maxlength="30" id="item1" dateType="date" shortDateInput=false timeDropdownParamName="" defaultDateTimeString="" localizedIconTitle="" timeDropdown="" timeHourName="" classString="" hour1="" hour2="" timeMinutesName="" minutes="" isTwelveHour="" ampmName="" amSelected="" pmSelected="" compositeType="" formName=""/>

        2. can't use double quotes twice in line 122, 131:

        <@htmlTemplate.renderDateTimeField name="shipAfterDate" value="${shoppingCart.getDefaultShipAfterDate()?default("")}" className="" alert="" title="Format: yyyy-MM-dd HH:mm:ss.SSS" size="25" maxlength="30" id="item2" dateType="date" shortDateInput=false timeDropdownParamName="" defaultDateTimeString="" localizedIconTitle="" timeDropdown="" timeHourName="" classString="" hour1="" hour2="" timeMinutesName="" minutes="" isTwelveHour="" ampmName="" amSelected="" pmSelected="" compositeType="" formName=""/>

        Please check patch file

        Hans Bakker added a comment -

        going back to revision 1044084 just before the jquery merge, it is working fine.

        Hans Bakker created issue -

          People

          • Assignee:
            Jacques Le Roux
            Reporter:
            Hans Bakker
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development