OFBiz
  1. OFBiz
  2. OFBIZ-4029

commit r1033717 breaks authorize.net processing.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: Trunk
    • Fix Version/s: None
    • Component/s: accounting
    • Labels:
      None
    • Environment:

      linux, postgres

      Description

      hi,

      i updated my code to the latest version and the commit r1033717 breaks the authorize payment process. i am not sure if we are expected to make any changes to 'authorize dot net' config settings, but if we need to do any changes they are not mentioned in the commit.

      the problem that i am facing after updating my code to the commit r1033717 is as follows:

      1) credit card are properly authorized, but the authorization status is not properly saved in the database. for eg. if the credit card was authorized for $10, in ofbiz is shows only 0. it happens the same for any amount used in authorization.

      2) in the reference number field, instead of the of reference number, the ofbiz order number is shown.

      3) in the 'Gateway Cv Result' field the reference number is showing instead to the CV result.

      i assume that the problem is with the storing of the response from authorize dot net into the ofbiz database. the authorization is however successful as we get a confirmation from authorize.net with the correct amount and other details.

      Thanks,

      Rohit

        Activity

        Rohit Sureka created issue -
        Andrew Zeneski made changes -
        Field Original Value New Value
        Assignee Andrew Zeneski [ jaz ]
        Andrew Zeneski made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Andrew Zeneski added a comment -

        This should be resolved in the trunk revision #1038317.
        Please confirm that this is resolved for you.

        Andrew Zeneski made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Jacques Le Roux added a comment -

        Close on Rohit's demand

        Jacques Le Roux made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open In Progress In Progress
        3d 14h 34m 1 Andrew Zeneski 23/Nov/10 19:18
        In Progress In Progress Resolved Resolved
        58m 38s 1 Andrew Zeneski 23/Nov/10 20:17
        Resolved Resolved Closed Closed
        11d 22h 38m 1 Jacques Le Roux 05/Dec/10 18:56

          People

          • Assignee:
            Andrew Zeneski
            Reporter:
            Rohit Sureka
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development