Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: Release 09.04
    • Fix Version/s: Release Branch 09.04
    • Component/s: accounting
    • Labels:
      None
    • Environment:

      Linux

      Description

      I'm trying to create a fixed asset but I'm not able to view the deprectation report for my assets although I entered the dates and purchase and salvage value.
      I receive a method that tells me that deprectaion method not found.
      the depreciation report works with the demo fixed asset called : DEMO_PROD_EQUIPMT_1 and also DEMO_PROD_EQUIPMT_2
      what's the reason behind this ?
      how can I make the depreciation reports work for all my assets

        Activity

        Shereen Ashraf created issue -
        Hide
        Jacques Le Roux added a comment -

        Hi Shereen,

        Is this working in trunk?

        Show
        Jacques Le Roux added a comment - Hi Shereen, Is this working in trunk?
        Jacques Le Roux made changes -
        Field Original Value New Value
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        Hide
        Jacques Le Roux added a comment -

        Oops, I did not intend to close, confusion with another issue

        Show
        Jacques Le Roux added a comment - Oops, I did not intend to close, confusion with another issue
        Jacques Le Roux made changes -
        Resolution Fixed [ 1 ]
        Status Closed [ 6 ] Reopened [ 4 ]
        Jacopo Cappellato made changes -
        Assignee Jacopo Cappellato [ jacopoc ]
        Hide
        Jacopo Cappellato added a comment - - edited

        You have to set the "depreciation method" for the asset in the entity FixedAssetDepMethod.

        Unfortunately in release 09.04 there is not a screen for this, part from the general purpose web tools screen:

        https://demo-old.ofbiz.apache.org/webtools/control/FindGeneric?entityName=FixedAssetDepMethod&find=true&VIEW_SIZE=50&VIEW_INDEX=0

        In more recent releases the feature has been implemented.

        Show
        Jacopo Cappellato added a comment - - edited You have to set the "depreciation method" for the asset in the entity FixedAssetDepMethod. Unfortunately in release 09.04 there is not a screen for this, part from the general purpose web tools screen: https://demo-old.ofbiz.apache.org/webtools/control/FindGeneric?entityName=FixedAssetDepMethod&find=true&VIEW_SIZE=50&VIEW_INDEX=0 In more recent releases the feature has been implemented.
        Jacopo Cappellato made changes -
        Status Reopened [ 4 ] Resolved [ 5 ]
        Resolution Won't Fix [ 2 ]
        Jacopo Cappellato made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        153d 39m 1 Jacques Le Roux 24/Jan/11 11:45
        Closed Closed Reopened Reopened
        48m 2s 1 Jacques Le Roux 24/Jan/11 12:33
        Reopened Reopened Resolved Resolved
        322d 3h 1 Jacopo Cappellato 12/Dec/11 15:34
        Resolved Resolved Closed Closed
        14h 51m 1 Jacopo Cappellato 13/Dec/11 06:26

          People

          • Assignee:
            Jacopo Cappellato
            Reporter:
            Shereen Ashraf
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development