OFBiz
  1. OFBiz
  2. OFBIZ-3445 Layered lookup umbrella main task
  3. OFBIZ-3667

Calendar rendered position too low when you scroll in a layered lookup

    Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Cannot Reproduce
    • Affects Version/s: Trunk
    • Fix Version/s: Trunk
    • Component/s: ALL APPLICATIONS
    • Labels:
      None

      Description

      If you 1st click on the button the position is ok (just below) but if you scroll before and then click the position is to low (seems to follow the scroll)

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Patch Available Patch Available
          1d 23h 43m 1 Atul Vani 12/Apr/10 08:48
          Patch Available Patch Available Closed Closed
          2h 17m 1 Jacques Le Roux 12/Apr/10 11:05
          Closed Closed Reopened Reopened
          84d 10h 52m 2 Jacques Le Roux 06/Jul/10 22:19
          Reopened Reopened Closed Closed
          186d 21h 7m 2 Jacques Le Roux 08/Jan/11 18:05
          Jacques Le Roux made changes -
          Status Reopened [ 4 ] Closed [ 6 ]
          Fix Version/s Release Branch 10.04 [ 12314832 ]
          Resolution Cannot Reproduce [ 5 ]
          Jacques Le Roux added a comment -

          This is now fixed in trunk. The problem remains in 10.04. If someone want to tackle it feel free to open a new Jira issue...

          Jacques Le Roux added a comment -

          This problem does not exist in the jQuery branch. I will personnaly wait the jQuery branch merge...

          Jacques Le Roux made changes -
          Link This issue blocks OFBIZ-3846 [ OFBIZ-3846 ]
          Jacques Le Roux made changes -
          Resolution Fixed [ 1 ]
          Status Closed [ 6 ] Reopened [ 4 ]
          Jacques Le Roux added a comment -

          We have an issue with the change in r949174 and r949175. See OFBIZ-3846

          Jacques Le Roux made changes -
          Link This issue relates to OFBIZ-3806 [ OFBIZ-3806 ]
          Atul Vani added a comment -

          Thanks Jacques

          Regards
          Atul Vani

          Jacques Le Roux made changes -
          Status Reopened [ 4 ] Closed [ 6 ]
          Fix Version/s Release Branch 10.04 [ 12314832 ]
          Resolution Fixed [ 1 ]
          Jacques Le Roux added a comment -

          Thanks Atul,

          Your patch is in trunk at r949174 , R10.04 at r949175

          I noticed the little shift of elements (in the calling form or lookup) too, but it's acceptable IMO and anyway far better than before!

          Atul Vani made changes -
          Attachment layeredCal.patch [ 12445771 ]
          Atul Vani added a comment -

          Hello Jacques, All,

          the patch attached fixes the issue,
          but i noticed some strange behavior (like there's little shifting of elements).

          Thanks & Regards
          Atul Vani

          Atul Vani added a comment -

          hi Jacques,

          it's spreading in the lookups too,
          will dig into the cause & try to find a fix soon (maybe the better way).

          and Thanks to Soumya for reporting

          Jacques Le Roux added a comment -

          BTW, we could eventually have 2 behaviours, one for layers (like we have now) and the old one on other cases. But of course if you find a better solution (ie like it was before, in both cases), it will be better.

          Jacques Le Roux added a comment -

          Thanks for your help Atul!

          Atul Vani added a comment -

          hello Jacques, All,

          the calender's position was made relative which is the cause of the problem as reported by Soumya Jyoti,
          but at the same time calender's parent element's height was set too,
          seem like something's making it ineffective and it's not working as it was while commiting,
          i will look into the problem.

          Thanks & Regards
          Atul Vani

          Jacques Le Roux made changes -
          Resolution Fixed [ 1 ]
          Status Closed [ 6 ] Reopened [ 4 ]
          Jacques Le Roux added a comment -

          We got a small issue reported by Soumya Jyoti Guru at http://markmail.org/message/whb4am3n6ngsuwgk.

          I think Atul's comment was related to that issue...

          Sascha Rodekamp added a comment -

          Thanks Atul & Jacques

          Atul we should keep that in mind... in my opinion there are more important issuses for now, but if you have a small fix for that, without thinking to much about it Feel free to report

          Have a nice day

          sascha

          Jacques Le Roux made changes -
          Status Patch Available [ 10002 ] Closed [ 6 ]
          Assignee Jacques Le Roux [ jacques.le.roux ]
          Fix Version/s SVN trunk [ 12311928 ]
          Resolution Fixed [ 1 ]
          Jacques Le Roux added a comment -

          Thanks Atul,

          Your patch is in trunk at r933169

          I just added some "mod for OFBiz layered lookups" comments around changes as suggested Sascha

          Atul Vani added a comment -

          thanks Sascha,

          well, while developing the fix i found that the logic in calendar_date_select.js to decide whether to show calendar above or below the input field works perfectly for calendars in the page but not for calendars from layered lookup,
          couldn't decide whether this issue is important enough to be reported. anyways...

          Thanks & Regards
          Atul Vani

          Atul Vani made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Sascha Rodekamp added a comment -

          Jep great, seems to work
          Thank you.

          In the future it would be an additional vlaue to mark changes in standard libs, this make them easier to update.

          i.e.
          /* mod for OFBiz ... */
          changes
          /* end mod */

          Have a nice day

          Sascha

          Atul Vani made changes -
          Attachment ScrolledCalendarFix.patch.zip [ 12441452 ]
          Atul Vani added a comment -

          this patch attempts to fix the problem,
          calendar is now relatively positioned,
          and the parent element's height is set appropriately.

          Jacques Le Roux made changes -
          Priority Major [ 3 ] Trivial [ 5 ]
          Jacques Le Roux made changes -
          Field Original Value New Value
          Parent OFBIZ-3445 [ 12455447 ]
          Issue Type Improvement [ 4 ] Sub-task [ 7 ]
          Jacques Le Roux created issue -

            People

            • Assignee:
              Jacques Le Roux
              Reporter:
              Jacques Le Roux
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development