Details

    • Type: Task Task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: SVN trunk
    • Fix Version/s: SVN trunk
    • Component/s: themes
    • Labels:
      None

      Description

      The tomahawk theme is really a huge enhancement, thanks Brainfood (Eric mostly I guess) and Bruno, really great!

      Here are some quirks found here and there. I suspect some are most the lack of consistency in OFBiz underneath (for instance do we really need 3 or more type of buttons, text links, etc.). We may though profit of the current effort to clean that all definitvely

      Jacques

        Issue Links

          Activity

          Jacques Le Roux added a comment -

          This time I don't see anything missing here

          Jacques Le Roux added a comment -

          Nothing left here

          Jacques Le Roux added a comment -

          Maybe what's annoy you is more the ALL COMPONENTS, ALL APPLICATIONS we added?

          Jacques Le Roux added a comment -

          I mean it's ok for themes as long as we don't have more than 5 themes. I'm sure you see my point...

          Jacques Le Roux added a comment -

          I have another way to store this information in the mail client. Anyway in the theme case it's ok with me. There are often many ways to do a thing, and I'm not much for the "fit them all" philosophy, I like freedom

          Scott Gray added a comment -

          Jacques, just click on "themes" from the component list on the main page and you will see your issues, you can even bookmark it if you like so I'm not sure what the problem is.

          The "theme" component is simply replacing your umbrella issue, they both do essentially the same thing.

          Bruno Busco added a comment -

          Oh, sorry!
          I understood Scott was not able to convert the sub-tasks to regular issues while I remembered to be possible and so I did.
          Anyway JIRA has so many way to filter out issues that I agree we do not need umbrella tasks.

          Jacques Le Roux added a comment -

          Bruno, Scott,

          In such cases in future, please at least create a link "is part of" (or from the other side)

          TIA

          Jacques Le Roux added a comment -

          This umbrella task has no meaning anymore

          Jacques Le Roux added a comment -

          Yes that's what Scott wanted (but not me)

          So I will have to use filter too. Umbrella task was much more quick for me, but not a big deal

          The better should be to check that we can't have sub-tasks typed !

          Bruno Busco added a comment - - edited

          I have converted them to simple issues (of type bug). Is this what you meant?

          Jacques Le Roux added a comment -

          You know what: I prefer that We bot both what we want: you can filte on theme, I can find quickly related issues.

          Scott Gray added a comment -

          I've added the theme component and attached each issue to it but jira won't let me convert the sub-tasks to top level tasks so I guess they'll have to stay as is.

          Jacques Le Roux added a comment -

          +1: go for it

          Scott Gray added a comment -

          Instead of:
          Component/s: ALL APPLICATIONS
          we would have:
          Component/s: Themes

          Jacques Le Roux added a comment -

          Not sure to understand what you mean, sorry

          Scott Gray added a comment -

          Or we could just deal with this case and create a component for themes?

          Jacques Le Roux added a comment -

          I see your point now. We should ask the Jira team (infra?) for sub-task types. This is possible http://confluence.atlassian.com/display/JIRA/Creating+a+Sub-Task#CreatingaSub-Task-Creatingasubtask but maybe not with our version (I suppose Academic and Pro seems needed http://forums.atlassian.com/message.jspa?messageID=257227435)

          Scott Gray added a comment -

          I guess it depends on how you are interacting with jira, for example I have predefined filters for bug issue types because I like to fix them in my spare time. Using umbrella tasks hides the actual issues from me because they are sub-tasks.

          Jacques Le Roux added a comment -

          Yes good idea.

          I find also very practical to have all the issues/tasks related to a topic at hand with a single umbrella issue. And I will still need to differentiate from one theme to another. The issues here are only related to Tomahawk.

          Scott Gray added a comment -

          I'm not a fan of umbrella tasks, how about we create a component called 'themes'? There are enough theme related issues for it to be justified IMO.


            People

            • Assignee:
              Jacques Le Roux
              Reporter:
              Jacques Le Roux
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development