Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: SVN trunk
    • Component/s: None
    • Labels:
      None

      Description

      This issue is really a blocker else we need to duplicate a lot of things. I began to work in this direction but after few hours on them I think I will preferably find a real solution than mucking around.

      I was not quite sure this was possible, but as Calendars are also called from layered popups, it seems possible.

      1. fieldlookup.patch
        0.6 kB
        Ankit Jain
      2. ASF.LICENSE.NOT.GRANTED--OFBIZ-3446_LayoutFix.patch
        4 kB
        Sascha Rodekamp
      3. ASF.LICENSE.NOT.GRANTED--OFBIZ-3446_LayoutFix.patch
        4 kB
        Sascha Rodekamp
      4. ASF.LICENSE.NOT.GRANTED--OFBIZ-3446_FixCloseButton.patch
        0.5 kB
        Sascha Rodekamp
      5. lookup.patch
        0.5 kB
        Ankit Jain
      6. OFBIZ-3446_Lookup_in_Lookup.patch
        23 kB
        Sascha Rodekamp
      7. OFBIZ-3446_Lookup_in_Lookup.patch
        19 kB
        Sascha Rodekamp

        Issue Links

          Activity

          Jacques Le Roux added a comment -

          A good example (and maybe the sole, not sure yet) is LookupWorkEffort. I created a LookupWorkEffortPopup but LookupWorkEffort is used all around in OFBiz. (72 instances of "LookupWorkEffort")
          I also wonder if we should not implement something to call a lookup with the "component:..." syntax from target-form-name than handling that in controllers (duplications). Maybe it already works but I did not try nor find an example of usage in OFBiz, to be revisited...

          Scott Gray added a comment -

          Downgraded priority from Blocker to Major, this is not a blocker for the project (which is what the priority refers to).

          Sascha Rodekamp added a comment -

          Hi Jacques, hi *

          here is a first proposal for this issue.

          Jacques your right, this wasn't the easiest bug, i had to rebuild/rethink the lookup layer model.
          I know there are a few bugs in the layout, i will fix it soon.
          This patch should only be for functional testing purposes, maybe someone can review it

          So long
          Sascha

          Jacques Le Roux added a comment -

          Hi Sascha,

          Be sure that I will review and test it as soon as I will get a chance. Also be sure that there will be no conflicts with Bilgin's recent works on aucompletion at OFBIZ-3555
          With these both enhanced features (layered+autocompleter) the lookups will get a new life!

          Jacques Le Roux added a comment -

          Hi Sascha,

          I have not be able to review/test this week as I planned. But 2 persons should begin to test this week and I expect to help also. We are not far from our goal and should release with 10.04(5?)

          Jacques Le Roux added a comment -

          Hi Sascha, all,

          I just quicly tested because I found an issue in the current code when you have a calendar used in a lookup. IIRW before the faded background it was working. But it seems logical that the faded background could have introduced an issue since it "hiddes" all other things.

          By moving the layered lookup you can click/select the calendar. But then, as it's supposed to work, it closes the layered lookup. I guess it's the same problem with other layered lookups called from a layered lookup.

          A good lookup to test is the Requirement Id lookup at the botton of https://localhost:8443/workeffort/control/EditWorkEffort. There you will find calendars and the Product Id lookup
          This suppose to have previously applied the patch at OFBIZ-3442 and then above patch.

          Atul, to allow to easily apply the above patch I have reverted the change introduced at r925632 (OFBIZ-3570).
          ie from
          if (fadeBackground != "false") {
          back to
          if (!fadeBackground != "false") {
          because Sascha also fixed this typo in the above patch

          Hope it's clear, sorry I have no time to help more right now

          Sascha Rodekamp added a comment -

          Hi Jacques,

          sorry for my late answer and thanks for the fix.
          I'm still working on this issue, i try to build a kind of window manager for the different Lookups. The registration works fine, but i have a few issus with identifying the lookup which is focused.

          I hope i find a solution this evening/ night when i'm back in my office.
          I will go on vacation at the end of the week (two weeks to the states ),
          so hopefully i can create a functional version of the lookups this night.

          Have a nice day
          Sascha

          Sascha Rodekamp added a comment -

          Hey Jacques,
          here a new version, seems that it works now

          Cheers
          Sascha

          Jacques Le Roux added a comment -

          Thanks Sascha,

          I will have a look this weekend.

          Have a good trip

          Jacques

          Sascha Rodekamp added a comment -

          Thanks Jacques,

          Have a dive day
          Cheers
          Sascha

          Jacques Le Roux added a comment -

          Thanks Sascha,

          I commited your patch at r928292

          It effectively fixes this issue. And to continue our progression I commited it.

          It does not fix the issue with calendar I reported. I will create a new Jira for that.
          Also it introduces a small drawback: you can't no longer close a layered lookup with the right left cross button. But Esc. is still working, so it's not a blocker. I will have a look at this and if needed will create a new Jira .

          Sascha Rodekamp added a comment -

          Hey Jacques,
          jep thanks for the commit, i noticed the issue with the cross (when you first click somewhere on the layer and then use the close button it works thast it caused by the focusing mechanisem, i will fix it after my vacation!)

          Next step will be the calender issue, we will get it to work i thing!

          Greets from Washington DC
          have a nice day

          Sascha

          Jacques Le Roux added a comment -

          Hi Sascha,

          Thanks for the tip

          Jacques Le Roux added a comment -

          I just found another small issue: if you use the collapse button you finally get caught and can get back to the calling screen.

          Easy to reproduce on
          https://demo-trunk.ofbiz.apache.org/catalog/control/login/main?USERNAME=admin&PASSWORD=ofbiz
          if you select the "Edit Category with Category ID" lookup and then use this button

          Ankit Jain added a comment -

          i just found a issue that value not reaching in the main screen field(AcroForm (PDF) Content ID) after using layer lookup from layer lookup "https://localhost:8443/content/control/FindSurvey"

          Jacques Le Roux added a comment -

          Yes, thanks Ankit. This is weird indeed, since the called lookup works ok and returns the values but then the 1st lookup does return any values. I will have a look.

          Sascha Rodekamp added a comment -

          morning guys, jep that is quiet confusing... maybe jacques you can figure out what happened there, if u haven"t time... i'll write it on my list

          Cheers
          Sascha

          Jacques Le Roux added a comment -

          Sascha,

          Yes, I plan to have a look.

          Jacques Le Roux added a comment -

          Reopened to fix, small issues:

          1. cross button does not work if you don't click on the layer before
          2. the minimize/enlarge buttons (+ -) block the layer
          3. an issue on https://localhost:8443/content/control/FindSurvey
          Ankit Jain added a comment -

          hey jacques i found something on the issue "the minimize/enlarge buttons (+ -)" that in the lookup layer when click on the minimize the background screenlet-body collapse, it is happening because both(main form and the lookup) the screenlet-body "div" having same ids ie.,"hsr1000" which is generated from "HtmlScreenRendere.java" , when the javascript:toggleScreenlet calls the "areaId" is "hsr1000 that's why both collapse.....

          Ankit Jain added a comment -

          hi jacques,
          here's a patch that aims to fix the bug,
          the actual problem i diagnosed was that the value of obj_caller.target wasn't being updated when the new layered lookup (the one that's get poped up from existing one) is closed, so here's the fix

          Jacques Le Roux added a comment -

          Thanks Ankit,

          Your patch is in trunk at r929508

          Ankit Jain added a comment -

          Thanks jacques!

          Sascha Rodekamp added a comment -

          Here is the fix for the close button issue.

          Jacques Le Roux added a comment -

          Thanks Sascha,

          Your patch is in trunk at r933170. I will soon close this issue and will open some new ones for other things I found. I'm almost ready to commit all to trunk and will update the demo server with it. Because it seems now things are pretty stable and we need more testing power...

          The only things which is still blocking is a specific case of this issue: recursive layered lookups callbacks. I found a simple workaround for that but there is another issue which seems related to the point 2 reported above (the minimize/enlarge buttons (+ -) block the layer). I will create an issue an attach my patch this afternoon (it's noon here ;o)

          Sascha Rodekamp added a comment -

          Here a patch for the layout issues in the Themes != Tomahawk.

          Jacques Le Roux added a comment -

          HI Sascha,

          Could you describe the issues you fixed with this patch?

          Thanks

          Sascha Rodekamp added a comment -

          The patch fixes following layout bugs in all all themes except Tomahawk.

          Lookup Image will not displaied for lookup in lokkups
          lookups that are opened from lookups have layout bugs in the surch buttons (it shows the lookup image)

          So long

          Sascha

          Jacques Le Roux added a comment -

          Great, thanks Sascha,

          I asked that because I already did a bunch of changes for OFBIZ-3656 at r932619, but yes found the 2d issue you reported coming from those changes

          Jacques Le Roux added a comment -

          Sascha,

          I continue here tough not all is specifically related to "lookup in lookup"

          Could you complete your patch for

          • flat grey
            • next-last buttons (only in "lookup in lookup" it seems)
            • not a big deal but we lost the blue color on links in the returned list, and on some buttons too (submit)
          • dropping crumbs, blue light, bizzness time
            • color on links in the returned list, and on some buttons too (find, submit, ...?)

          Thanks

          Sascha Rodekamp added a comment -

          Hi Jacques,
          i extend my previous patch.
          color issuses for buttons and links in flat grey, dropping crumbs, blue light, bizzness time fixed.
          next-last buttons in flat grey seems to be ok.

          So long
          Sascha

          Jacques Le Roux added a comment -

          Thanks Sascha,

          I confirm there no longer any layer issues, I commited your patch in trunk at r933586.

          However it seems that the FindSurvey bug reported and fixed by Ankit above is back again. Not totally sure because I find that sometimes even using Ctrl+F5 does not empty completly the Firefox cache (at least the CSS part it seems). Anyway I will just try with Opera... Yes I confirm: same with Opera

          Ankit Jain added a comment -

          Hi Jacques,
          i tried FindSurvey it's working in both opera & Firefox properly, i dont know whats the reason at your side....?

          Thanks

          Jacques Le Roux added a comment -

          Thanks Ankit,

          I suppose you tried with the last trunk version. Then I guess it's some changes I have in my current code, I will check

          Ankit Jain added a comment -

          Jacques,
          I tried it on the latest revision and its working.

          I want to report another issue "the image for the collapse/minimize in the lookup is hide by the fieldlookup image " this image is also overlap over "Find" button and it is also coming in the find results in all the themes (as i find it is due the the fieldlookup image(fieldlookup.gif) override the button image(btn-bg.gif) in the css )& in the tom hawk theme the position of that minimize image is also not at its appropriate place.......

          Thanks

          Jacques Le Roux added a comment -

          Ankit,

          Could you please post a patch with the changes you did (related to layer lookup) in order to help track the reason for finSurvey. I guess I have an idea (I try to generalize theuse) but it would be certainly helpfull to compare with yours. Also, where do you see the above issue (URL+theme at least)?

          Thanks

          Ankit Jain added a comment -

          jacques,

          i'd attached the patch for the FindSurvey,
          This is the link for the issue https://localhost:8443/content/control/FindSurvey in bizznesstime theme, this issue is in all themes. when we use layer lookup you can see the issue which i mentioned before.
          one thing i want to remind you is that you have to change the lookup to layerlookup(presentation="layer") in applications/content/webapp/content/survey/SurveyForms.xml

          Thanks

          Jacques Le Roux added a comment -

          Thanks Ankit,

          Actually this patch is already in trunk, I committed it at r929508 (see some comments above). Actually you answered my question. As I suspected you use presentation="layer" when I now work (for more than a week actually) without any changes in the forms (ie no presentation="layer", nor position="center", like I had before in the temporary-demonstative-testing patch I submitted at OFBIZ-3442). I think it's time to share my work and I will submit a new patch there with less much changes and still some issues to face it seems. When we will be all on the same page it will be easier to go to the end of this work as we are facing only small issues now.

          Ankit Jain added a comment -

          hi jacques,

          finally you sort out the problem.....its great that we are reaching to the end.

          Thanks!

          Sascha Rodekamp added a comment -

          Good morning Jacques & Ankit,

          great job ... so we are ready for the next step ??

          Have a nice day

          Sascha

          Jacques Le Roux added a comment -

          Hi Sascah, Ankit, All,

          I have posted a new much more simple patch at OFBIZ-3442. As ever all testing good wills are really appreciated.

          Thanks

          Ankit Jain added a comment -

          Hi Jacques & Sascha

          Jacques, I review your patch & its good & i dont think any other changes needed in it, and i also try to look in that issues.......

          Thanks for the patch

          Jacques Le Roux added a comment -

          I think I will commit the patch. But I will also add all needed presentation="window" as far as I know. I just discovered another case, but anyway there is a way to find almost (if not all) cases. Then we will have the feature in trunk (and 10.0?) and we will get more help from users if we miss some issues. Should be this weekend...

          Jacques Le Roux added a comment -

          Ankit,

          I just had a quick look, should we not add the same change you made to
          function set_value (value) {
          at
          function set_values (value, value2) {
          ie the
          obj_caller.target = $(GLOBAL_LOOKUP_REF.getReference(ACTIVATED_LOOKUP).parentTarget.id);
          line?
          And then what for target2?

          Note that Idid not review the code in detail, it's just a question.

          Thanks

          Ankit Jain added a comment -

          Hi Jacques,

          Sorry for the late reply, i was quite busy so i didn't looked into it.
          Yes, we have to make the same changes in set_values(value,value2) as in set_value(value)....
          because when we open a layered lookup inside a layered lookup then the target value is replaced by new target i am adding a link for it so can see it

          https://localhost:8443/example/control/FormWidgetExamples

          and finally here is the patch which resolves it.

          Thanks for reminding me

          Jacques Le Roux added a comment -

          Thanks Ankit,

          I have applied your patch in trunk at r940309, R 10.04 at r940313

          Actually I commented out your change since I did not find any real effect, as you can see in the link you suggested. What was supposed to be fixed by your patch?

          Also I wondered if we should not have the same for var target2 = obj_caller.target2;

          Jacques Le Roux added a comment -

          Note that at this stage it seems that we have some side effect. For instance at r940248 I have fixed a bug related to this issue by adding position="center" to the lookup called. It should not have any effects on the issue but it has... to investigate further...

          Ankit Jain added a comment -

          Thanks Jacques,

          here i explained you in detail so you get easily what i fixed ,

          Use the link https://localhost:8443/example/control/FormWidgetExamples here you find a heading Examples Lookup Fields (first of type popup, second layered) . When you open the layered lookup and click on find and selecting any value the values of the fields "name" & "partyIdTo" is shown, but if you open layered lookup inside the layered lookup and select a value then the value shown in the first layered lookup field and finally selecting a value from the list the value of "name" filed is missing in the main form from where the lookup called.

          It is because the target value of the first lookup is replaced by the target value of the second lookup, that's why we have to use this(obj_caller.target = $(GLOBAL_LOOKUP_REF.getReference(ACTIVATED_LOOKUP).parentTarget.id) in the set_values(value, value2) you can also see the changes after applying my patch.

          Yet, It is not needed for target2 because it is used only once so its value is not replaced , but in future we can use it if needed .
          I think now it will clear you what i fixed.
          So we have to uncomment that line for working it properly. Here is the patch for that.

          Jacques Le Roux added a comment -

          Thanks Ankit,

          Indeed, I did not notice it was not returning the name value, when I was 1st asking for it some comments above. I was certainly tired, focused on another problem and did not remember the reason why I asked , my apologies.

          It's fixed at r940401 in trunk and r940402 in R10.04

          Ankit Jain added a comment -

          Hi jacques,

          No problem & Thanks

          Jacques Le Roux added a comment -

          Now a duplicate of OFBIZ-3768. It's hard to read: a lot of unrelated things here. Please Sascha watch now OFBIZ-3768 instead

          Thanks guys for your help!


            People

            • Assignee:
              Jacques Le Roux
              Reporter:
              Jacques Le Roux
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development