OFBiz
  1. OFBiz
  2. OFBIZ-3329

commonext component has dependency on party management component

    Details

    • Type: Bug Bug
    • Status: Reopened
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: Trunk
    • Fix Version/s: None
    • Component/s: commonext/setup
    • Labels:
      None
    • Sprint:
      Bug Crush Event - 21/2/2015

      Description

      I've just tried commenting out all components except commonext on trunk (i.e. in component-load.xml).

      I ran the ant tasks create-admin-user-login, then run and then tried to
      access the url https://localhost:8443/webtools/

      I received the following error message:

      org.ofbiz.widget.screen.ScreenRenderException: Error rendering
      screen component://common/widget/CommonScreens.xml#GlobalDecorator:
      org.ofbiz.base.util.GeneralException: Error running Groovy script at
      location [component://commonext/script/changeOrgPartyId.groovy] (Could
      not find definition for entity name PartyAcctgPrefAndGroup) (Error
      running Groovy script at location
      [component://commonext/script/changeOrgPartyId.groovy] (Could not find
      definition for entity name PartyAcctgPrefAndGroup))

      It seems that commonext has a dependency on the party component. I'm not sure is this is an issue - is there any guidelines on what dependencies can go in commonext?

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open In Progress In Progress
          1772d 13h 31m 1 Anil K Patel 18/Oct/14 12:43
          Resolved Resolved Reopened Reopened
          58s 1 Anil K Patel 18/Oct/14 12:47
          Reopened Reopened Patch Available Patch Available
          2h 2m 1 Divesh Dutta 18/Oct/14 14:49
          Patch Available Patch Available In Progress In Progress
          22m 45s 1 Anil K Patel 18/Oct/14 15:12
          In Progress In Progress Resolved Resolved
          8m 2 Anil K Patel 18/Oct/14 15:17
          Resolved Resolved Closed Closed
          7s 1 Anil K Patel 18/Oct/14 15:17
          Closed Closed Reopened Reopened
          35m 12s 1 Anil K Patel 18/Oct/14 15:52
          Sharan Foga made changes -
          Rank Ranked higher
          Sharan Foga made changes -
          Rank Ranked higher
          Sharan Foga made changes -
          Rank Ranked higher
          Sharan Foga made changes -
          Sprint Bug Crush Event - 21/2/2015 [ 91 ]
          Anil K Patel made changes -
          Resolution Fixed [ 1 ]
          Status Closed [ 6 ] Reopened [ 4 ]
          Anil K Patel added a comment -

          We will discuss part of the code changes made in previous commit related to this issue. Its possible that we will revert partial code change.

          Anil K Patel made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Anil K Patel made changes -
          Status In Progress [ 3 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Anil K Patel added a comment -

          Fix applied to Trunk and Release 13.07.
          Thanks Divesh, Mridul for fix and Adrian and Chris for reporting the issue.

          Anil K Patel made changes -
          Status Patch Available [ 10002 ] In Progress [ 3 ]
          Divesh Dutta added a comment -


          OFBiz-3329-trunk.patch should also work on OFBiz 13.07

          Divesh Dutta made changes -
          Attachment OFBiz-3329-trunk.patch [ 12675674 ]
          Divesh Dutta added a comment -

          Removing dependency of framework component from commonext component:

          1) Ui labels of CommonExtUiLabels are not used in common component. so not loading Ui labels of CommonExtUiLabels in LookupDecorator of HelpScreens.xml

          2) When ant create-component is used basic component is set up in hot-deploy. So when component is created, main-decorator refers to ApplicationDecorator of CommonExt component because it refers to main-decorator of framework/resources/templates/CommonScreens.xml . And main-decorator of framework/resources/templates/CommonScreens.xml was referring to ApplicationDecorator of CommonExt component. So used Global Decorator instead of ApplicationDecorator. One who will be using the ant create-component can make changes in his custom CommonScreens.xml to use decorator of his choice.

          Divesh Dutta made changes -
          Status Reopened [ 4 ] Patch Available [ 10002 ]
          Anil K Patel made changes -
          Comment [ Looking at the conversation on the task, We can close this issue. There is nothing to be fixed.
          IMO: This application is special purpose, and should live in specialpurpose folder. ]
          Anil K Patel made changes -
          Resolution Fixed [ 1 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          Anil K Patel made changes -
          Status In Progress [ 3 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Anil K Patel made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          Anil K Patel made changes -
          Assignee Anil K Patel [ anilpatel ]
          Divesh Dutta added a comment -

          Thanks Jacques Le Roux for your views. I discussed with Arun Patidar internally as he recently researched on use of Common ext component. As you mentioned that its a set up component, he also found that:

          'commonext' component can be use to setup organization party, store, website, facility, catalog, category, product and customer over the seed data of OFBiz. We can only create single record for each using this component.

          So when ever you don't want to use demo data of OFBiz and set up your own/ext data or your client's data you can use commonext component to set up that data.

          So I think its OKAY that commonext component having dependency on other applications's component as its used to set up various set of data.

          So we can discard this issue now.

          Thanks all for discussions and helping in conclusions

          Jacques Le Roux added a comment -

          Oops sorry Deepak, Divesh, fixed.

          I should not work too late

          Deepak Dixit added a comment -

          Small typo in name
          "Quoting Deepak on dev ML" ==> "Quoting Divesh on dev ML"

          Jacques Le Roux added a comment - - edited

          Quoting Divesh Dutta on dev ML

          Today we looked in OFBIZ-3329 . Its 5 years old issue. OFBiz community have put lots of efforts in moving some of the components in special-purose. Did we conclude any thing about “commonext” component in “applications” ? I think its more of demo component to show how can you extend any application in OFBiz.

          Is commonest component is good candidate for moving in special-purpose folder ?

          I thought the commonext component was put by Hans for the Setup component (I know it's used by it). But it seems it was really committed (at http://svn.apache.org/viewvc?view=revision&revision=748144) as a "common component for applications".

          I know this component is also used by other applications components and I see not need to remove it but dependencies to it from framework should be removed of course, as dependencies from it to other applicationd component, though this is IMO less an issue, since we tolerate dependency between applications component

          Divesh Dutta added a comment -

          Started conversation on dev mailing list with subject line "Conclusion on OFBIZ-3329"

          Gavin made changes -
          Workflow jira [ 12484396 ] OFbiz Workflow [ 12507192 ]
          Bruno Busco made changes -
          Link This issue is part of OFBIZ-1867 [ OFBIZ-1867 ]
          Bruno Busco made changes -
          Link This issue is blocked by OFBIZ-1867 [ OFBIZ-1867 ]
          Bruno Busco made changes -
          Field Original Value New Value
          Link This issue is blocked by OFBIZ-1867 [ OFBIZ-1867 ]
          Adrian Crum added a comment -

          That screen would have to be moved to the framework - along with any other security-related screens.

          chris snow added a comment -

          I assumed that this commonext was being used to display the password change screen for the admin user?

          Adrian Crum added a comment -

          I think the problem is more fundamental. Why does Webtools need the commonext component? It seems to me that is an inappropriate dependency.

          If the goal is to get the framework to run independently, then we can't have any components in the applications folder enabled.

          chris snow created issue -

            People

            • Assignee:
              Anil K Patel
              Reporter:
              chris snow
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:

                Development

                  Agile