Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: SVN trunk
    • Fix Version/s: SVN trunk
    • Component/s: framework
    • Labels:
      None

      Description

      I have created another response attribute "view-last-noparam" that has functionality of view-last but without last parameters like "request-redirect-noparam".
      Could it be useful?

        Activity

        Jacques Le Roux made changes -
        Status Reopened [ 4 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        Jacques Le Roux added a comment -

        No longer a concern if status-code 303 is used

        Jacques Le Roux added a comment -

        I believe this will be fixed when we will use status-code. Indeed the 303 code redirect with a GET so the POST method will be dropped. So the solution (to be confirmed when OFBIZ-5109 will becommitted) here is to set a status-code="303"

        Jacques Le Roux added a comment -

        This is interesting in the context of OFBIZ-5109. I will get back to this later...

        Bruno Busco made changes -
        Resolution Fixed [ 1 ]
        Status Closed [ 6 ] Reopened [ 4 ]
        Bruno Busco added a comment -

        Hi,
        it seems that the view-last-noparam just works (resets the parameters) if it is used with a request that has the parameters in the URL.

        Since we have now moved to form submitted parameters I found that the view-last-noparam is not able to remove the parameters from the context.
        Does anyone have any idea of how to fix this?

        Gavin made changes -
        Workflow jira [ 12479170 ] OFbiz Workflow [ 12505965 ]
        Matarazzo Angelo added a comment -

        Thank you Jacques.
        It's true.

        Adam Heath committed 883933 (1 file)
        Reviews: none

        In the Product/Parties screen, the link to the related party was broken.
        Instead of showing the related party, it would show the user who was
        logged into the partymgr backend. The patch that fixed this was
        provided by Ean Schuessler in
        (https://issues.apache.org/jira/browse/OFBIZ-3027) OFBIZ-3027

        Jan le Roux committed 883915 (1 file)
        Reviews: none

        I forgot to improve Angelo Matarazzo's patch I committed for "view-last-noparam" (https://issues.apache.org/jira/browse/OFBIZ-3027) - OFBIZ-3027 in r829727

        Jacques Le Roux added a comment -

        Hi Angelo,

        Something we both missed when you created and I commited your patch: the site-conf.xsd update. It's done in revision 883914.

        Jan le Roux committed 883914 (1 file)
        Reviews: none

        I forgot to improve Angelo Matarazzo's patch I committed for "view-last-noparam" (https://issues.apache.org/jira/browse/OFBIZ-3027) - OFBIZ-3027 in r829727

        Jacques Le Roux made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Assignee Jacques Le Roux [ jacques.le.roux ]
        Resolution Fixed [ 1 ]
        Jacques Le Roux added a comment -

        Thanks Angelo,

        Your patch is in trunk at r829727

        Jan le Roux committed 829727 (1 file)
        Reviews: none

        A patch from Angelo Matarazzo "Add view-last-noparam" (https://issues.apache.org/jira/browse/OFBIZ-3027) - OFBIZ-3027
        "view-last-noparam" has functionality of view-last but without last parameters like "request-redirect-noparam".

        I' m using this attribute because in my application all the screens are linked to a field in the context. that I call "commonValue". I have a link in the common header that change the value of this field but when I click this link the screen must not change but the field of current screen must be cleaned. By this attribute the view is set at " last-view" but the last parameters are cleaned.

        Matarazzo Angelo added a comment -

        I' m using this attribute because in my application all the screens are linked to a field in the context. that I call "commonValue"
        I have a link in the common header that change the value of this field but when I click this link the screen must not change but the field of current screen must cleaned.
        By this attribute the view is set at " last-view" but the last parameters are cleaned.
        I think this is same approach of "request-redirect-noparam". Perhaps it won' t often be used but could be useful.
        Or not?

        Jacques Le Roux added a comment -

        Hi Angelo,

        Why did you created it, how and when are you using it ?

        Thanks

        Matarazzo Angelo made changes -
        Field Original Value New Value
        Attachment view-last-noparam.patch [ 12421830 ]
        Matarazzo Angelo created issue -

          People

          • Assignee:
            Jacques Le Roux
            Reporter:
            Matarazzo Angelo
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development