OFBiz
  1. OFBiz
  2. OFBIZ-2989

purchase invoice posting only creates one transaction of the double entry.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Not A Problem
    • Affects Version/s: Trunk
    • Fix Version/s: None
    • Component/s: accounting
    • Labels:
      None
    • Environment:

      demo.ofbiz.org

      Description

      Steps to reproduct:
      ===============

      In Accounting application, create new Purchase Invoice

      Invoice Type: Purchase Invoice
      Org Party Id: Your Company Name Here
      From Party ID: BigSupplier

      Click "Create".

      Select Items. Add a new invoice Item

      Invoice Item Type: Invoice Sales Tax
      Quantity: 1
      Unit Price: 1

      Click "Add"

      Click "Status to 'Ready'".

      Only one transaction is entered. I would expect an error to be generated if account mapping not found for "Invoice Sales Tax" Invoice Item Type.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open In Progress In Progress
        1741d 9h 58m 1 Jacopo Cappellato 09/Jul/14 08:27
        In Progress In Progress Resolved Resolved
        1m 55s 1 Jacopo Cappellato 09/Jul/14 08:29
        Resolved Resolved Closed Closed
        7s 1 Jacopo Cappellato 09/Jul/14 08:29
        Jacopo Cappellato made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Jacopo Cappellato made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Resolution Not a Problem [ 8 ]
        Jacopo Cappellato added a comment -

        The transaction is created but due to the missing configuration setup the GL account for the tax is not found: as a consequence the transaction is created but NOT posted; it requires a manual step from an accountant to complete it and post.
        This is the expected behavior.

        Jacopo Cappellato made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Jacopo Cappellato made changes -
        Assignee Jacopo Cappellato [ jacopoc ]
        Gavin made changes -
        Field Original Value New Value
        Workflow jira [ 12478434 ] OFbiz Workflow [ 12507065 ]
        chris snow created issue -

          People

          • Assignee:
            Jacopo Cappellato
            Reporter:
            chris snow
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development