OFBiz
  1. OFBiz
  2. OFBIZ-2837

Wildcard (%) characters in search fields are manipulated/truncated in screens throughout the system

    Details

    • Type: Bug Bug
    • Status: Reopened
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: Trunk
    • Fix Version/s: None
    • Component/s: ALL COMPONENTS
    • Labels:
      None
    • Sprint:
      Bug Crush Event - 21/2/2015

      Description

      Original thread from Nabble:
      http://www.nabble.com/-CA-bug-td24764527.html#a24764527

      Examples:
      02S%000 - I searched on this string in the orderId field of OrderHeader in entity data maintenance. Got an error on this one:
      (ERROR: invalid byte sequence for encoding "UTF8": 0x00)

      When I shorten it or change it up a bit I don't get the error but the % get's replaced with a space and I get no results. For example:
      02S%09070201 gets replaced with 02S 070201 (the % and 09 were removed).

        Activity

        Vince Clark created issue -
        Gavin made changes -
        Field Original Value New Value
        Workflow jira [ 12473405 ] OFbiz Workflow [ 12505051 ]
        Jacques Le Roux added a comment -

        Not quite sure but this seems related to OFBIZ-2628

        Markus M. May added a comment - - edited

        I am having the same issue with special characters (Umlaute) in the search field still. Probably still an issue with OFIBZ-2628 ?

        Jacques Le Roux added a comment -

        Reopen if it's not an OFBIZ-2868 duplicate

        Jacques Le Roux made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Duplicate [ 3 ]
        Jacques Le Roux made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Jacques Le Roux added a comment - - edited

        This is actually not a duplicate of OFBIZ-2628 said Sascha

        Jacques Le Roux made changes -
        Resolution Duplicate [ 3 ]
        Status Closed [ 6 ] Reopened [ 4 ]
        Sebastian Wachinger added a comment -

        Please see my comment on OFBIZ-4535

        Jacques Le Roux made changes -
        Link This issue relates to OFBIZ-4535 [ OFBIZ-4535 ]
        Jacques Le Roux made changes -
        Link This issue is related to OFBIZ-5312 [ OFBIZ-5312 ]
        Jacques Le Roux made changes -
        Link This issue depends upon OFBIZ-5312 [ OFBIZ-5312 ]
        Jacques Le Roux added a comment -

        Hi,

        If someone is still interested by this isue please try to make searches with special characters using the new branch https://svn.apache.org/repos/asf/ofbiz/branches/OFBIZ-5312-ofbiz-ecommerce-seo-2013-10-23 ?

        Else I will consider this issue as a duplicate of OFBIZ-4535

        Jacques Le Roux made changes -
        Link This issue is related to OFBIZ-5312 [ OFBIZ-5312 ]
        Jacques Le Roux added a comment -

        This, like OFBIZ-4535, should be solved by OFBIZ-5312. I actually believe OFBIZ-4535 is a duplicate of this one. To be cleaned later with the merge of the SEO branch in trunk...

        Jacopo Cappellato made changes -
        Priority Critical [ 2 ] Major [ 3 ]
        Jacques Le Roux made changes -
        Link This issue depends upon OFBIZ-5312 [ OFBIZ-5312 ]
        Jacques Le Roux made changes -
        Link This issue relates to OFBIZ-4535 [ OFBIZ-4535 ]
        Jacques Le Roux added a comment -

        I can't reproduce the case 1, but the 2nd still exist and is not related with either OFBIZ-5312 nor OFBIZ-4535

        Sharan Foga made changes -
        Sprint Bug Crush Event - 21/2/2015 [ 91 ]
        Sharan Foga made changes -
        Rank Ranked higher
        Sharan Foga made changes -
        Rank Ranked higher
        Sharan Foga made changes -
        Rank Ranked higher

          People

          • Assignee:
            Unassigned
            Reporter:
            Vince Clark
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:

              Development

                Agile