OFBiz
  1. OFBiz
  2. OFBIZ-252

ecommerce customer survey error return wipes out entries

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None

      Description

      Copy of an issue reported by Les Austin in the old server:

      After taking the effort to complete a survey, if the customer did not properly specify a URL (which is not requested on the survey screen), he gets the error message:
      "The following errors occurred:

      • What is your favorite on-line store? requires a valid URL"

      Furthermore, all of his entries are stripped so he must complete the form again if he feels like it. This reduces the effectiveness of the survey, and erodes confidence in the application itself, IMO.

      Either the request for his favorite on-line store needs to state explicity that he enter a valid URL or the error processing mechanism needs to retain his original survey, allowing him to make only the one correction.

        Activity

        Jacopo Cappellato created issue -
        Gavin made changes -
        Field Original Value New Value
        Workflow jira [ 12383564 ] OFbiz Workflow [ 12504414 ]
        Pranay Pandey made changes -
        Assignee Pranay Pandey [ pandeypranay ]
        Amardeep Singh Jhajj added a comment - - edited

        Steps followed:
        1. Go to ecommerce store.
        2. Click on Profile link.
        3) Click on Take Survey button.
        3. Submit the survey using no URL and with URL http://www.google.com.

        Survey submit successfully and it is showing proper survey answer. Hence, unable to regenerate the issue.

        Pranay Pandey added a comment -

        Thanks Amardeep for digging in and providing details. This issue is not reproducible.

        Pranay Pandey made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Cannot Reproduce [ 5 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        3048d 10h 1m 1 Pranay Pandey 17/Jan/15 14:36

          People

          • Assignee:
            Pranay Pandey
            Reporter:
            Jacopo Cappellato
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development