OFBiz
  1. OFBiz
  2. OFBIZ-2410

EditShipmentRouteSegments does not show the package.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: Trunk
    • Fix Version/s: None
    • Component/s: product
    • Labels:
      None
    • Environment:

      redhat, postgres

      Description

      Hi,

      The EditShipmentRouteSegments, does not show the order package(s), at the link https://www.example.com/facility/control/EditShipmentRouteSegments?shipmentId=10010

      The bug was probably introduced with the migration of this file EditShipmentRouteSegments.bsh from bsh to groovy.

      shipmentId = request.getParameter("shipmentId");

      if (!shipmentId)

      { shipmentId = context.shipmentId; }

      shipment = null;
      if (!shipmentId)

      { shipment = delegator.findOne("Shipment", [shipmentId : shipmentId], false); }

      1. OrderShipmentRouteSegement.png
        87 kB
        HotWax Media OFBiz Team
      2. Package.png
        94 kB
        HotWax Media OFBiz Team

        Activity

        Rohit Sureka created issue -
        Gavin made changes -
        Field Original Value New Value
        Workflow jira [ 12462410 ] OFbiz Workflow [ 12506631 ]
        HotWax Media OFBiz Team added a comment -

        It looks like issue is no more exists. I created a SO and packed it. I was able to see the packages. Please see the attached screen shots.

        HotWax Media OFBiz Team made changes -
        Attachment OrderShipmentRouteSegement.png [ 12662295 ]
        HotWax Media OFBiz Team made changes -
        Attachment Package.png [ 12662296 ]
        Anil K Patel made changes -
        Assignee Anil K Patel [ anilpatel ]
        Anil K Patel made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Anil K Patel added a comment -

        Unable reproduce. Cannot fix the issue. Thanks ofbiz.us team for help.

        Anil K Patel made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Anil K Patel made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open In Progress In Progress
        1932d 20h 30m 1 Anil K Patel 16/Aug/14 16:19
        In Progress In Progress Resolved Resolved
        41s 1 Anil K Patel 16/Aug/14 16:20
        Resolved Resolved Closed Closed
        7s 1 Anil K Patel 16/Aug/14 16:20

          People

          • Assignee:
            Anil K Patel
            Reporter:
            Rohit Sureka
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development