OFBiz
  1. OFBiz
  2. OFBIZ-1978

createShipment parameters : add a shipmentId in IN parameters

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Trunk
    • Component/s: product
    • Labels:
      None

      Description

      In Shipment services, the service of creation, called createShipment, don't accept our own shipmentId. It can be a problem in some business, and I think it won't be difficult to add a IN parameter shipmentId.
      So, I propose to change the service and use a shipmentId given by default, and if there is no shipmentId in parameters, it will get the next sequenced id (as it already done in the createShipment service).

      1. shipment.patch
        2 kB
        Nicolas Malin

        Activity

        Bilgin Ibryam added a comment -

        Jacques, you mean harmless probably

        Jacques Le Roux added a comment - - edited

        Thanks Charles and Nicolas,

        This makes sense indeed and is harmless anyway.
        Your patch is commited in revision: 702232

        Nicolas Malin added a comment -

        The problem is present when ofbiz is a slave on shipment system.
        He receive order from the master to send package with given shipmentId. It's more easier in ofbiz to create the shipment with a shipmentId given by the master.


          People

          • Assignee:
            Jacques Le Roux
            Reporter:
            Charles STELTZLEN
          • Votes:
            3 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 0.5h
              0.5h
              Remaining:
              Remaining Estimate - 0.5h
              0.5h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development