OFBiz
  1. OFBiz
  2. OFBIZ-181

In Microsoft Internet Explorer the ecommain.css is not parsed correctly

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: SVN trunk
    • Fix Version/s: SVN trunk
    • Labels:
      None
    • Environment:

      Windows

      Description

      In the ecommerce application using Internet Explorer same pages are not correctly show on screen due to a bug of Internet Explorer that doesn't parse correctly some css file.
      In particular those class into the ecommain.css are not correctly interpreted due to the use of the tag voice-family without the widht tag inside a class.

      rightonly
      leftonly
      center
      nocolumns
      ecom-header

      Some documentation to work-around and solve the issue can be found on this site:
      http://tantek.com/CSS/Examples/boxmodelhack.html

      So I have tried this work-around and it works now correctly.
      Can someone test it also on other browse like Firefox, Opera, Safari, ... and then if everything is ok apply this patch.

      Thanks a lot
      Marco Risaliti

      1. css_for_explore5.patch
        1 kB
        Marco Risaliti
      2. ecomPeekaboo.patch
        2 kB
        Chris Howe
      3. ofbiz_logo.jpg
        6 kB
        Jacques Le Roux
      4. tabstyle_for_explorer.css
        0.7 kB
        Marco Risaliti

        Issue Links

          Activity

          Marco Risaliti added a comment -

          I forgot to say that the patch contains also some improvement for i18n of the ecommerce application.

          Thanks
          Marco

          Jacques Le Roux added a comment -

          I tried using Firefox and IE Tab plugin (to view IE in Firefox). It seems ok to me. I vote for.

          There is always a litle problem in Firefox when showing cart. The first title (Quick Add Continue Shopping Checkout) is truncated at bottom. I suggested a css patch some time ago (ok also in IE, I did not test Opera nor Safari). It could be integrated with this. For that I propose a new patch.

          The ecommain.css part is enhanced by my modification which is :
          @@ -230,7 +235,7 @@
          #ecom-mainarea .screenlet-header

          { background: #000099; padding-top: 1px; -padding-bottom: 1px; +padding-bottom: 3px; padding-right: 4px; padding-left: 4px; }
          Jacques Le Roux added a comment -

          css_for_explorer.patch2 replaces css_for_explorer.patch (little css enhancement)

          David E. Jones added a comment -

          Thanks for working on this stuff Marco and Jacques. The CSS in ecommerce certainly needs a lot of work and it's great to see effort going into this. I'm not a CSS expert, so I'd push for more feedback but given that the CSS in ecommerce has problems right now, I think just throwing it in is the best way to go. Once in SVN chances are more people will look at it and we'll get more feedback then (the good old commit and review process again...).

          Jacques Le Roux added a comment -

          Please Marco take care with your patches. In this one the last 2 files had an incomplete path.

          Thanks for your work, it was a long time I was hoping for some progress in this area. Some may think that's it's only a demo UI, but one may not forget that it's our window open on the world :o)

          In OFBiz rev 436946.

          I'm reading "Designing With Web Standards, 2nd edition" (french edition ;o) from Jeffrey Zeldman and I encourage everybody interested in this area to read this book, please see http://www.zeldman.com/dwws/

          Marco Risaliti added a comment -

          I have test it again and seems to be ok.

          Thanks a lot Jacques for your work and your promptly reply to this issue.

          Jacques Le Roux added a comment -

          I just tried in Opera (using OperaVIew in Firefox), it's ok too. It's the 1st time I use Opera : fast !

          If someone could test in Camino/Safari ... (even if we already used the CTR process).

          One point, in IE 6 (perhaps IE 7 will get rid of that ?) there is the PNG transparency problem. We have already gif files in svn. But are we abilited to transform this files in gif format to get rid of this grey background when using IE ? Or is there another option we may use like this one (sorry french but the last images seen in IE speaks for itself) : http://www.pim.asso.fr/pages_externes/tth/faq_tutos/png/png32_a_ie.html

          Thanks

          BTW I saw for the 1st time the OFBiz's demo official "Store Policies", not bad ;o)

          Jacques Le Roux added a comment -

          Sorry above by "this files" I mean png product files. In the link, to see transparency in IE move the logo at end of page.

          Chris Howe added a comment -

          for png i use this javascript solution

          http://homepage.ntlworld.com/bobosola/pnghowto.htm

          the author doesn't give license information...so who knows...

          on the more info page there are alternative solutions

          Jacques Le Roux added a comment -

          Thanks Chris,

          In the info page I found this reference that sound better http://www.daltonlp.com/daltonlp.cgi?item_type=1&item_id=217 (only CSS).

          We may use it in OFBiz, what do you think folks ?

          Chris Howe added a comment -

          I saw that one too. I'm concerned on the link bug that he describes on that page as well as the other issues that are described in the comments section of that page.

          David E. Jones added a comment -

          I just did some quick (very cursory) tests of ecommerce in Firefox 1.5.0.6 and there are some issues with this change... The width of the center column is restricted and for very wide screens results in a big white space to the right of the column. Also, when the window is more narrow there is no padding between the center column and the right column.

          Jacques Le Roux added a comment -

          I propose to test it only on product images in eCommerce. We will see then. Anyway it seems that there is no "good" patch for this problem but IE 7 !

          I often wonder why Micro$oft do nothing for such a long time for so well known problems like this. Marketing certainly, sometimes I hate statistics

          Marco Risaliti added a comment -

          I have download and install now Firefox 1.5.0.6 and in my Laptop there are not any problems.
          Could you please tell me in details which screen is still affected to this issue so that I can investigate and solve the problem.

          Thanks a lot
          Marco

          Marco Risaliti added a comment -

          In case the issue is due to the explict use of fixed number of pixels we can use percentage.

          Jacques Le Roux added a comment -

          Yes David,

          I can see this too.

          Marco I think David has already well explained the problem : no padding between content (colum in the center : products) and the right column ( view car, checkout, etc). For instance, when the window is progressively narrowed the phenomenon is easily visible. However I'm not sure this was OK before : I did not try with a revert.

          Jacques Le Roux added a comment -

          Sorry Marco but there is more than that.

          Under IE if you open and close your favorites, the cart (or the products column) is moving under the last boxe of the left column (when the favorites are opens).

          I just tried on http://test.opentravelsystem.org/ecommerce/control/main and there you can see how the padding was working before.

          I will revert tomorrow morning. Thanks to see if using percentages resolve this problem.

          Jacques Le Roux added a comment -

          The ecommain.css file is reverted from changes by Marco. Widthes in pix must certainly be changed to percentages. I kept my little change for cart header and i18n/i10n changes. Committed in revision 437568.

          David E. Jones added a comment -

          Sounds like a good way to for now Jacques. Thanks for taking care of this.

          Marco Risaliti added a comment -

          Ok, thanks Jacques & David I will try with percentages and then I will upload a new patch.
          I'm sorry for the problems that can be caused by this commit.
          I will let you know as I will be ready for a new patch.

          Thanks again
          Marco

          Jacques Le Roux added a comment -

          Don't worry Marco apart David and me I think that nobody else has "suffer" from this patch ;o)

          Marco Risaliti added a comment -

          Hi Jacques & David,

          I have tried to use the percentage instead of use fixed number of pixels and now it seems to be better.
          Could you please look at this and tell me if there are other issues.

          Thanks
          Marco

          Jacques Le Roux added a comment -

          Marco,

          It's not perfect but I agree that it's better. I think that it's imposible to have pefection here anyway.
          Under Firefox there is no more padding problem.
          Under IE there is always the too narrow product column problem (product column shift under last boxe of left column if the screen is narrowed)
          Under Opera the padding problem remains (appears ?).

          We loosed the benefit of my increase of the <<#ecom-mainarea .screenlet-header { padding-bottom>> to 3px (from 1px) in the view of the cart header

          I wait for other reviews before really thinking of commit.

          Another remark, please Marco try to always use a path from OFBIZ_HOME in your patches.

          Chris Howe added a comment -

          because of the problems with IE why not make it easier on ourselves ...drop the css validation logo and include an iehacks.css as an if comment in the header?

          Jacques Le Roux added a comment -

          Chris,

          Actually the work done by Marco allow to use IE. Before the cart was unreadable (yellow on white, etc.). I'm not sure that we can go further without tricks like the one you suggest. Let's see what OFBiz people think about it..

          Chris Howe added a comment -

          ecomPeekaboo.patch

          This is actually the IE peekaboo bug caused by empty line height and float, not caused by the voice-family.

          The attached patch makes the correction by applying a height of auto marked !important so that all the real browsers use that definition. Since IE doesn't know what !important means it will use the following height definition: height: 1%; and render as it does in FF.

          AND it does validate

          Jacques Le Roux added a comment -

          Thanks Chris,

          Please is this patch to apply on svn or after Marco's last patch ?

          Chris Howe added a comment -

          on svn provided this nothing has been done to address this issue for the last couple of monhs.

          Marco Risaliti added a comment -

          Hi Jacques & David,

          I have tried the suggestions of Chris Howe and they are true and probably solve this issue.
          In attach a new patch, now seems also the product summary ok.
          I have tested only on IE and FireFox, have you the possibility to test on Opera and others browser to be sure that now it's ok.

          Thanks a lot
          Marco

          Chris Howe added a comment -

          I'm not anywhere that I can test Marco's patch, but by reading the patch, I believe it's going to screw something up depending on how much content is in the box.

          following this approach, http://wellstyled.com/css-minheight-hack.html , I believe will act more consistantly

          Jacques Le Roux added a comment -

          Marco,

          May you adapt your last patch with last Chris's remark, if needed ? I did not have a chance to try your last patch indeed.

          Thanks to both

          Marco Risaliti added a comment -

          Hi Jacques & Chris,

          I have revert my previous patch and apply the corrected suggestion from Chris and I have also changed something to correcting the issue into the product summary.
          I have tested on Internet Explorer and Firefox and now seems to be ok.

          Thanks
          Marco

          Jacques Le Roux added a comment -

          Marco, Chris,

          If I rightly applied patches (css_for_explore3.patch and then css_for_explore4.patch) there is still some problems (at least) :

          Firefox 1.5.0.6
          . in Main view there is always a padding problem at right of center column (products column)
          . Cart view is completly destructured
          . In product view the line under customer review is muchlonguer than others
          . No more padding between left and center column (in general)

          Opera 9.0.1
          . In Main view padding problem at right of center column (products column)
          . Each product in the main view appears in a list (scroll at right). Seems to be Opera specific.
          . Cart view is destructured (less than in Firefox)
          . No more padding between left and center column (in general)
          . Something strange : if in cart view you select "continue shopping" (or Main) the right column loose the cart view boxe (this is also the case with a version non patched)

          IE 6
          . Main view :
          . if products column is narrowed the column is shifted under the last boxe of the left column (you don't need to use 800*600 to see that)
          . Always a padding problem on large screens (not so large, 1400 is enough)

          Sorry...

          Marco Risaliti added a comment -

          Hi Jacques,

          I'm sorry but I'm not explain to you very well, you have only to apply the patch css_for_explore4.patch.
          Could you please try it.

          Thanks
          Marco

          Chris Howe added a comment -

          Marco hasn't attached a patch that integrates my comments (I don't believe). All of the other attachments were correcting the wrong problem. If you're testing, you should only be testing

          peekaboo.patch by itself
          this one does not attempt to correct any padding issues or min-height boxes issues

          or

          css for explorer 4 by itself
          This one will likely still have issues with min-height boxes issues.

          Marco Risaliti added a comment -

          Hi Chris,

          Your patch peekaboo.patch contains only those corrections :

          +height:auto !important;
          +height:1%;

          and are included in my last patch css_for_explore4.patch.

          If you don't want believe me you can modify and attach a new patch without any problems.
          So you can do as you want.

          Marco

          Jacques Le Roux added a comment -

          Thanks to both,

          Seemed strange also...

          OK, I revert to svn and try last patch from Marco. Wil see after...

          I have no IE 4...

          Chris Howe added a comment -

          Marco,

          You're right that css for explorer 4 incorporates them, however css_for_explorer_4 doesn't incorporate the comments that I made on/at [29/Aug/06 02:50 PM].

          It gets confusing when there are several bugs to be worked out

          Jacques Le Roux added a comment -

          This time it seems good. At least in Firefox and IE 6. Opera still have some problems. One is really bad : the cart view. Padding in Main view is not good also and the dropdown for language is too large and a part of it is out of view if the center column is narrowed (from a 1400 screen)

          To resume

          Opera 9.0.1
          . In Main view padding problem at right of center column (products column)
          . Each product in the main view appears in a list (scroll at right). Finally it's not Opera specific. When products column is narrowed in IE, scrolls appear also. In Opera they remain even if the column is large enough.
          . Cart view is destructured
          . No more padding between left and center column (in general)
          . Something strange : if in cart view you select "continue shopping" (or Main) the right column loose the cart view boxe (this is also the case with a version non patched)

          All of this (apart the "strange thing") is correct in svn not patched.

          I'm not sure if it's ok to commit because of Opera. But as there is MUCH more users of IE 6 than Opera I think it worth to be commited. Waiting for other reviews. Some tricks for Opera are welcome ...

          Thanks for your help Chris and Marco !

          Jacques Le Roux added a comment -

          Marco, Chris,

          From you comments above, I kept only css_for_explore4.patch and ecomPeekaboo.patch to avoid confusion.

          Marco Risaliti added a comment -

          Hi Jacques,

          I made same changes to the ecomm.css that you can find here in attach.
          Could you please try it reverting your local file from the repository and then apply only css_for_explorer5.patch.
          Then clear all the local caches of the browsers (IE, Firefox & Opera).
          It's seems to be better now and works very similar on all three browsers (IE, Firefox & Opera).
          Actually I have used those version of browser on Windows XP SP2.
          Internet Explorer 6.0.2900
          Firefox 1.5.0.6
          Opera 9.0.1

          I'm not able at the moment to test on others browser like Safari.

          Thanks
          Marco

          Jacques Le Roux added a comment -

          Thanks Marco,

          This time everything seems ok indeed. Your patch is in svn revision: 439223 . BTW thanks to Chris also who helped much in this work.

          I just saw a problem that already existed in IE. In cart view If from an empty cart you click on the button "Add to cart" the next screen is not very good but usable.

          Marco Risaliti added a comment -

          Hi Jacques,

          I'm happy to solve this issue.
          I have also see the last issue you have explain to me and I will try to correct when I have time.
          I have seen also that the same issue can be present also into the back-end.

          Thanks
          Marco

          Chris Howe added a comment -

          Just from memory, the back-end issue is because it uses

          boxoutside instead of screenlet
          boxtop for screenlet-header
          boxbottom instead of screenlet-body

          so a fix to those classes in the maincss.css should do the trick

          I also think I was a bit over zealous in adding that fix to the screenlet-body tag. That shouldn't be necessary, but I haven't tested it.

          Jacques Le Roux added a comment -

          I reopen this issue rather than opening a new one because some points here above will be easierly readable.

          To summarize

          Grey background under images with IE 6
          Chris proposes this solution : http://homepage.ntlworld.com/bobosola/pnghowto.htm

          In cart view If from an empty cart you click on the button "Add to cart" the next screen is not very good but usable.

          Perhaps this last problem is related to a such problem in back-end. Chris proposes a solution on his previous comment.

          I have also noticed that with last changes the cart view has again a problem in FIrefox with its " Quick Add ... Continue Shopping Checkout" header. This problem does not occurs with a higher logo (75 px in place of 70). So I propose an OFBiz logo (same than before but 75 px high).

          Jacques Le Roux added a comment -

          I used XnView Image/Resize option with Lanczos algorithm to create this logo.

          Marco Risaliti added a comment -

          Hi Jacques,

          I have tried to do some changes into tabstyle.css and now seems also the back-end is better.

          Thanks
          Marco

          Jacques Le Roux added a comment -

          Marco,

          I have committed your change in revision 440995. I have also committed the above new logo.

          To be clear I closed this issue and reopen a new one with the comments above.

          Thanks


            People

            • Assignee:
              Jacques Le Roux
              Reporter:
              Marco Risaliti
            • Votes:
              2 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development