Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: Release 4.0
    • Fix Version/s: Release Branch 4.0
    • Component/s: accounting
    • Labels:
      None
    • Environment:

      windows

      Description

      2008-04-10 00:57:53,843 (http-0.0.0.0-8443-Processor3) [ ModelService.java:481:ERROR] [ModelService.validate] :

      {ofbGcProcessor}

      : (IN) Required test error: org.ofbiz.service.ServiceValidationException: The following required parameter is missing:: [IN] [ofbGcProcessor.billToParty]The following required parameter is missing:: [IN] [ofbGcProcessor.giftCard]The following required parameter is missing:: [IN] [ofbGcProcessor.orderId]The following required parameter is missing:: [IN] [ofbGcProcessor.orderItems]
      2008-04-10 00:57:53,843 (http-0.0.0.0-8443-Processor3) [ ServiceDispatcher.java:333:ERROR]
      ---- exception report ----------------------------------------------------------
      Incoming context (in runSync : ofbGcProcessor) does not match expected requirements
      Exception: org.ofbiz.service.ServiceValidationException
      Message: The following required parameter is missing:: [IN] [ofbGcProcessor.billToParty]The following required parameter is missing:: [IN] [ofbGcProcessor.giftCard]The following required parameter is missing:: [IN] [ofbGcProcessor.orderId]The following required parameter is missing:: [IN] [ofbGcProcessor.orderItems]
      ---- stack trace ---------------------------------------------------------------
      org.ofbiz.service.ServiceValidationException: The following required parameter is missing:: [IN] [ofbGcProcessor.billToParty]The following required parameter is missing:: [IN] [ofbGcProcessor.giftCard]The following required parameter is missing:: [IN] [ofbGcProcessor.orderId]The following required parameter is missing:: [IN] [ofbGcProcessor.orderItems]
      org.ofbiz.service.ModelService.validate(ModelService.java:523)
      org.ofbiz.service.ModelService.validate(ModelService.java:478)
      org.ofbiz.service.ServiceDispatcher.runSync(ServiceDispatcher.java:331)
      org.ofbiz.service.ServiceDispatcher.runSync(ServiceDispatcher.java:214)
      org.ofbiz.service.GenericDispatcher.runSync(GenericDispatcher.java:166)
      org.ofbiz.accounting.payment.PaymentGatewayServices.capturePayment(PaymentGatewayServices.java:1541)
      org.ofbiz.accounting.payment.PaymentGatewayServices.capturePayment(PaymentGatewayServices.java:1447)
      org.ofbiz.accounting.payment.PaymentGatewayServices.captureOrderPayments(PaymentGatewayServices.java:1179)
      sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      java.lang.reflect.Method.invoke(Method.java:585)
      org.ofbiz.service.engine.StandardJavaEngine.serviceInvoker(StandardJavaEngine.java:94)
      org.ofbiz.service.engine.StandardJavaEngine.runSync(StandardJavaEngine.java:56)
      org.ofbiz.service.ServiceDispatcher.runSync(ServiceDispatcher.java:347)
      org.ofbiz.service.ServiceDispatcher.runSync(ServiceDispatcher.java:214)
      org.ofbiz.service.GenericDispatcher.runSync(GenericDispatcher.java:152)
      org.ofbiz.accounting.payment.PaymentGatewayServices.capturePaymentsByInvoice(PaymentGatewayServices.java:986)
      sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      java.lang.reflect.Method.invoke(Method.java:585)
      org.ofbiz.service.engine.StandardJavaEngine.serviceInvoker(StandardJavaEngine.java:94)
      org.ofbiz.service.engine.StandardJavaEngine.runSync(StandardJavaEngine.java:56)
      org.ofbiz.service.ServiceDispatcher.runSync(ServiceDispatcher.java:347)
      org.ofbiz.service.ServiceDispatcher.runSync(ServiceDispatcher.java:214)
      org.ofbiz.service.GenericDispatcher.runSync(GenericDispatcher.java:152)
      org.ofbiz.service.eca.ServiceEcaAction.runAction(ServiceEcaAction.java:113)
      org.ofbiz.service.eca.ServiceEcaRule.eval(ServiceEcaRule.java:141)
      org.ofbiz.service.eca.ServiceEcaUtil.evalRules(ServiceEcaUtil.java:158)
      org.ofbiz.service.ServiceDispatcher.runSync(ServiceDispatcher.java:463)
      org.ofbiz.service.ServiceDispatcher.runSync(ServiceDispatcher.java:214)
      org.ofbiz.service.GenericDispatcher.runSync(GenericDispatcher.java:152)
      org.ofbiz.order.order.OrderServices.checkDigitalItemFulfillment(OrderServices.java:2739)
      sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      java.lang.reflect.Method.invoke(Method.java:585)
      org.ofbiz.service.engine.StandardJavaEngine.serviceInvoker(StandardJavaEngine.java:94)
      org.ofbiz.service.engine.StandardJavaEngine.runSync(StandardJavaEngine.java:56)
      org.ofbiz.service.ServiceDispatcher.runSync(ServiceDispatcher.java:347)
      org.ofbiz.service.ServiceDispatcher.runSync(ServiceDispatcher.java:214)
      org.ofbiz.service.GenericDispatcher.runSync(GenericDispatcher.java:152)
      org.ofbiz.service.eca.ServiceEcaAction.runAction(ServiceEcaAction.java:113)
      org.ofbiz.service.eca.ServiceEcaRule.eval(ServiceEcaRule.java:141)
      org.ofbiz.service.eca.ServiceEcaUtil.evalRules(ServiceEcaUtil.java:158)
      org.ofbiz.service.ServiceDispatcher.runSync(ServiceDispatcher.java:383)
      org.ofbiz.service.ServiceDispatcher.runSync(ServiceDispatcher.java:214)
      org.ofbiz.service.GenericDispatcher.runSync(GenericDispatcher.java:152)
      org.ofbiz.order.order.OrderChangeHelper.orderStatusChanges(OrderChangeHelper.java:171)
      org.ofbiz.order.order.OrderChangeHelper.approveOrder(OrderChangeHelper.java:77)
      org.ofbiz.order.shoppingcart.CheckOutHelper.processPayment(CheckOutHelper.java:996)
      org.ofbiz.order.shoppingcart.CheckOutEvents.processPayment(CheckOutEvents.java:540)
      org.ofbiz.order.shoppingcart.CheckOutEvents.processPayment(CheckOutEvents.java:504)
      sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      java.lang.reflect.Method.invoke(Method.java:585)
      org.ofbiz.webapp.event.JavaEventHandler.invoke(JavaEventHandler.java:91)
      org.ofbiz.webapp.event.JavaEventHandler.invoke(JavaEventHandler.java:77)
      org.ofbiz.webapp.control.RequestHandler.runEvent(RequestHandler.java:448)
      org.ofbiz.webapp.control.RequestHandler.doRequest(RequestHandler.java:277)
      org.ofbiz.webapp.control.RequestHandler.doRequest(RequestHandler.java:381)
      org.ofbiz.webapp.control.RequestHandler.doRequest(RequestHandler.java:381)
      org.ofbiz.webapp.control.ControlServlet.doGet(ControlServlet.java:192)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:595)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:688)
      org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
      org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
      org.ofbiz.webapp.control.ContextFilter.doFilter(ContextFilter.java:251)
      org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
      org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
      org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
      org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
      org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
      org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
      org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
      org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:541)
      org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
      org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
      org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:664)
      org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
      org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)
      org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
      java.lang.Thread.run(Thread.java:595)
      --------------------------------------------------------------------------------

      2008-04-10 00:57:53,843 (http-0.0.0.0-8443-Processor3) [ ServiceDispatcher.java:396:DEBUG] [[Sync service failed...- total:0.0,since last(Begin):0.0]] - 'ecommerce / ofbGcProcessor'

        Activity

        Scott Gray added a comment -

        Not a critical issue by OFBiz standards

        Scott Gray added a comment -

        Could you please provide more information on what caused the exception to occur, steps to reproduce would be great.

        bj_zhou added a comment -

        Scott Gray (JIRA),您好!

        I buy a giftcard and then use this giftcard to pay in ecommerce.

        ======= 2008-05-08 17:14:55 您在来信中写道:=======

        = = = = = = = = = = = = = = = = = = = =

                致
        礼!

                bj_zhou
                bj_zhou@163.com
                  2008-05-09

        Jacques Le Roux added a comment -

        As you can see here https://lamouline.myvnc.com:18443/ordermgr/control/orderview?orderId=WSCO10022 I got it working without problems in trunk.
        I tried also in release4.0 (I saw later that you were asking about release4.0) and got an issue not related to gift-card but it seems to uspsRateInquire service (though I did not ask for USPS but DHL shipment)
        The error message was "This gift card no longer has any value." but in the log I see
        008-05-11 15:35:18,965 (TP-Processor8) [ UspsServices.java:1325:INFO ] USPS XML request string: <RateV2Request PASSWORD="999999999999" USERID="000000000000"><Package ID="0"><Service>Express</Service><ZipOrigination>84058</ZipOrigination><ZipDestination>84057</ZipDestination><Pounds>4</Pounds><Ounces>0</Ounces><Size>Regular</Size><Machinable>False</Machinable></Package></RateV2Request>
        2008-05-11 15:35:18,978 (http-0.0.0.0-8080-Processor4) [ControlEventListener.java:62 :INFO ] Creating session: 91FE54624C019461710E41EF1BE435B2.jvm1
        2008-05-11 15:35:18,980 (http-0.0.0.0-8080-Processor4) [ UspsMockApiServlet.java:70 :ERROR] Unsupported API [RateV2]
        2008-05-11 15:35:18,984 (TP-Processor8) [ UspsServices.java:1347:INFO ] USPS response:
        2008-05-11 15:35:19,026 (TP-Processor8) [ UspsServices.java:191:INFO ]
        ---- exception report ----------------------------------------------------------
        Exception: org.ofbiz.shipment.thirdparty.usps.UspsRequestException
        Message: Error reading request Document from a String: Premature end of file.
        ---- stack trace ---------------------------------------------------------------
        org.ofbiz.shipment.thirdparty.usps.UspsRequestException: Error reading request Document from a String: Premature end of file.
        [snip...]

        I gave up at this stage...

        Jacopo Cappellato added a comment -

        The release branch 4.0 is no more actively maintained.


          People

          • Assignee:
            Unassigned
            Reporter:
            bj_zhou
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development