OFBiz
  1. OFBiz
  2. OFBIZ-1733

"Owner" field in edit facility screen generates an application error

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Duplicate
    • Affects Version/s: SVN trunk
    • Fix Version/s: None
    • Component/s: product
    • Labels:
      None
    • Environment:

      SVN Trunk 643139

      Description

      1) Select
      Facility -> WebStoreWarehouse

      2) Choose a wrong party Id in the "Owner" field

      3) Click on "Update" button

      An application error is generated

      1. error_screen.jpg
        371 kB
        Bruno Busco

        Issue Links

          Activity

          Hide
          David E. Jones added a comment -

          What was the error?

          Show
          David E. Jones added a comment - What was the error?
          Hide
          Bruno Busco added a comment -

          Please see attached file "error_screen"

          Show
          Bruno Busco added a comment - Please see attached file "error_screen"
          Hide
          Scott Gray added a comment -

          From the looks of the error message you tried to change the owner to "compan" which isn't a valid party id.

          Could you try again with a valid party and see if works? (It does for me)

          Show
          Scott Gray added a comment - From the looks of the error message you tried to change the owner to "compan" which isn't a valid party id. Could you try again with a valid party and see if works? (It does for me)
          Hide
          Bruno Busco added a comment -

          With a valid party it works for sure.
          What i was reporting was only that a non "user friendly" error is displayed if the party id is not valid.
          Ofbiz should say something like "The following error occurs: The party id is not valid"

          In any case it seems that there is already an issue open (OFBIZ-255) that is general for all framework error message handling/hiding.

          Show
          Bruno Busco added a comment - With a valid party it works for sure. What i was reporting was only that a non "user friendly" error is displayed if the party id is not valid. Ofbiz should say something like "The following error occurs: The party id is not valid" In any case it seems that there is already an issue open ( OFBIZ-255 ) that is general for all framework error message handling/hiding.
          Hide
          Scott Gray added a comment -

          Ah I see, shall we close this issue then? If we were to create an issue for every error message like this it would run into the hundreds.

          Show
          Scott Gray added a comment - Ah I see, shall we close this issue then? If we were to create an issue for every error message like this it would run into the hundreds.
          Hide
          Bruno Busco added a comment -

          When I created the issue i did not know it was one of hundreds.
          Sorry...

          Show
          Bruno Busco added a comment - When I created the issue i did not know it was one of hundreds. Sorry...
          Hide
          Scott Gray added a comment -

          Not a problem All help is appreciated

          Show
          Scott Gray added a comment - Not a problem All help is appreciated

            People

            • Assignee:
              Scott Gray
              Reporter:
              Bruno Busco
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development