OFBiz
  1. OFBiz
  2. OFBIZ-1254

XML Data Export All does not include data present in blob fields

    Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: Trunk
    • Fix Version/s: None
    • Component/s: framework
    • Labels:
      None

      Description

      When exporting XML data to a directory using 'XML Data Export All', data present in blob fields is not included in the export.

      How to reproduce:

      1) https://localhost:8443/partymgr/control/viewprofile?partyId=admin
      2) Under section 'Party Content', attach content to admin. I used: a png image, 'User Defined Content', 'Publisher', 'PNG Image'
      3) Note the contentID
      4) https://localhost:8443/webtools/control/EntityExportAll
      5) Set output directory to (for example): '/tmp/ofbiz-export' (ensure it exists) and click 'Export'
      6) Open /tmp/ofbiz-export/ImageDataResource.xml and look for dataResourceId that is the same as contentID in step 4
      7) Note missing image data.
      8) Compare with https://localhost:8443/webtools/control/FindGeneric?entityName=ImageDataResource&find=true&VIEW_SIZE=50&VIEW_INDEX=0

        Activity

          People

          • Assignee:
            Unassigned
            Reporter:
            Arno Peters
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:

              Development