Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-11133

Resolve build.gradle warnings

    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Open
    • Minor
    • Resolution: Unresolved
    • None
    • None
    • None
    • None

    Description

      The Gradle build show several warnings which should be eliminated:

        - 'org.asciidoctor.convert' is deprecated. When you have time please switch over to 'org.asciidoctor.jvm.convert'.
        - jcenter() is no longer added by default. If you relied on this behaviour in the past, please add jcenter() to the repositories block.
        - You have used 'backends'. When upgrading you will need to: Use outputOptions.setbackends

       

      Update 21.04.2022

      You are using one or more deprecated Asciidoctor Gradle plugin features.
      These will be removed in 3.0 of these plugins.
      To help you migrate we have compiled some tips for you based upon your current usage.
      - Task: asciidoctor:
        - You have used 'backends'. When upgrading you will need to: Use outputOptions.setbackends
      - Task: assetmaint-Documentation:
        - You have used 'backends'. When upgrading you will need to: Use outputOptions.setbackends
      - Task: bi-Documentation:
        - You have used 'backends'. When upgrading you will need to: Use outputOptions.setbackends
      - Task: birt-Documentation:
        - You have used 'backends'. When upgrading you will need to: Use outputOptions.setbackends
      - Task: cmssite-Documentation:
        - You have used 'backends'. When upgrading you will need to: Use outputOptions.setbackends
      - Task: ebay-Documentation:
        - You have used 'backends'. When upgrading you will need to: Use outputOptions.setbackends
      - Task: ecommerce-Documentation:
        - You have used 'backends'. When upgrading you will need to: Use outputOptions.setbackends
      - Task: example-Documentation:
        - You have used 'backends'. When upgrading you will need to: Use outputOptions.setbackends
      - Task: exampleext-Documentation:
        - You have used 'backends'. When upgrading you will need to: Use outputOptions.setbackends
      - Task: firstdatapaymentgateway-Documentation:
        - You have used 'backends'. When upgrading you will need to: Use outputOptions.setbackends
      - Task: generateOfbizDocumentation:
        - You have used 'backends'. When upgrading you will need to: Use outputOptions.setbackends
      - Task: generateReadmeFiles:
        - You have used 'backends'. When upgrading you will need to: Use outputOptions.setbackends
      - Task: ldap-Documentation:
        - You have used 'backends'. When upgrading you will need to: Use outputOptions.setbackends
      - Task: lucene-Documentation:
        - You have used 'backends'. When upgrading you will need to: Use outputOptions.setbackends
      - Task: msggateway-Documentation:
        - You have used 'backends'. When upgrading you will need to: Use outputOptions.setbackends
      - Task: multiflex-Documentation:
        - You have used 'backends'. When upgrading you will need to: Use outputOptions.setbackends
      - Task: myportal-Documentation:
        - You have used 'backends'. When upgrading you will need to: Use outputOptions.setbackends
      - Task: passport-Documentation:
        - You have used 'backends'. When upgrading you will need to: Use outputOptions.setbackends
      - Task: pricat-Documentation:
        - You have used 'backends'. When upgrading you will need to: Use outputOptions.setbackends
      - Task: projectmgr-Documentation:
        - You have used 'backends'. When upgrading you will need to: Use outputOptions.setbackends
      - Task: rest-api-Documentation:
        - You have used 'backends'. When upgrading you will need to: Use outputOptions.setbackends
      - Task: scrum-Documentation:
        - You have used 'backends'. When upgrading you will need to: Use outputOptions.setbackends
      - Task: solr-Documentation:
        - You have used 'backends'. When upgrading you will need to: Use outputOptions.setbackends
      - Task: webpos-Documentation:
        - You have used 'backends'. When upgrading you will need to: Use outputOptions.setbackends
      - org.asciidoctor.convert:
        - 'org.asciidoctor.convert' is deprecated. When you have time please switch over to 'org.asciidoctor.jvm.convert'.
        - jcenter() is no longer added by default. If you relied on this behaviour in the past, please add jcenter() to the repositories block.

      Attachments

        Activity

          People

            mbrohl Michael Brohl
            mbrohl Michael Brohl
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated: