Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-11128

Error when manually loading data in "XML Data Import" using "Import Text"

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Invalid
    • Release Branch 16.11, Release Branch 18.12, Release Branch 17.12, Trunk
    • None
    • framework/webtools
    • None

    Description

      I cross this issue for already some times and while testing OFBIZ-10966 I decided to report it. It' still present once the today OFBIZ-10966 patch is applied. I guess R16 is also concerned.

      I thought only Windows was concerned but I tested today by copying the 1st block of line in AccountingDemoData.xml and stable as trunk demo also fail.

      Reproducing is easy: simply copy a block of lines from a data file either in Eclipse or in another editor.

      The error is
      org.xml.sax.SAXParseException: The markup in the document following the root element must be well-formed.

      • Importing only the 1st line works.
      • Removing the lines delimiter (ie have the text not separated by lines) in the OFBiz textarea does not work
      • Converting CR/LF to LF does not help
      • Removing heading or trailing white spaces does not help
      • Surrounding by <entity-engine-xml> does not help

      In other words you have to import lines one by one.

      Attachments

        Activity

          People

            Unassigned Unassigned
            jleroux Jacques Le Roux
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: