Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: odfdom-0.8.6
    • Fix Version/s: odfdom-0.8.7
    • Component/s: codegen
    • Labels:
      None
    • Environment:
      Operating System: Windows
      Platform: PC

      Description

      Created an attachment (id=421)
      Ignoring the test

      Under some platforms (e.g. Oracle JDK 64bit 6b22 on W7 64bit) changing results on the amount of found XML nodes let the test testExtractPuzzlePieces of odfdom~schema2template\schema2template fail.

      The same test works fine under Oracle JDK 32bit on XP 32bit).

      The attached patch will at first only ignore the test.
      Later, when working on DOM enhancement, this issue should be further investigated.

      • Svante

        Issue Links

          Activity

          Svante Schubert added a comment -

          Due to problems in issue 91, the patch above have to be ignored and should be fixed.
          At home on an old XP 32 bit machine the test run smooth, the problem occurs for me in Ubuntu/W7 64bit environment.

          I will try to reproduce the problem on XP at home and upload generated sources, if I can not reproduce the issue.

          • Svante
          Svante Schubert added a comment -

          Seems to be solely a JDK 64 bit problem

          Svante Schubert added a comment -

          Closing issue


            People

            • Assignee:
              Svante Schubert
              Reporter:
              Svante Schubert
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development