Uploaded image for project: 'ODE'
  1. ODE
  2. ODE-984

Upgrade ODE OSGi headers to be compliant with modern Apache Smx/Fuse ESB

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.5
    • Fix Version/s: 1.3.6, 1.4
    • Component/s: Deployment
    • Labels:

      Description

      ODE jbi-bundle OSGi headers are incompatible with Apache ServiceMix Fuse ESB 4.4 and later (Fuse ESB Enterprise 7.x)

      ODE-917 address some of the issue.
      However the current jbi-bundle has plenty of optional dependencies, dynamic import section and most of required packages have missing version range.

      The attached patch for 1.3.6 branch addresses these aspects - and it is working under latest Fuse ESB Enterprise 7.1.0 as well.

        Attachments

        1. ode-136-patch.patch
          6 kB
          Mateusz Nowakowski

          Activity

            People

            • Assignee:
              hadrian Hadrian Zbarcea
              Reporter:
              matihost Mateusz Nowakowski
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: