ODE
  1. ODE
  2. ODE-957

Invocation of a WSDL operation that doesn't have a request message part gives NPE at runtime

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 1.3.5
    • Fix Version/s: 1.3.6, 1.4
    • Component/s: BPEL Runtime
    • Labels:
      None

      Description

      Invocation of a service operation which doesn't have a message part results in a NPE at runtime. For example invocation of the getVersion operation of Version service provided by the axis2 results in a null pointer exception.

        Activity

        Sathwik Bantwal Premakumar added a comment -

        Sorry, it works fine in ODE. I should have tested a little bit more before filing the bug.

        Tammo van Lessen added a comment -

        I'm not entirely sure if this was the same issue but at least the symptoms are the same.

        via mail from Dominic Pöllath:

        The Apache ODE engine throws exception if i try to invoke webservice without parameter. Because there is no InputMessage to the WebService.
        As far as I know is there no need of input message (minOccurs="0" of InputOperationMessage in W3C def).
        A webservice with no input message should be supported, but as workaround I’m using a empty messagepart with input message link.
        It is working, but the WSDL file is not as clean as I thought it should be. Anyway, is the ODE engine working as intended, and do I missing something?

        best regards,
        dominic

        <!—w3c tBindingOperation –>

        <xs:complexType name="tBindingOperation">
        <xs:complexContent>
        <xs:extension base="wsdl:tExtensibleDocumented">
        <xs:sequence>
        <xs:element name="input" type="wsdl:tBindingOperationMessage" minOccurs="0"/>
        <xs:element name="output" type="wsdl:tBindingOperationMessage" minOccurs="0"/>
        <xs:element name="fault" type="wsdl:tBindingOperationFault" minOccurs="0" maxOccurs="unbounded"/>
        </xs:sequence>
        <xs:attribute name="name" type="xs:NCName" use="required"/>
        </xs:extension>
        </xs:complexContent>
        </xs:complexType>

        <!—used WSDL def–>

        <wsdl:types>
        <xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema" attributeFormDefault="unqualified" elementFormDefault="qualified" targetNamespace="http://adito/webservice">
        <xs:element name="helloResponse">
        <xs:complexType>
        <xs:sequence>
        <xs:element name="returnValue" type="xs:string"/>
        </xs:sequence>
        </xs:complexType>
        </xs:element>
        </xs:schema>
        </wsdl:types>
        <wsdl:message name="helloOutput">
        <wsdl:part name="parameters" element="tns:helloResponse"/>
        </wsdl:message>
        <wsdl:portType name="ws_helloworldPortType">
        <wsdl:operation name="hello">
        <wsdl:output message="tns:helloOutput"/>
        </wsdl:operation>
        </wsdl:portType>
        <wsdl:binding name="ws_helloworldSoapBinding" type="tns:ws_helloworldPortType">
        <soap:binding style="document" transport="http://schemas.xmlsoap.org/soap/http"/>
        <wsdl:operation name="hello">
        <soap:operation soapAction="hello" style="document"/>
        <wsdl:output>
        <soap:body use="literal"/>
        </wsdl:output>
        </wsdl:operation>
        </wsdl:binding>

        <!—Nullpointer Exception –>

        Method "run" in class "org.apache.ode.bpel.runtime.INVOKE" threw an unexpected exception.
        java.lang.NullPointerException
        at org.apache.ode.bpel.runtime.INVOKE.setupOutbound(INVOKE.java:224)
        at org.apache.ode.bpel.runtime.INVOKE.run(INVOKE.java:72)
        at sun.reflect.GeneratedMethodAccessor11.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:601)
        at org.apache.ode.jacob.vpu.JacobVPU$JacobThreadImpl.run(JacobVPU.java:451)
        at org.apache.ode.jacob.vpu.JacobVPU.execute(JacobVPU.java:139)
        at org.apache.ode.bpel.engine.BpelRuntimeContextImpl.execute(BpelRuntimeContextImpl.java:968)
        at org.apache.ode.bpel.engine.PartnerLinkMyRoleImpl.invokeNewInstance(PartnerLinkMyRoleImpl.java:208)
        at org.apache.ode.bpel.engine.BpelProcess$1.invoke(BpelProcess.java:283)
        at org.apache.ode.bpel.engine.BpelProcess.invokeProcess(BpelProcess.java:238)
        at org.apache.ode.bpel.engine.BpelProcess.invokeProcess(BpelProcess.java:279)
        at org.apache.ode.bpel.engine.BpelProcess.handleJobDetails(BpelProcess.java:426)
        at org.apache.ode.bpel.engine.BpelEngineImpl.onScheduledJob(BpelEngineImpl.java:460)
        at org.apache.ode.bpel.engine.BpelServerImpl.onScheduledJob(BpelServerImpl.java:450)
        at org.apache.ode.il.MockScheduler.doExecute(MockScheduler.java:304)
        at org.apache.ode.il.MockScheduler.access$200(MockScheduler.java:47)
        at org.apache.ode.il.MockScheduler$4.call(MockScheduler.java:123)
        at org.apache.ode.il.MockScheduler.execTransaction(MockScheduler.java:168)
        at org.apache.ode.il.MockScheduler.execTransaction(MockScheduler.java:159)
        at org.apache.ode.il.MockScheduler$6.call(MockScheduler.java:190)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
        at java.util.concurrent.FutureTask.run(FutureTask.java:166)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
        at java.lang.Thread.run(Thread.java:722)
        Scheduled job failed; jobDetail=JobDetails( instanceId: null mexId: 4611686018427387903 processId:

        {http://adito/bpel}

        Workflow-1 type: INVOKE_INTERNAL channel: null correlatorId: null correlationKeySet: null retryCount: null inMem: true detailsExt: {})
        java.lang.RuntimeException: java.lang.NullPointerException
        at org.apache.ode.jacob.vpu.JacobVPU$JacobThreadImpl.run(JacobVPU.java:464)
        at org.apache.ode.jacob.vpu.JacobVPU.execute(JacobVPU.java:139)
        at org.apache.ode.bpel.engine.BpelRuntimeContextImpl.execute(BpelRuntimeContextImpl.java:968)
        at org.apache.ode.bpel.engine.PartnerLinkMyRoleImpl.invokeNewInstance(PartnerLinkMyRoleImpl.java:208)
        at org.apache.ode.bpel.engine.BpelProcess$1.invoke(BpelProcess.java:283)
        at org.apache.ode.bpel.engine.BpelProcess.invokeProcess(BpelProcess.java:238)
        at org.apache.ode.bpel.engine.BpelProcess.invokeProcess(BpelProcess.java:279)
        at org.apache.ode.bpel.engine.BpelProcess.handleJobDetails(BpelProcess.java:426)
        at org.apache.ode.bpel.engine.BpelEngineImpl.onScheduledJob(BpelEngineImpl.java:460)
        at org.apache.ode.bpel.engine.BpelServerImpl.onScheduledJob(BpelServerImpl.java:450)
        at org.apache.ode.il.MockScheduler.doExecute(MockScheduler.java:304)
        at org.apache.ode.il.MockScheduler.access$200(MockScheduler.java:47)
        at org.apache.ode.il.MockScheduler$4.call(MockScheduler.java:123)
        at org.apache.ode.il.MockScheduler.execTransaction(MockScheduler.java:168)
        at org.apache.ode.il.MockScheduler.execTransaction(MockScheduler.java:159)
        at org.apache.ode.il.MockScheduler$6.call(MockScheduler.java:190)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
        at java.util.concurrent.FutureTask.run(FutureTask.java:166)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
        at java.lang.Thread.run(Thread.java:722)
        Caused by: java.lang.NullPointerException
        at org.apache.ode.bpel.runtime.INVOKE.setupOutbound(INVOKE.java:224)
        at org.apache.ode.bpel.runtime.INVOKE.run(INVOKE.java:72)
        at sun.reflect.GeneratedMethodAccessor11.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:601)
        at org.apache.ode.jacob.vpu.JacobVPU$JacobThreadImpl.run(JacobVPU.java:451)
        ... 20 more
        Caught an exception during transaction
        java.lang.RuntimeException: Scheduled transaction failed unexpectedly: transaction will not be retried!.
        at org.apache.ode.il.MockScheduler.doExecute(MockScheduler.java:306)
        at org.apache.ode.il.MockScheduler.access$200(MockScheduler.java:47)
        at org.apache.ode.il.MockScheduler$4.call(MockScheduler.java:123)
        at org.apache.ode.il.MockScheduler.execTransaction(MockScheduler.java:168)
        at org.apache.ode.il.MockScheduler.execTransaction(MockScheduler.java:159)
        at org.apache.ode.il.MockScheduler$6.call(MockScheduler.java:190)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
        at java.util.concurrent.FutureTask.run(FutureTask.java:166)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
        at java.lang.Thread.run(Thread.java:722)
        Caused by: org.apache.ode.bpel.iapi.Scheduler$JobProcessorException: java.lang.RuntimeException: java.lang.NullPointerException
        at org.apache.ode.bpel.engine.BpelEngineImpl.onScheduledJob(BpelEngineImpl.java:478)
        at org.apache.ode.bpel.engine.BpelServerImpl.onScheduledJob(BpelServerImpl.java:450)
        at org.apache.ode.il.MockScheduler.doExecute(MockScheduler.java:304)
        ... 10 more
        Caused by: java.lang.RuntimeException: java.lang.NullPointerException
        at org.apache.ode.jacob.vpu.JacobVPU$JacobThreadImpl.run(JacobVPU.java:464)
        at org.apache.ode.jacob.vpu.JacobVPU.execute(JacobVPU.java:139)
        at org.apache.ode.bpel.engine.BpelRuntimeContextImpl.execute(BpelRuntimeContextImpl.java:968)
        at org.apache.ode.bpel.engine.PartnerLinkMyRoleImpl.invokeNewInstance(PartnerLinkMyRoleImpl.java:208)
        at org.apache.ode.bpel.engine.BpelProcess$1.invoke(BpelProcess.java:283)
        at org.apache.ode.bpel.engine.BpelProcess.invokeProcess(BpelProcess.java:238)
        at org.apache.ode.bpel.engine.BpelProcess.invokeProcess(BpelProcess.java:279)
        at org.apache.ode.bpel.engine.BpelProcess.handleJobDetails(BpelProcess.java:426)
        at org.apache.ode.bpel.engine.BpelEngineImpl.onScheduledJob(BpelEngineImpl.java:460)
        ... 12 more
        Caused by: java.lang.NullPointerException
        at org.apache.ode.bpel.runtime.INVOKE.setupOutbound(INVOKE.java:224)
        at org.apache.ode.bpel.runtime.INVOKE.run(INVOKE.java:72)
        at sun.reflect.GeneratedMethodAccessor11.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:601)
        at org.apache.ode.jacob.vpu.JacobVPU$JacobThreadImpl.run(JacobVPU.java:451)
        ... 20 more

        Tammo van Lessen added a comment -

        The problem is a null pointer returned by getInput() in INVOKE.setupOutbound(). Such exceptions should in general never hit the jacob core.

        Sathwik Bantwal Premakumar added a comment -

        As per Basic Profile 1.1

        4.5.2 Allowed Operations
        Solicit-Response and Notification operations are not well defined by WSDL 1.1; furthermore, WSDL 1.1 does not define bindings for them.
        R2303 A DESCRIPTION MUST NOT use Solicit-Response and Notification type operations in a wsdl:portType definition.

        Many Webservice stack like axis2, cxf etc; doesn't support this.

        We definitely need to add a check for the NPE, the question is what should be the behaviour of ODE.

        Sathwik Bantwal Premakumar added a comment -

        Initial changes have been made in ODE to incorporate this feature, but one should note that this use case will not be complaint with Basic Profile 1.1

        Hudson added a comment -

        Integrated in ODE-1.x #148 (See https://builds.apache.org/job/ODE-1.x/148/)
        ODE-957: Changes to handle invocation of external services which doesn't specify input message. (Revision 6bc1650e680be389a5a9f0a71fcf1f6b033db05c)
        ODE-957: rectified compilation error after cherry-pick from master (Revision 14a41fa0a02b58b36714789cad88774120d34344)

        Result = SUCCESS
        sathwik :
        Files :

        • dao-jpa/src/main/java/org/apache/ode/dao/jpa/MessageDAOImpl.java
        • axis2-war/src/test/java/org/apache/ode/axis2/DummyService.java
        • bpel-runtime/src/main/java/org/apache/ode/bpel/runtime/INVOKE.java
        • bpel-runtime/src/main/java/org/apache/ode/bpel/engine/BpelRuntimeContextImpl.java
        • axis2-war/src/test/resources/TestNoInputMessageInvocation/dummy-service.wsdl
        • axis2/src/main/java/org/apache/ode/axis2/util/SoapMessageConverter.java
        • axis2-war/src/test/resources/TestNoInputMessageInvocation/deploy.xml
        • axis2-war/src/test/java/org/apache/ode/axis2/NoInputMessageInvocationTest.java
        • axis2-war/src/test/resources/TestNoInputMessageInvocation/testRequest.soap
        • axis2-war/src/test/resources/TestNoInputMessageInvocation/NoArgumentInvocationProcess.bpel
        • axis2-war/src/test/resources/TestNoInputMessageInvocation/NoArgumentInvocationProcessArtifacts.wsdl

        sathwik :
        Files :

        • axis2-war/src/test/java/org/apache/ode/axis2/NoInputMessageInvocationTest.java

          People

          • Assignee:
            Sathwik Bantwal Premakumar
            Reporter:
            Sathwik Bantwal Premakumar
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development