ODE
  1. ODE
  2. ODE-892

routing fails as terminated instance's data was not cleaned up.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.3.3, 1.3.4
    • Fix Version/s: 1.3.5
    • Component/s: BPEL Runtime
    • Labels:
      None
    • Environment:
      tomcat6
      Ode-1.3.3

      Description

      Though <cleanup on="always" /> is set in deploy.xml, terminated instance's data is not cleaned up.
      If previous instance's routing information are left on ODE_MESSAGE_ROUTE, and newer instance's CORRELATION_KEY is same as before,
      request for newer instance can not be routed correctly.
      Terminated instance's data should be cleaned up, too.
      see attached patch.

      1. ode-892.patch
        0.8 kB
        Rick.Todo
      2. HelloWorld2_exit.zip
        4 kB
        Rick.Todo

        Activity

        Jeff Yu added a comment -

        Could you please check with ODE-1.3.4 release, as I believed your following description issue should be already fixed in ODE 1.3.4

        "If previous instance's routing information are left on ODE_MESSAGE_ROUTE, and newer instance's CORRELATION_KEY is same as before,
        request for newer instance can not be routed correctly. "

        Rick.Todo added a comment -

        Sorry, that issue was ODE1.3.3's problem.

        By the way, "Though <cleanup on="always" /> is set in deploy.xml, terminated instance's data is not cleaned up.
        " is not a bug? Database size may increase.

        Jeff Yu added a comment -

        It is a bug if it didn't clean up.

        Could you please test this in ODE 1.3.4 or you can provide a simple test case that we can verify if it still has this problem in ODE 1.3.4

        Thanks
        Jeff

        Rick.Todo added a comment -

        sample bpel with <exit/>(terminate)

        Rick.Todo added a comment -

        I tested attached sample-bpel in ODE-1.3.4.
        There were STATE_TERMINATED instances in ODE_PROCESS_INSTANCE table.

        Tammo van Lessen added a comment -

        Rick, thanks for the patch.

        I messed up the commit comments, the changesets are r1058619 and r1058637.

        Hudson added a comment -

        Integrated in ODE-trunk #412 (See https://hudson.apache.org/hudson/job/ODE-trunk/412/)
        fixing ODE-892, thanks Rick!

        Hudson added a comment -

        Integrated in ODE-trunk-jdk6 #401 (See https://hudson.apache.org/hudson/job/ODE-trunk-jdk6/401/)
        fixing ODE-892, thanks Rick!


          People

          • Assignee:
            Tammo van Lessen
            Reporter:
            Rick.Todo
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development