ODE
  1. ODE
  2. ODE-764

Weird XML constant parsing problem

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.3.4
    • Component/s: JBI Integration
    • Labels:
      None
    • Environment:
      ServiceMix 3.3

      Description

      2010-02-09 11:06:21 | ERROR | ODEServer-12-1 | BpelEngineImpl | ode.bpel.engine.BpelEngineImpl 452 | Job could not be completed after 0 retries: hqejbhcnphr515nxl4n7qm[48600416497; 0]:

      {channel=91 , type=INVOKE_RESPONSE, iid=105, inmem=true, mexid=4611686018427388289}

      java.lang.RuntimeException: org.w3c.dom.DOMException: INVALID_CHARACTER_ERR: An invalid or illegal XML character is specified.
      at org.apache.ode.jacob.vpu.JacobVPU$JacobThreadImpl.run(JacobVPU.java:464)
      at org.apache.ode.jacob.vpu.JacobVPU.execute(JacobVPU.java:139)
      at org.apache.ode.bpel.engine.BpelRuntimeContextImpl.execute(BpelRuntimeContextImpl.java:933)
      at org.apache.ode.bpel.engine.BpelProcess.handleWorkEvent(BpelProcess.java:461)
      at org.apache.ode.bpel.engine.BpelEngineImpl.onScheduledJob(BpelEngineImpl.java:430)
      at org.apache.ode.bpel.engine.BpelServerImpl.onScheduledJob(BpelServerImpl.java:377)
      at org.apache.ode.scheduler.simple.SimpleScheduler$4$1.call(SimpleScheduler.java:476)
      at org.apache.ode.scheduler.simple.SimpleScheduler$4$1.call(SimpleScheduler.java:467)
      at org.apache.ode.scheduler.simple.SimpleScheduler.execTransaction(SimpleScheduler.java:268)
      at org.apache.ode.scheduler.simple.SimpleScheduler$4.call(SimpleScheduler.java:466)
      at org.apache.ode.scheduler.simple.SimpleScheduler$4.call(SimpleScheduler.java:463)
      at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:176)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:665)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:690)
      at java.lang.Thread.run(Thread.java:810)
      Caused by:
      org.w3c.dom.DOMException: INVALID_CHARACTER_ERR: An invalid or illegal XML character is specified.
      at org.apache.xerces.dom.CoreDocumentImpl.createElement(Unknown Source)
      at org.apache.xerces.dom.CoreDocumentImpl.importNode(Unknown Source)
      at org.apache.xerces.dom.CoreDocumentImpl.importNode(Unknown Source)
      at org.apache.xerces.dom.CoreDocumentImpl.importNode(Unknown Source)
      at org.apache.xerces.dom.CoreDocumentImpl.importNode(Unknown Source)
      at org.apache.ode.bpel.o.OAssign$Literal.getXmlLiteral(OAssign.java:113)
      at org.apache.ode.bpel.runtime.ASSIGN.evalRValue(ASSIGN.java:234)
      at org.apache.ode.bpel.runtime.ASSIGN.copy(ASSIGN.java:368)
      at org.apache.ode.bpel.runtime.ASSIGN.run(ASSIGN.java:82)
      at sun.reflect.GeneratedMethodAccessor236.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:618)
      at org.apache.ode.jacob.vpu.JacobVPU$JacobThreadImpl.run(JacobVPU.java:451)
      ... 14 more

      Redeploying of process helps to resolve this problem. So I suppose it's related to global Xerces settings like locale or maybe some classloader issue.
      However it may be helpful to move Xerces XML parsing from inside O Model into Bpel Runtime (ASSIGN).

        Activity

        Hudson added a comment -

        Integrated in ODE-1.x #62 (See http://hudson.zones.apache.org/hudson/job/ODE-1.x/62/)
        : Weird XML constant parsing problem fix


          People

          • Assignee:
            Rafal Rusin
            Reporter:
            Rafal Rusin
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development