Uploaded image for project: 'ODE'
  1. ODE
  2. ODE-725

Patch to add support for postgres to dao-jpa-db

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: None
    • Labels:
      None
    • Environment:

      Description

      dao-jpa-db only has scripts for oracle, mysql and derby. Here is a candidate patch for adding support for postgres:

      1. I've copied simplesched-postgres.sql over from dao-hibernate-db. Is this generated somehow?
      2. I've created persistence.postgres.xml descriptor.
      3. I've updated Buildfile to include postgres.

        Attachments

        1. Buildfile.patch
          0.5 kB
          Terry Mueller
        2. dao-jpa-db.patch
          4 kB
          Terry Mueller

          Activity

            People

            • Assignee:
              vanto Tammo van Lessen
              Reporter:
              terry_permeance Terry Mueller
            • Votes:
              1 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: