ODE
  1. ODE
  2. ODE-544

Missing prefix declarations in literal xml causes NAMESPACE_ERR: An attempt is made to create...

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.2
    • Fix Version/s: 1.3.2
    • Component/s: BPEL Runtime
    • Labels:
      None

      Description

      Hey guys,

      I commented on https://issues.apache.org/jira/browse/ODE-536 which made no sense at all.

      I created a copy activity below:

      <bpws:copy>
      <bpws:from>
      <bpws:literal>
      <supercalifragilisticexpialidocious>
      <complexStuff xmlns="http://ode/bpel/unit-test-diff">
      <mytext>Initialised-supercalifragilisticexpialidocious</mytext>
      </complexStuff>
      </supercalifragilisticexpialidocious>
      </bpws:literal>
      </bpws:from>
      <bpws:to variable="supercalifragilisticexpialidocious"/>
      </bpws:copy>

      Note that the xml in the literal has no xml prefix declarations but it still valid. This seems to cause the following exception:

      ERROR - GeronimoLog.error(108) | Error while executing transaction
      org.apache.ode.bpel.iapi.Scheduler$JobProcessorException: java.lang.RuntimeException: org.w3c.dom.DOMException: NAMESPACE_ERR: An attempt is made to create or c
      hange an object in a way which is incorrect with regard to namespaces.
      at org.apache.ode.bpel.engine.BpelEngineImpl.onScheduledJob(BpelEngineImpl.java:409)
      at org.apache.ode.bpel.engine.BpelServerImpl.onScheduledJob(BpelServerImpl.java:391)
      at org.apache.ode.scheduler.simple.SimpleScheduler$4$1.call(SimpleScheduler.java:386)
      at org.apache.ode.scheduler.simple.SimpleScheduler$4$1.call(SimpleScheduler.java:380)
      at org.apache.ode.scheduler.simple.SimpleScheduler.execTransaction(SimpleScheduler.java:208)
      at org.apache.ode.scheduler.simple.SimpleScheduler$4.call(SimpleScheduler.java:379)
      at org.apache.ode.scheduler.simple.SimpleScheduler$4.call(SimpleScheduler.java:376)
      at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
      at java.util.concurrent.FutureTask.run(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at java.lang.Thread.run(Unknown Source)
      Caused by: java.lang.RuntimeException: org.w3c.dom.DOMException: NAMESPACE_ERR: An attempt is made to create or change an object in a way which is incorrect wit
      h regard to namespaces.
      at org.apache.ode.jacob.vpu.JacobVPU$JacobThreadImpl.run(JacobVPU.java:464)
      at org.apache.ode.jacob.vpu.JacobVPU.execute(JacobVPU.java:139)
      at org.apache.ode.bpel.engine.BpelRuntimeContextImpl.execute(BpelRuntimeContextImpl.java:868)
      at org.apache.ode.bpel.engine.PartnerLinkMyRoleImpl.invokeNewInstance(PartnerLinkMyRoleImpl.java:206)
      at org.apache.ode.bpel.engine.BpelProcess.invokeProcess(BpelProcess.java:221)
      at org.apache.ode.bpel.engine.BpelProcess.handleWorkEvent(BpelProcess.java:393)
      at org.apache.ode.bpel.engine.BpelEngineImpl.onScheduledJob(BpelEngineImpl.java:399)
      ... 11 more
      Caused by: org.w3c.dom.DOMException: NAMESPACE_ERR: An attempt is made to create or change an object in a way which is incorrect with regard to namespaces.
      at org.apache.xerces.dom.CoreDocumentImpl.checkDOMNSErr(Unknown Source)
      at org.apache.xerces.dom.ElementNSImpl.setName(Unknown Source)
      at org.apache.xerces.dom.ElementNSImpl.<init>(Unknown Source)
      at org.apache.xerces.dom.CoreDocumentImpl.createElementNS(Unknown Source)
      at org.apache.ode.utils.DOMUtils.cloneNode(DOMUtils.java:1155)
      at org.apache.ode.bpel.runtime.ASSIGN.replaceElement(ASSIGN.java:490)
      at org.apache.ode.bpel.runtime.ASSIGN.copy(ASSIGN.java:416)
      at org.apache.ode.bpel.runtime.ASSIGN.run(ASSIGN.java:81)
      at sun.reflect.GeneratedMethodAccessor49.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at org.apache.ode.jacob.vpu.JacobVPU$JacobThreadImpl.run(JacobVPU.java:451)
      ... 17 more

        Activity

        Karthick Sankarachary added a comment -

        I've reverted my change to the ASSIGN statement (revision 751065), which should resolve this issue.

        Colin added a comment -

        Attached is a BPEL process to replicate the problem. I butchered an existing process I found on a different bug.


          People

          • Assignee:
            Karthick Sankarachary
            Reporter:
            Colin
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development