ODE
  1. ODE
  2. ODE-514

InstanceManagementApi does not lists running process instances

    Details

    • Type: Task Task
    • Status: Resolved
    • Priority: Trivial Trivial
    • Resolution: Invalid
    • Affects Version/s: 2.0
    • Fix Version/s: 1.3.4
    • Component/s: Management API
    • Labels:
      None
    • Environment:
      Ubuntu 8.04, JDK 5, Tomcat 5.5, Ode 2.0beta

      Description

      I slightly modified HelloWorld example and added a few 5 second waits in between. I invoked the service and in parallel I fired listAllInstances. What I noticed was, in logs I could see new process instance being created but not listed in ListAllInstances output, instead all that was listed were instances in COMPLETED state
      .
      Second, Even if I fire suspend and provide iid of the running processes (after looking in the logs) It throws me an exception which says Process "null" does not exist.

      I want to know, how can I suspend/resume a running instance using InstanceManagement service?

        Activity

        hmarcal added a comment -

        I've also noticed that this happens for the other versions too. I'm currently using version 1.3.3 and I have the same problem listing running process instances. I need to get that information.

        I really need some help to solve this problem because I'm stuck in a project because of this.

        Does anyone have an idea for a solution?

        Alex Boisvert added a comment -

        Alternatively, if you have a reproductible test case that illustrates one of the issues describe above then please reopen and attach any necessary files.

        Alex Boisvert added a comment -

        Please use the mailing list for questions.


          People

          • Assignee:
            Unassigned
            Reporter:
            Akshay Dev Vankhede
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development