ODE
  1. ODE
  2. ODE-352

Type attribute replaces xsi-type attribute value

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2
    • Fix Version/s: 1.3.5
    • Component/s: None
    • Labels:

      Description

      This is related to ODE-343, see for context.

      The xsi:type attribute goes missing when you define a type attribute.

      Example:

      <soapenv:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:myns="myns">
      <soapenv:Header/>
      <soapenv:Body>
      <myns:hello>
      <myns:in xsi:type="myns:DustyMagicPixie" type="Why">
      <myns:value>Test message</myns:value>
      <myns:dust>fooo</myns:dust>
      </myns:in>
      </myns:hello>
      </soapenv:Body>
      </soapenv:Envelope>

        Activity

        Ciaran Jessup added a comment -

        This verbosely named patch should provide support for elements that contain multiple attributes with the same local name, but belonging to different namespaces. Without it, the last repeated local-name attribute wins

        Ciaran Jessup added a comment -

        The attached process should accept requests like:
        <soapenv:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:myns="myns">
        <soapenv:Header/>
        <soapenv:Body>
        <myns:hello>
        <myns:in xsi:type="myns:DustyMagicPixie" type="fff">
        <myns:value>Test message</myns:value>
        <myns:dust>fooo</myns:dust>
        </myns:in>
        </myns:hello>
        </soapenv:Body>
        </soapenv:Envelope>

        and respond with responses like:

        <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
        <soapenv:Body>
        <helloResponse xmlns="myns">
        <out type="fff" xsi:type="myns:DustyMagicPixie" xmlns:myns="myns" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
        <value>Test message</value>
        <dust>fooo</dust>
        </out>
        </helloResponse>
        </soapenv:Body>
        </soapenv:Envelope>

        Without the patch the responses look like :

        <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
        <soapenv:Body>
        <helloResponse xmlns="myns">
        <out type="fff">
        <value>Test message</value>
        <dust>fooo</dust>
        </out>
        </helloResponse>
        </soapenv:Body>
        </soapenv:Envelope>

        which obviously isn't quite what we want

        Tammo van Lessen added a comment -

        I tried the attached process and cannot reproduce the issue anymore. Seems to be fixed.


          People

          • Assignee:
            Tammo van Lessen
            Reporter:
            Colin
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development