ODE
  1. ODE
  2. ODE-30

Ode uses XPath 1.0 even when XPath 2.0 is specified at process level

    Details

      Description

      If in the process definition the default languages are set as XPath 2.0:

      <process
      ...
      queryLanguage="urn:oasis:names:tc:wsbpel:2.0:sublang:xpath2.0"
      expressionLanguage="urn:oasis:names:tc:wsbpel:2.0:sublang:xpath2.0">

      Expressions are still all compiled using XPath 1.0.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        9d 21h 12m 1 Matthieu Riou 24/Aug/06 17:30
        Resolved Resolved Closed Closed
        278d 5h 34m 1 Matthieu Riou 29/May/07 23:04
        Matthieu Riou made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Matthieu Riou made changes -
        Field Original Value New Value
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Hide
        Matthieu Riou added a comment -

        The expression language was just not set on the process during parsing (only query language was).

        Show
        Matthieu Riou added a comment - The expression language was just not set on the process during parsing (only query language was).
        Matthieu Riou created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Matthieu Riou
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development