ODE
  1. ODE
  2. ODE-302

Use embedded TransactionManager if database mode is EMBEDDED or INTERNAL

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.3.6, 1.4
    • Component/s: JBI Integration
    • Labels:

      Description

      Ode should not use the TransactionManager provided by the JBI container in EMBEDDED and INTERNAL database modes since it creates its own DataSource which are not under the responsibility of the container's TransactionManager. This happened to work with ServiceMix since it uses the same TransactionManager (Geronimo's), but it's not something we can assume in other JBI environments.

      1. ODE302.patch.txt
        3 kB
        Alex Boisvert

        Activity

        aillet added a comment -

        I have patched ODE-1.2 with the previous patch and try to deploy the new ODE zip on PETALS JBI implementation .
        Unfortunatly the patch seems not good.
        I have a runtime exception at deployment time when ODE starts the BPEL Engine (see below) :

        10:26:03,046 ERROR SimpleScheduler:289 - Error retrieving node list.
        org.apache.ode.bpel.iapi.ContextException: Internal Error, could not begin transaction.
        at org.apache.ode.scheduler.simple.SimpleScheduler.execTransaction(SimpleScheduler.java:170)
        at org.apache.ode.scheduler.simple.SimpleScheduler.start(SimpleScheduler.java:280)
        at org.apache.ode.bpel.engine.BpelServerImpl.start(BpelServerImpl.java:137)
        at org.apache.ode.jbi.OdeLifeCycle.start(OdeLifeCycle.java:370)
        at org.ow2.petals.container.thread.ComponentLifeCycleThread.doTask(ComponentLifeCycleThread.java:104)
        at org.ow2.petals.container.thread.AbstractThread.run(AbstractThread.java:106)
        Caused by: java.lang.NullPointerException
        at org.apache.ode.scheduler.simple.SimpleScheduler.execTransaction(SimpleScheduler.java:167)
        ... 5 more
        10:26:03,046 ERROR OdeLifeCycle:373 - ODE BPEL Server failed to start.org.apache.ode.bpel.iapi.ContextException: Error retrieving node list.
        at org.apache.ode.scheduler.simple.SimpleScheduler.start(SimpleScheduler.java:290)
        at org.apache.ode.bpel.engine.BpelServerImpl.start(BpelServerImpl.java:137)
        at org.apache.ode.jbi.OdeLifeCycle.start(OdeLifeCycle.java:370)
        at org.ow2.petals.container.thread.ComponentLifeCycleThread.doTask(ComponentLifeCycleThread.java:104)
        at org.ow2.petals.container.thread.AbstractThread.run(AbstractThread.java:106)
        Caused by: org.apache.ode.bpel.iapi.ContextException: Internal Error, could notbegin transaction.
        at org.apache.ode.scheduler.simple.SimpleScheduler.execTransaction(SimpleScheduler.java:170)
        at org.apache.ode.scheduler.simple.SimpleScheduler.start(SimpleScheduler.java:280)
        ... 4 more
        Caused by: java.lang.NullPointerException
        at org.apache.ode.scheduler.simple.SimpleScheduler.execTransaction(SimpleScheduler.java:167)
        ... 5 more
        [petals.Container] [Installer_OdeBpelEngine] -CALL - LifeCycleAbstract.stateChanged()
        [petals.Container] [Installer_OdeBpelEngine] -CALL - LifeCycleAbstract.stateChangeFailed()
        [petals.Autoloader] Error occured during auto installation.
        javax.management.MBeanException
        at mx4j.server.ReflectionMBeanInvoker.doInvoke(ReflectionMBeanInvoker.java:135)
        at mx4j.server.ReflectionMBeanInvoker.invoke(ReflectionMBeanInvoker.java:52)
        at mx4j.server.interceptor.InvokerMBeanServerInterceptor.invoke(InvokerMBeanServerInterceptor.java:238)
        at mx4j.server.interceptor.DefaultMBeanServerInterceptor.invoke(DefaultMBeanServerInterceptor.java:120)
        at mx4j.server.interceptor.SecurityMBeanServerInterceptor.invoke(SecurityMBeanServerInterceptor.java:84)
        at mx4j.server.interceptor.DefaultMBeanServerInterceptor.invoke(DefaultMBeanServerInterceptor.java:120)
        at mx4j.server.interceptor.DefaultMBeanServerInterceptor.invoke(DefaultMBeanServerInterceptor.java:120)
        at mx4j.server.interceptor.ContextClassLoaderMBeanServerInterceptor.invoke(ContextClassLoaderMBeanServerInterceptor.java:203)
        at mx4j.server.MX4JMBeanServer.invoke(MX4JMBeanServer.java:1043)
        at org.ow2.petals.jbi.management.autoload.AutoLoaderServiceImpl.performInstall(AutoLoaderServiceImpl.java:455)
        at org.ow2.petals.jbi.management.autoload.AutoLoaderServiceImpl.install(AutoLoaderServiceImpl.java:232)
        at org.ow2.petals.jbi.management.autoload.InstallDirectoryScanner.run(InstallDirectoryScanner.java:56)
        at java.util.TimerThread.mainLoop(Timer.java:512)
        at java.util.TimerThread.run(Timer.java:462)
        Caused by: javax.jbi.JBIException: An exception occured during the start.
        at org.ow2.petals.container.lifecycle.LifeCycleAbstract.start(LifeCycleAbstract.java:289)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at mx4j.server.ReflectionMBeanInvoker.invokeImpl(ReflectionMBeanInvoker.java:156)
        at mx4j.server.ReflectionMBeanInvoker.doInvoke(ReflectionMBeanInvoker.java:117)
        ... 13 more
        Caused by: javax.jbi.JBIException: Life cycle exception on START
        at org.ow2.petals.container.thread.ComponentLifeCycleThread.doTask(ComponentLifeCycleThread.java:120)
        at org.ow2.petals.container.thread.AbstractThread.run(AbstractThread.java:106)
        Caused by: javax.jbi.JBIException: ODE BPEL Server failed to start.
        at org.apache.ode.jbi.OdeLifeCycle.start(OdeLifeCycle.java:374)
        at org.ow2.petals.container.thread.ComponentLifeCycleThread.doTask(ComponentLifeCycleThread.java:104)
        ... 1 more
        Caused by: org.apache.ode.bpel.iapi.ContextException: Error retrieving node list.
        at org.apache.ode.scheduler.simple.SimpleScheduler.start(SimpleScheduler.java:290)
        at org.apache.ode.bpel.engine.BpelServerImpl.start(BpelServerImpl.java:137)
        at org.apache.ode.jbi.OdeLifeCycle.start(OdeLifeCycle.java:370)
        ... 2 more
        Caused by: org.apache.ode.bpel.iapi.ContextException: Internal Error, could notbegin transaction.
        at org.apache.ode.scheduler.simple.SimpleScheduler.execTransaction(SimpleScheduler.java:170)
        at org.apache.ode.scheduler.simple.SimpleScheduler.start(SimpleScheduler.java:280)
        ... 4 more
        Caused by: java.lang.NullPointerException
        at org.apache.ode.scheduler.simple.SimpleScheduler.execTransaction(SimpleScheduler.java:167)

        Richard.

        Mateusz Nowakowski added a comment -

        For these people who use Fuse/Servicemix (probably PETALS too) with ODE JBI 1.2 distribution and have problems with ODE database.

        ODE binding component contains Derby database bundled into zip file, and this database is extracted while deploying ODE into ServiceMix.

        So the easiest working solution is to add JNDI entry (jndi.xml) with unzipped database path:
        <util:map id="jndiEntries">
        (...)
        <entry key="java:comp/env/jdbc/ode">
        <bean class="org.apache.derby.jdbc.EmbeddedDataSource">
        <property name="databaseName" value="../smx/components/OdeBpelEngine/version_1/jpadb"/>
        <property name="createDatabase" value="create"/>
        <property name="user" value="sa"/>
        </bean>
        </entry>
        (...)
        </util:map>

        and make sure that
        ode-jbi.properties has such lines:

        ode-jbi.db.mode=EXTERNAL
        (...)
        ode-jbi.db.ext.dataSource=java:comp/env/jdbc/ode

        (embedded and internal database entries should be commented)


        Regards
        Mateusz Nowakowski

        Michael Smith added a comment -

        Just FYI, this issue (TransactionManager is not recoverable) still exists in 1.4-snapshot (trunk) running under ServiceMix 4.4 with INTERNAL database mode.

        I ported the patch attached to this bug and get the following trace:

        [code]
        2011-08-14 23:44:33,573 DEBUG [ODE Extender:Start:com.xxx.biz-engine] (BpelProcess.java:994) - Creating new process DAO for

        {urn:xxx:201106:business:bpel}

        BusinessProcess-0 (guid=trnr1ec1w78hmne3uk5nq4chgaj6lw1e)...
        2011-08-14 23:44:33,573 ERROR [ODE Extender:Start:com.xxx.biz-engine] (BpelDAOConnectionImpl.java:132) - DbError
        org.hibernate.HibernateException: Unable to locate current JTA transaction
        at org.hibernate.context.JTASessionContext.currentSession(JTASessionContext.java:61)[226:wrap_mvn_org.hibernate_hibernate_3.2.5.ga:0]
        at org.hibernate.impl.SessionFactoryImpl.getCurrentSession(SessionFactoryImpl.java:544)[226:wrap_mvn_org.hibernate_hibernate_3.2.5.ga:0]
        at org.apache.ode.daohib.SessionManager.getSession(SessionManager.java:104)[247:org.apache.ode.ode-jbi-bundle:1.4.0.SNAPSHOT]
        at org.apache.ode.daohib.bpel.BpelDAOConnectionImpl.getSession(BpelDAOConnectionImpl.java:89)[247:org.apache.ode.ode-jbi-bundle:1.4.0.SNAPSHOT]
        at org.apache.ode.daohib.bpel.BpelDAOConnectionImpl.getProcess(BpelDAOConnectionImpl.java:126)[247:org.apache.ode.ode-jbi-bundle:1.4.0.SNAPSHOT]
        at org.apache.ode.bpel.engine.BpelProcess.createProcessDAO(BpelProcess.java:1006)[247:org.apache.ode.ode-jbi-bundle:1.4.0.SNAPSHOT]
        at org.apache.ode.bpel.engine.BpelProcess.bounceProcessDAOInDB(BpelProcess.java:995)[247:org.apache.ode.ode-jbi-bundle:1.4.0.SNAPSHOT]
        at org.apache.ode.bpel.engine.BpelProcess.access$1700(BpelProcess.java:97)[247:org.apache.ode.ode-jbi-bundle:1.4.0.SNAPSHOT]
        at org.apache.ode.bpel.engine.BpelProcess$HydrationLatch$3.call(BpelProcess.java:975)[247:org.apache.ode.ode-jbi-bundle:1.4.0.SNAPSHOT]
        at org.apache.ode.scheduler.simple.SimpleScheduler.execTransaction(SimpleScheduler.java:286)[247:org.apache.ode.ode-jbi-bundle:1.4.0.SNAPSHOT]
        at org.apache.ode.scheduler.simple.SimpleScheduler.execTransaction(SimpleScheduler.java:241)[247:org.apache.ode.ode-jbi-bundle:1.4.0.SNAPSHOT]
        at org.apache.ode.bpel.engine.BpelProcess$HydrationLatch.doHydrate(BpelProcess.java:973)[247:org.apache.ode.ode-jbi-bundle:1.4.0.SNAPSHOT]
        at org.apache.ode.bpel.engine.BpelProcess$HydrationLatch.access$200(BpelProcess.java:836)[247:org.apache.ode.ode-jbi-bundle:1.4.0.SNAPSHOT]
        at org.apache.ode.bpel.engine.BpelProcess$HydrationLatch$2.run(BpelProcess.java:846)[247:org.apache.ode.ode-jbi-bundle:1.4.0.SNAPSHOT]
        at org.apache.ode.bpel.engine.NStateLatch.latch(NStateLatch.java:89)[247:org.apache.ode.ode-jbi-bundle:1.4.0.SNAPSHOT]
        at org.apache.ode.bpel.engine.BpelProcess.hydrate(BpelProcess.java:747)[247:org.apache.ode.ode-jbi-bundle:1.4.0.SNAPSHOT]
        at org.apache.ode.bpel.engine.BpelServerImpl.register(BpelServerImpl.java:324)[247:org.apache.ode.ode-jbi-bundle:1.4.0.SNAPSHOT]
        at org.apache.ode.jbi.OdeServiceUnit.start(OdeServiceUnit.java:118)[247:org.apache.ode.ode-jbi-bundle:1.4.0.SNAPSHOT]
        at org.apache.ode.jbi.OdeSUManager.start(OdeSUManager.java:118)[247:org.apache.ode.ode-jbi-bundle:1.4.0.SNAPSHOT]
        at org.apache.ode.jbi.osgi.deployer.OdeDeployedBundle.deploy(OdeDeployedBundle.java:158)[247:org.apache.ode.ode-jbi-bundle:1.4.0.SNAPSHOT]
        at org.apache.ode.jbi.osgi.deployer.OdeDeployedBundle.doStart(OdeDeployedBundle.java:92)[247:org.apache.ode.ode-jbi-bundle:1.4.0.SNAPSHOT]
        at org.apache.ode.jbi.osgi.deployer.OdeExtenderImpl$Start.perform(OdeExtenderImpl.java:240)[247:org.apache.ode.ode-jbi-bundle:1.4.0.SNAPSHOT]
        at org.apache.ode.jbi.osgi.deployer.OdeExtenderImpl$OperationClosure.run(OdeExtenderImpl.java:222)[247:org.apache.ode.ode-jbi-bundle:1.4.0.SNAPSHOT]
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)[:1.6.0_26]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)[:1.6.0_26]
        at java.lang.Thread.run(Thread.java:662)[:1.6.0_26]
        [/code]

        Hudson added a comment -

        UNSTABLE: Integrated in ODE-1.x #399 (See https://builds.apache.org/job/ODE-1.x/399/)
        fixing ODE-302 (vanto: rev 570ce78d56de8413df25024076073d6906be778b)

        • Rakefile
        • jbi/src/main/java/org/apache/ode/jbi/OdeContext.java
        • jbi/src/main/java/org/apache/ode/jbi/OdeLifeCycle.java
        Tammo van Lessen added a comment -

        fixed in 1.3.6 and trunk

        Hudson added a comment -

        FAILURE: Integrated in ODE-1.x #400 (See https://builds.apache.org/job/ODE-1.x/400/)
        fixing a bug in the fix for ODE-302. (vanto: rev 74d7ffb76130906d8c050579f8413f9ff0985647)

        • jbi/src/main/java/org/apache/ode/jbi/OdeContext.java
        Hudson added a comment -

        SUCCESS: Integrated in ODE-trunk-jdk6 #733 (See https://builds.apache.org/job/ODE-trunk-jdk6/733/)
        fixing ODE-302 (vanto: rev 558b2c67ab45dd39e9da982cb9cb3cc32debabbc)

        • jbi/src/main/java/org/apache/ode/jbi/OdeLifeCycle.java
        • jbi/src/main/java/org/apache/ode/jbi/OdeContext.java
        • Rakefile
          fixing a bug for ODE-302 (vanto: rev 19854fb90bc4393ca179099de185a91ec70998e9)
        • jbi/src/main/java/org/apache/ode/jbi/OdeContext.java
        Hudson added a comment -

        FAILURE: Integrated in ODE-1.x #411 (See https://builds.apache.org/job/ODE-1.x/411/)


          People

          • Assignee:
            Tammo van Lessen
            Reporter:
            Alex Boisvert
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development